CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on Bottom Frame Addon (Old - Need to fix)

    Got it to work. Thanks all for the help.

    Posted in: WoW
  • 0

    posted a message on Bottom Frame Addon (Old - Need to fix)

    In reply to eSkiSo:

     No luck with that change. Still get an error.

     

    I replaced 

     

    local sep = CreateFrame("frame", nil, UIParent)

     

    with

     

    local sep = CreateFrame("frame", nil, UIParent, BackdropTemplateMixin and "BackdropTemplate");

     

     

    error code remains the same:

     

    1x BottomFrame\BottomFrame.lua:5: attempt to call method 'SetBackdrop' (a nil value)
    [string "@BottomFrame\BottomFrame.lua"]:5: in main chunk

    Locals:
    sep = <unnamed> {
    0 = <userdata>
    }
    (*temporary) = nil
    (*temporary) = <unnamed> {
    0 = <userdata>
    }
    (*temporary) = <table> {
    bgFile = "Interface/Tooltips/UI-Tooltip-Background"
    tileSize = 16
    edgeFile = "Interface/Tooltips/UI-Tooltip-Border"
    tile = true
    edgeSize = 16
    insets = <table> {
    }
    }
    (*temporary) = "attempt to call method 'SetBackdrop' (a nil value)"

    Posted in: WoW
  • 0

    posted a message on Bottom Frame Addon (Old - Need to fix)

    Hello,

     

    I'm recently starting to get back into WoW for this free play weekend and I was working on some addons that aren't working anymore. First one that I need help with is one that I have called BottomFrame. See my attached GUI from a few years ago. The large see-through frame on the bottom is what I'm referring to that won't work anymore. Does anyone have this mod? I can't seem to find it on the curse addons. I believe I got it from some forums years ago that someone made for themselves. I also added the .lua and .toc (the only files within the addons folder for BottomFrame). Please let me know if someone can help me get this thing to work again.

     

    Current error code: 

     

    Interface\AddOns\BottomFrame\BottomFrame.lua:5: attempt to call method 'SetBackdrop' (a nil value)
    [string "@Interface\AddOns\BottomFrame\BottomFrame.lua"]:5: in main chunk
    sep = <unnamed> {
    0 = <userdata>
    }
    (*temporary) = nil
    (*temporary) = <unnamed> {
    0 = <userdata>
    }
    (*temporary) = <table> {
    bgFile = "Interface/Tooltips/UI-Tooltip-Background"
    tileSize = 16
    edgeFile = "Interface/Tooltips/UI-Tooltip-Border"
    tile = true
    edgeSize = 16
    insets = <table> {
    }
    }
    (*temporary) = "attempt to call method 'SetBackdrop' (a nil value)"

    Posted in: WoW
  • To post a comment, please or register a new account.