• 0

    posted a message on GatherMate: Offical Thread
    Mapster and Gathermate don't seem to play nice for me anymore.

    No errors, just nothing shows up on the minimap or world map anymore.

    Thoughts?
    Posted in: General AddOns
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    Could someone identify the module that puts the huge list of names into my chat window when i'm trying to tab through my whisper reply targets (/r then hit tab)?
    Posted in: General AddOns
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    Is there any way to show the arrow buttons on only one frame?

    I only need them on my main chat frame, but I can't seem to find a per-frame setting (used to be able to in prat 2) >_<
    Posted in: General AddOns
  • 0

    posted a message on Baggins - Official Thread
    Not sure what's going on, but the latest version of baggins refuses to sort by periodic table set for some things, but not others.

    I have a bag set up for herbs, but everything keeps getting dumped into my main bag.

    This might have something to do with me moving back to not using external libraries, but seeing how some things still work (food, bandages, etc.) I'm not so sure.

    A quick look into the copy of periodic table located in baggins shows that herbs are infact listed (testing with peacebloom item:2447), yet it does not show up in my herbalism bag (category is just PTSet:Tradeskill.Gather.Herbalism).

    Any ideas?

    edit:
    For the record it was working just fine until I updated it today (was previously using the oct 15th release)

    edit 2:
    Appears to also have a problem with netherweave (id:21877) and the set PTSet:Tradeskill.Mat
    Posted in: General AddOns
  • 0

    posted a message on GatherMate: Offical Thread
    Small oddity with gathermate's display (live verison, latest release). For some reason whenever the world map is open (and sometimes when i'm on a taxi), the minimap gathermate textures stop updating until the map is closed, or in the case of the flypoint taxi is opened and closed.

    Not really a huge issue, but something that is a small annoyance.
    Posted in: General AddOns
  • 0

    posted a message on PeriodicTable-3.1
    Mark of Thrallmar (24581) as well as all 3 scourgestones (12840, 12841, 12843) are missing from Misc.Currency

    I believe they'd go under Misc.Currency.World no?

    [edit]
    I suppose a case can be made that the scourgestones aren't currency, but the mark of thrallmar certainly is (alliance one is there but the horde one isn't) XD
    Posted in: Libraries
  • 0

    posted a message on Parrot 1.0 Beta for the 2.4 combat log
    as of the latest revision mend pet has suddenly become a normal heal again (ie it shows up under all 4 heal over time filters (incoming pet, outgoing pet, incoming heal over time, and outgoing heal over time). Would greatly appreciate it being set back to only show up on the pet filters.
    Posted in: General AddOns
  • 0

    posted a message on How to turn OFF the ~ AGGRO ~ message in Omen?
    Omen Settings window -> Modules -> Single Target Mode -> Warnings -> Uncheck "enable warning message"

    Or if you want to disable it completely (all text based warnings), you can go Omen settings window -> Output -> Check "None"
    Posted in: AddOn HELP!
  • 0

    posted a message on Gatherer & Icon
    try /nsb off
    Posted in: AddOn HELP!
  • 0

    posted a message on TabletLib causing addon mem increase rate 60K/sec
    Quote from sylvanaar »


    Well, since the fubar plugin was loaded on demand, its likely that it didnt run its initialization code right away, i think if you delay doing setup code, the api's may get confused, and show that number as "since last gc". This happens with Prat's modules if they are loaded on demand through a call to LoadAddon.
    Right, but why would this suddenly cause a problem? Like I said before, it's not that it's using the memory that bothers me, it's that it WASN'T doing it 3 weeks ago.
    Posted in: AddOn HELP!
  • 0

    posted a message on TabletLib causing addon mem increase rate 60K/sec
    Quote from sylvanaar »

    What is your number of addons set to? Mine was set to the maximum number for some reason.
    Number shown? 30 in the screenshot, normally it's set to 5.
    Posted in: AddOn HELP!
  • 0

    posted a message on TabletLib causing addon mem increase rate 60K/sec
    Quote from sylvanaar »

    There is some amount that you can't really GC away, for example if you cause a LoD addon to be loaded, you are billed for the amount of memory that its main chunk uses when it executes. The only way to lose that number is to allow the lod addon to be gc'd away.
    Ya that makes sense, but I still can't shake the feeling that it wasn't this bad before >_< Maybe something else is causing it, and I'm just noticing performancefu instead of it. Though I can't really think of what, other than libdogtag... Maybe I'll look into that.

    edit:
    For the record, I'm not obsessing because it's using ram, that's what addons do. I'm obsessing cause something is using ram that wasn't doing it before XD
    Posted in: AddOn HELP!
  • 0

    posted a message on TabletLib causing addon mem increase rate 60K/sec
    Quote from Xinhuan »

    Yes it does. PerformanceFu does a lot of string concatenation and string conversions, generating *a lot* of string garbage, especially with changing numbers every second. Every text you see in the Tablet is a string, and there's a whole bunch you don't see too.

    Something like
    "FuBar (12)" is really "FuBar".."("..number..")"
    resulting in the following 4 strings created:
    "Fubar ("
    "12"
    "Fubar (12"
    "Fubar (12)"
    in addition to "(" and ")" and "FuBar" already existing. And since everything in WoW's Lua has a tainted flag attached to it, that's even more memory used per string/number/table/etc.
    That makes more sense, but it's odd that I don't remember it generating that much garbage in the past >_< Also, I'm monitoring the kb/s on fubar without the tooltip open as well, and it's still between 10-20kb/s, which shouldn't be the case if tabletlib is indeed the cause of the increasing rate (unless tabletlib is doing the work even if the tooltip isn't visible?)

    Quote from sylvanaar »

    Is your tablet detached?

    Detached from fubar? no, the tooltip is anchored to the performancefu icon.
    Posted in: AddOn HELP!
  • 0

    posted a message on TabletLib causing addon mem increase rate 60K/sec
    Quote from sylvanaar »

    It could just as easily be a change in the system those addons run in.

    Metrognome, thats still around? It looks pretty busy, and so does librocktimer, those 2 do similar things - run code on a timer - what is using them. Metrognome especially.
    Right, but 20kb increase over the course of 45 seconds doesn't amount to a 30kb/s increasing rate.

    Metrognome is still a dependency of archud2 (and the only reason I keep the library around), and I've yet to find another hud addon that I like. It shouldn't be the one causing the problem because neither archud2, or metrognome has been updated recently at ALL (yet the problem is recent within a few weeks)

    I still think it's performancefu... Does a tablet table really generate 57kb of memory in the span of 10 seconds of having the tooltip open without cpu profiling on? I literally forced a GC then opened the tooltip and immediately counted to 10. Cause I don't remember that happening before at all.

    edit:
    Though I do have to say the increasing rate seems to be down by about 10-15kb/s after the recent performancefu update. I just updated and where I was 20-40kb/s this morning, after the update I'm between 10-20 now. Whether that's related or not, who knows, but it seemed to help.
    Posted in: AddOn HELP!
  • 0

    posted a message on TabletLib causing addon mem increase rate 60K/sec
    Quote from sylvanaar »

    I thought everyone understood that performancefu's tooltip uses TabletLib, so the more you look at it the more cpu tabletlib (or whatever addon tabletlib is embedded in) uses.

    Its one of those things, you are changing the behavior of the system through your attempts to measure it.

    Let me explain: You measure cpu use, then you display cpu use, this then uses more cpu, so you have to change the cpu use number you are displaying, which in turn uses more cpu...

    Simply put, anything which has to do work to show you the performance numbers should be excluded from those numbers.
    And I don't think you grasped what we were saying. I'm aware that they increase when the tooltip is open, the issue is that they're doing it when it's not.

    I'm IDLING around 20-30kb/s increasing rate WITHOUT the tooltip open. I was NOT idling that high 2-3 weeks ago (used to be between 0 and 5).

    The fact that performancefu/tabletlib exert additional memory when the tooltip is active is irrelevant unless the change to a tablet frame was RECENT. It's my understanding that this is not the case, and as such something ELSE has changed to cause the increase in rate. The ONLY things reporting ANY change in memory usage on my system are Tabletlib, Performancefu, and libdogtag. EVERYTHING else is either not increasing at all while idle, or increasing by 1-10kib TOTAL between garbage collects, which does not explain the 20kib per second increase in memory usage. The three addons I listed above are increasing by 50-150kib between garbage collects, and such the only likely culprits (outside of a blizzard addon, but I can't see why one would suddenly change without being patched).

    This was NOT the behavior of the addons 3 weeks ago. I think I would have noticed performancefu and tabletlib jumping to the top of my list every time I hovered over the tooltip.

    What I'm getting at is nothing else is exhibiting any behavior that would account for the increase in memory, except for the addons I listed.

    If it's not performancefu, and it's not tabletlib, then it has to be libdogtag, but that hasn't been updated recently to my knowledge. As you can see in the attached screenshot nothing else could account for that much of an increasing rate.
    Posted in: AddOn HELP!
  • To post a comment, please or register a new account.