• 0

    posted a message on Skinner

    beta7.25497.2

    hi , unitframe still gives error,  slightly different code line numbers. same method: fresh install,  unit frames,  move opacity slider.

     

    Message: Interface\AddOns\Skinner\Modules\UnitFrames.lua:441: attempt to index field 'sf' (a nil value)
    Time: 11/19/17 14:16:18
    Count: 1
    Stack: Interface\AddOns\Skinner\Modules\UnitFrames.lua:441: attempt to index field 'sf' (a nil value)
    (tail call): ?
    Interface\AddOns\Skinner\Modules\UnitFrames.lua:441: in function <Interface\AddOns\Skinner\Modules\UnitFrames.lua:418>
    Interface\AddOns\Skinner\Modules\UnitFrames.lua:523: in function 'adjustUnitFrames'
    Interface\AddOns\Skinner\Modules\UnitFrames.lua:538: in function <Interface\AddOns\Skinner\Modules\UnitFrames.lua:535>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
    (tail call): ?
    ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:818: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:639>
    ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:870: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:858>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[3]"]:9: in function <[string "safecall Dispatcher[3]"]:5>
    (tail call): ?
    ...erface\AddOns\Skinner\Libs\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire'
    ...nner\Libs\AceGUI-3.0\widgets\AceGUIWidget-Slider.lua:70: in function <...nner\Libs\AceGUI-3.0\widgets\AceGUIWidget-Slider.lua:60>

    Locals: <none>

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Right,  found another.

    fresh install  addon/wtf delete. 

    menu / interface / skinner / Profiles   choose and existing one (i choose the class one here), or create a new profile

    also the text on the popup window seems to have low strata (pic included now)

     

    Message: Interface\AddOns\Skinner\Skinner.lua:751: attempt to index field 'Gradient' (a nil value)
    Time: 11/16/17 10:40:57
    Count: 1
    Stack: Interface\AddOns\Skinner\Skinner.lua:751: attempt to index field 'Gradient' (a nil value)
    [C]: ?
    Interface\AddOns\Skinner\Skinner.lua:751: in function `applyGradient'
    Interface\AddOns\Skinner\Skinner.lua:918: in function <Interface\AddOns\Skinner\Skinner.lua:847>
    Interface\AddOns\Skinner\Skinner.lua:943: in function `applySkin'
    Interface\AddOns\Skinner\Skinner.lua:674: in function <Interface\AddOns\Skinner\Skinner.lua:588>
    (tail call): ?
    Interface\AddOns\Skinner\UIFrames.lua:4283: in function <Interface\AddOns\Skinner\UIFrames.lua:4274>
    (tail call): ?
    [C]: ?
    [C]: in function `Show'
    Interface\FrameXML\StaticPopup.lua:4187: in function `StaticPopup_Show'
    Interface\AddOns\Skinner\Skinner.lua:424: in function <Interface\AddOns\Skinner\Skinner.lua:424>
    ...
    [string "safecall Dispatcher[3]"]:9: in function <[string "safecall Dispatcher[3]"]:5>
    (tail call): ?
    ...erface\AddOns\Skinner\Libs\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire'
    ...er\Libs\AceGUI-3.0\widgets\AceGUIWidget-DropDown.lua:442: in function <...er\Libs\AceGUI-3.0\widgets\AceGUIWidget-DropDown.lua:433>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[3]"]:9: in function <[string "safecall Dispatcher[3]"]:5>
    (tail call): ?
    ...erface\AddOns\Skinner\Libs\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire'
    ...s\AceGUI-3.0\widgets\AceGUIWidget-DropDown-Items.lua:351: in function <...s\AceGUI-3.0\widgets\AceGUIWidget-DropDown-Items.lua:341>

    Locals:

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Oh thanks,  it seems i can not reproduce error A or B anymore with the new build.

    only the last one now:  fresh wow , install beta7.25497.1 go into menu / interface / skinner / modules / Unit frames tab / use unitframe Background opacity slider ,   throws an error.

    I do not use it, so i don't mind,  but thought still should report it.

     

    Message: Interface\AddOns\Skinner\Modules\UnitFrames.lua:427: attempt to index field 'sf' (a nil value)
    Time: 11/16/17 08:18:04
    Count: 1
    Stack: Interface\AddOns\Skinner\Modules\UnitFrames.lua:427: attempt to index field 'sf' (a nil value)
    (tail call): ?
    Interface\AddOns\Skinner\Modules\UnitFrames.lua:427: in function <Interface\AddOns\Skinner\Modules\UnitFrames.lua:420>
    Interface\AddOns\Skinner\Modules\UnitFrames.lua:523: in function `adjustUnitFrames'
    Interface\AddOns\Skinner\Modules\UnitFrames.lua:538: in function <Interface\AddOns\Skinner\Modules\UnitFrames.lua:535>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
    (tail call): ?
    ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:818: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:639>
    ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:870: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:858>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[3]"]:9: in function <[string "safecall Dispatcher[3]"]:5>
    (tail call): ?
    ...erface\AddOns\Skinner\Libs\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire'
    ...nner\Libs\AceGUI-3.0\widgets\AceGUIWidget-Slider.lua:70: in function <...nner\Libs\AceGUI-3.0\widgets\AceGUIWidget-Slider.lua:60>
    [C]: in function `SetValue'
    ...nner\Libs\AceGUI-3.0\widgets\AceGUIWidget-Slider.lua:112: in function <...nner\Libs\AceGUI-3.0\widgets\AceGUIWidget-Slider.lua:100>

    Locals: <none>

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    In reply to Jncl:

    Hello

    beta7.25383.4  according to curse.

    If i have both button borders & check buttons enabled,   i cannot reproduce error "B"

    error "A" is on toy/heirloom/appearance panes,  for me basically those that have multiple pages, with those left/right paging arrow icons.

     

    also if i enable in modules / unit frames / player  and use the background opacity slider,   i get 

    (update:  don't have to enable player unit frames in modul, just use the slider)

     

    Message: Interface\AddOns\Skinner\Modules\UnitFrames.lua:424: attempt to index field '?' (a nil value)
    Time: 11/14/17 14:27:31
    Count: 2
    Stack: Interface\AddOns\Skinner\Modules\UnitFrames.lua:424: attempt to index field '?' (a nil value)
    (tail call): ?
    Interface\AddOns\Skinner\Modules\UnitFrames.lua:424: in function <Interface\AddOns\Skinner\Modules\UnitFrames.lua:421>
    Interface\AddOns\Skinner\Modules\UnitFrames.lua:518: in function `adjustUnitFrames'
    Interface\AddOns\Skinner\Modules\UnitFrames.lua:533: in function <Interface\AddOns\Skinner\Modules\UnitFrames.lua:530>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
    (tail call): ?
    ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:818: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:639>
    ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:870: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:858>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[3]"]:9: in function <[string "safecall Dispatcher[3]"]:5>
    (tail call): ?
    ...erface\AddOns\Skinner\Libs\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire'
    ...nner\Libs\AceGUI-3.0\widgets\AceGUIWidget-Slider.lua:70: in function <...nner\Libs\AceGUI-3.0\widgets\AceGUIWidget-Slider.lua:60>

    Locals: <none>

     
    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Fresh wow install, no other addons installed.

    Modules: UI Buttons enabled,  gives nice ui buttons.

    Button borders enabled, then going to the blizzard toy / heirloom / appearances  gives error "A".

    Enabling check buttons, then clicking on interface/addons/skinner submenus gives error "B"

    (reloads included) 

     

    "A"

     

    Message: Interface\AddOns\Skinner\PlayerFrames.lua:847: attempt to call global 'skinPageBtns' (a nil value)
    Time: 11/13/17 23:12:30
    Count: 2
    Stack: Interface\AddOns\Skinner\PlayerFrames.lua:847: attempt to call global 'skinPageBtns' (a nil value)
    [C]: in function `skinPageBtns'
    Interface\AddOns\Skinner\PlayerFrames.lua:847: in function <Interface\AddOns\Skinner\PlayerFrames.lua:828>
    (tail call): ?
    [C]: ?
    [C]: in function `SetShown'
    ...AddOns\Blizzard_Collections\Blizzard_Collections.lua:52: in function `CollectionsJournal_UpdateSelectedTab'
    ...AddOns\Blizzard_Collections\Blizzard_Collections.lua:7: in function `CollectionsJournal_SetTab'
    [string "*:OnClick"]:1: in function <[string "*:OnClick"]:1>

    Locals:

     

    "B"

     

    Message: Interface\AddOns\Skinner\AddonSkins\Ace3.lua:148: <unnamed>:SetParent(): Cannot set a 'nil' parent for fonts or textures
    Time: 11/13/17 23:20:30
    Count: 7
    Stack: Interface\AddOns\Skinner\AddonSkins\Ace3.lua:148: <unnamed>:SetParent(): Cannot set a 'nil' parent for fonts or textures
    [C]: ?
    [C]: in function `SetParent'
    Interface\AddOns\Skinner\AddonSkins\Ace3.lua:148: in function <Interface\AddOns\Skinner\AddonSkins\Ace3.lua:141>
    (tail call): ?
    [C]: in function `SetType'
    ...ns\Ace3\AceGUI-3.0\widgets\AceGUIWidget-CheckBox.lua:78: in function `OnAcquire'
    Interface\AddOns\Ace3\AceGUI-3.0\AceGUI-3.0.lua:190: in function `Create'
    Interface\AddOns\Skinner\AddonSkins\Ace3.lua:394: in function <Interface\AddOns\Skinner\AddonSkins\Ace3.lua:393>
    (tail call): ?
    ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1162: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1075>
    ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1608: in function `FeedGroup'
    ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1888: in function `Open'
    ...
    [C]: ?
    [string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
    (tail call): ?
    Interface\AddOns\Ace3\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire'
    ...GUI-3.0\widgets\AceGUIContainer-BlizOptionsGroup.lua:20: in function <...GUI-3.0\widgets\AceGUIContainer-BlizOptionsGroup.lua:19>
    [C]: in function `Show'
    Interface\FrameXML\InterfaceOptionsFrame.lua:28: in function <Interface\FrameXML\InterfaceOptionsFrame.lua:17>
    [C]: in function `InterfaceOptionsList_DisplayPanel'
    Interface\FrameXML\InterfaceOptionsFrame.lua:46: in function `InterfaceOptionsListButton_OnClick'
    [string "*:OnClick"]:2: in function <[string "*:OnClick"]:1>

    Locals:

    Posted in: General AddOns
  • 0

    posted a message on BuffBroker: automatic friendly auras
    my refresh time is always 0.

    1.4.8. same as before

    1.4.10 ohhh

    solo: the correct buffs get applied. then it finishes. was playing with removing buffs and such, and couldnt find any error in buffing logic

    party: well it takes time to scan and suggest, but. did the buffs correctly. inner fire, then fortitude, then after few combat, the spirit. (had no pet in party this time)

    this was actually usable tonight :)
    Posted in: General AddOns
  • 0

    posted a message on BuffBroker: automatic friendly auras
    now with 1.4.4B :)
    solo: now it buffs me then it stucks at inner fire, recasting it over and over (if i disable inner fire, then small spirit over and over)

    party: inner fire over and over, despite nobody having fortitude or spirit on them. (but i can see the fortitude buff queue under the inner fire icon, just that inner fire comes back up almost instantly)
    manually buffing everyone , its still inner fire rebuff
    turning off inner fire as buff, it recasts fortitude or spirit (big one - chooses one after combat icon)

    basicly , tested it a few runs, i never saw it saying: hey everyone is buffed fine :)

    (and i like to buff shadow protection in party raids, maybe add later, its not as complicated as pally buffs , if someone dont have it, buff it ;) )

    ps: i just do some personal feedbacks, not whining, you do with them whatever you want, i still thank you for your effort in this addon
    Posted in: General AddOns
  • 0

    posted a message on BuffBroker: automatic friendly auras
    Some extra information would help me out; Is it suggesting greater or lesser spirit?
    -greater
    Are there other priests in the group?
    -no
    Does this happen when you're not in a party?
    -no it does nothing in solo (but just tried it standing in a city, not actual soloplaying. it says profiled players 0/1 and does absolutely nothing)
    What level is your priest?
    -80
    What version are you using?
    -1.4.3

    +there were pets in the party, i don't know how the addon handles their buff calculations (rebuffing greater, when at least 2 members missing it)
    and no, nobody clicking it off and not out of range

    ++ and i want to thank you for your work. do as much of it, as you feel its not a burden and have some fun too :)
    Posted in: General AddOns
  • 0

    posted a message on BuffBroker: automatic friendly auras
    very nice initiative.
    cannot really test it yet, because it seems to want to cast spirit over and over on the party on my priest account (properly configured)
    my 2 cent is that it should have a keybinding for the buffing (or i was just too dumb to find it)
    and it should have a preset spell for buffing in combat(self one is enough). like shamans want to rebuff their water shield many times during combat ( inner fire for priest, a shout for a warrior (shouts are short, and some fights are long))
    and i'm sure there is a lots of things still on the "to do" list, so keep up the good work man :D
    but i like this idea very much and i'll be keeping an eye on this now ;)
    Posted in: General AddOns
  • 0

    posted a message on sRaidFrames: Alternative CTRA raid frames
    mehh
    Arcane mages have the arcane blast spell which leaves a debuff on them, increasing spell damage and cost. It is magic, and can be dispelled, but we dont want to do that.
    I have been playing with blacklist/whitelist options and it hides the debuff icon from the raidframes, but not the red background coloring which indicates the dispellable debuff on players.
    am i the only one having this problem again?
    Posted in: Unit Frames
  • To post a comment, please or register a new account.