CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on When is it ok to fork a seemingly abandoned addon?

    Well, you could do what many other people do, and just write your own version of the addon. I am sure that you could improve upon it.

    Posted in: General Chat
  • 0

    posted a message on Prat Specific Setup Help

    PlayerNames - set coloring to None

     

    CustomFilters, configure a filter like so:

     

     

     You can modify the events that this filter applies to, and create others to do other things for other events, like different colors.

    Posted in: AddOn HELP!
  • 0.966420034149118

    posted a message on Prat 3.0 Chat Mod Framework

    In reply to Myrroddin:

     Due to spammers creating 10000+ issues with spam content. Issues were disabled by the admins.
    Posted in: General AddOns
  • 0

    posted a message on Prat 3.0 Chat Mod Framework

    The packager broke the addon, I had to make some emergency fixes in order to restore functionality. 

     

    Thanks for your support

    Posted in: General AddOns
  • 0.96220633299285

    posted a message on Prat update today reset all of my settings

    The addon packager completely messed up the localizations, breaking the addon. I had to scramble to implement a fix. Should all be ok now.

    Posted in: AddOn HELP!
  • 0

    posted a message on Big problem: Localization substitution syntax and other errors

    I had to completely redo my localization code in my addon to compensate for this. It was a major hassle. Now when you fix it, I will have to undo it. As for now, I cant update other addons with localizations, because I would have to re-engineer them too.

     

    What happened?

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    Quote from Ketho
    The WowAce file version ordering is a bit strange. It goes from 3.6.10 to 3.6.9-nolib to 3.6.11 to 3.6.9-nolib again
    So I used 3.6.11 which works fine on Legion Beta/PTR, but it sure was confusing at first
    http://i.imgur.com/GZqm9PQ.png

    I guess only a few people had this problem, since that 3.6.9-nolib is only an alpha and not on Curse

    Also can't seem to report bugs through the WowAce ticket tracker
    http://i.imgur.com/8vsz8mG.png


    It is some kind of bug in the packager. That version seems to be stuck up top.
    Posted in: General AddOns
  • 0

    posted a message on My Work on a Lua IDE
    No, it doesn't use the TOC file. I wanted it to be slightly generic, but I am always open to new committers that want to take on a challenge
    Posted in: Lua Code Discussion
  • 0

    posted a message on My Work on a Lua IDE
    Yes. It is possible. Your best bet is to open a ticket on the bitbucket tracker for this project. Or join #IDLua and pester me

    Even better bet would be to submit a patch - for the enhancement. But I recognize it is complicated. If you are intererested, and know Java, I can tell you what needs to be done
    Posted in: Lua Code Discussion
  • 0

    posted a message on Curse Client not detecting WoD beta
    Great tip Stan.

    I wish they would update the infrastructure (client, packager) to recognize wow beta.
    Posted in: Updaters
  • 0

    posted a message on WoD and repos:
    If you use a mercurial repository, you need to make sure that the TIP commit is always on your default branch.

    I recently created a WoD branch, and it was packaging and going to the curse client. I had to make a dummy commit on the default branch so that TIP pointed to it in order to fix the situation.
    Posted in: General Chat
  • 0

    posted a message on My Work on a Lua IDE
    I have been updating this, and it works much better these days.

    Check out the screencast:

    http://www.screencast.com/t/RJom4qlcBN

    Posted in: Lua Code Discussion
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    What version of wow do you see that error on?
    Posted in: General AddOns
  • 0

    posted a message on Functions in a local table
    Here is one thing that won't help.

    [PHP]cdFrame[rune]:SetScript("OnUpdate", function() cdTextUpdate(rune) end)[/PHP]

    You refer to the global function [FONT="Courier New"]cdTextUpdate [/FONT]but you declare it on the RIA table. You should probably just put the eventhandler back on the RIA table so you can refer to it via self or RIA since it looks like there will only ever be one RIA table anyways.

    [PHP]-- OnUpdate to count down RIA.cooldown counts
    function RIA:cdTextUpdate(rune)
    local start, duration, runeReady = GetRuneCooldown(rune)
    if (RIADB.cdtext == "1") then
    local apply, time = self:cooldownUpdate(rune, start, duration, runeReady)
    if (apply) then
    self:ccCount(rune, time)
    end
    end
    if (runeReady) then
    cdFrame[rune]:SetScript("OnUpdate", nil)
    end
    end[/PHP]
    Posted in: Lua Code Discussion
  • To post a comment, please or register a new account.