• 0

    posted a message on Packager issues
    It is unfortunately stuck giving assertion errors again.
    Posted in: General Chat
  • 0

    posted a message on Packager issues
    Looking at http://www.wowace.com/packager/, it seems like the packager is stuck in an infinite loop getting Assertion errors at the moment.
    Posted in: General Chat
  • 0

    posted a message on Sending addon message on login
    Thanks a lot for your fast response. I actually did it through he whisper channel in the minimal test example, so I suppose it counts for all addon channels.

    I just tried doing it on the first GUILD_ROSTER_UPDATE, but it seems like the channels still aren't ready by then. Seems like the only solution is adding a delay.
    Posted in: Lua Code Discussion
  • 0

    posted a message on Sending addon message on login
    Hello,

    I am working on my first addon, and am experiencing an frustrating issue. I was hoping someone could help me.

    The addon allows players to specify which bosses they need and this information is shared with the rest of the guild. This is then shown in a list for each player who uses the addon to review. To keep this information up to date, I want a player that logs in to receive the latest version of the information available. To do this, I simply send a message to the guild addon channel to request this when a player logs in.

    There is one issue however. When I do this in the ADDON_LOADED event on login, for some reason the message is never received by any recipients. The strange thing is, when I reload the ui instead of logging in, sending the request in the same event works fine. Also sending it later manually works. I've tried a few different events that are generated on logging in like PLAYER_LOGIN, but that doesn't help either.

    It seems like the communication channels take a while to be initialized when logging in the first time.

    I couldn't find anyone else having this issue. I am considering temporarily registering for the OnUpdate event to send the message with a delay, but that seems like an excessively complex way to solve this.

    Any thoughts on solving this problem? I've attached a minimal version of the addon that reproduces the problem. It sends a message to itself on ADDON_LOADED, and when that message is received it should send a message back. The message is never received however.

    Here is a pastebin link to the .lua file in case you prefer that:
    http://pastebin.com/zDR3QQqB
    Posted in: Lua Code Discussion
  • 0

    posted a message on Acheron - Death Reports [official thread]
    You can download them yourselves here:

    http://www.wowace.com/addons/ace3/
    Posted in: Raid AddOns
  • 0

    posted a message on Acheron - Death Reports [official thread]
    Ah thanks, updating the libs fixed it for me
    Posted in: Raid AddOns
  • 0

    posted a message on Acheron - Death Reports [official thread]
    It is working quite well still in 4.0.1, just having a few minor issues

    -I can't choose a name from the option screen, I have to target a person and open the acheron window with right click to see their death info. It only lists "Acheron" as a player.
    -I don't see text where the different deaths should be, I can select them though
    -Health percentage/value isn't showing the right number (very high percentage, 0 health)

    Great addon though
    Posted in: Raid AddOns
  • 0

    posted a message on Bartender4 - Official Topic
    Quote from Nevcairiel
    Get 4.4.11, should be fixed in there.


    Thank you, sorry for not noticing
    Posted in: General AddOns
  • 0

    posted a message on Bartender4 - Official Topic
    When using the call pet ability as a hunter (the one that pops up a little menu with all your active pets), I get the following error


    Message: Interface\FrameXML\ActionButton.lua:617: Usage: GetActionInfo(slot)
    Time: 10/13/10 20:01:41
    Count: 1
    Stack: [C]: in function `GetActionInfo'
    Interface\FrameXML\ActionButton.lua:617: in function `ActionButton_UpdateFlyout'
    Interface\FrameXML\SpellFlyout.lua:306: in function <Interface\FrameXML\SpellFlyout.lua:294>
    [C]: in function `Show'
    Interface\FrameXML\SpellFlyout.lua:287: in function `Toggle'
    Interface\FrameXML\SecureTemplates.lua:271: in function `handler'
    Interface\FrameXML\SecureTemplates.lua:540: in function <Interface\FrameXML\SecureTemplates.lua:488>
    
    Locals: (*temporary) = nil


    And the following when it hides

    Message: Interface\FrameXML\ActionButton.lua:617: Usage: GetActionInfo(slot)
    Time: 10/13/10 20:03:34
    Count: 2
    Stack: [C]: in function `GetActionInfo'
    Interface\FrameXML\ActionButton.lua:617: in function `ActionButton_UpdateFlyout'
    Interface\FrameXML\SpellFlyout.lua:325: in function <Interface\FrameXML\SpellFlyout.lua:310>
    [C]: in function `Hide'
    Interface\FrameXML\RestrictedFrames.lua:320: in function `Hide'
    [string "		if not newstate then return end..."]:9: in function <[string "		if not newstate then return end..."]:1>
    (tail call): ?
    [C]: ?
    Interface\FrameXML\RestrictedExecution.lua:441: in function <Interface\FrameXML\RestrictedExecution.lua:412>
    (tail call): ?
    Interface\FrameXML\SecureHandlers.lua:113: in function <Interface\FrameXML\SecureHandlers.lua:108>
    [C]: ?
    [C]: in function `SetAttribute'
    Interface\FrameXML\SecureStateDriver.lua:114: in function <Interface\FrameXML\SecureStateDriver.lua:95>
    Interface\FrameXML\SecureStateDriver.lua:127: in function <Interface\FrameXML\SecureStateDriver.lua:119>
    
    Locals: (*temporary) = nil
    
    Posted in: General AddOns
  • To post a comment, please or register a new account.