• 0

    posted a message on XPBarNone
    I'm currently upgrading the version of LibSharedMedia to 3.0. It might be broken since I've not tested it myself yet. If it is, it should be fixed within a few hours when I'm able to login to WoW.
    Posted in: AddOn HELP!
  • 0

    posted a message on NameToggleFu - Misplaced Menu
    Working fine for me in 2.4 too, the only thing that seems to need doing is for me to add the new toggles since Ackis already fixed the CVars :)
    Might get around to that later today.
    Posted in: FuBar AddOns
  • 0

    posted a message on XPBarNone
    Then files.wowace.com hasn't updated yet. The latest version is in the SVN and working fine.

    Revision: 66132
    Posted in: AddOn HELP!
  • 0

    posted a message on Help me fix these DogTag lines please!
    WTB [Assistance]
    [IsEnemy ? ~IsPlayer ? IsTapped ? Text(*):Gray][IsPlayer ? [IsFriend ? Name:ClassColor ! [IsEnemy ? [PvP ? Name:HostileColor ! Name:ClassColor] ] ] ! [~IsPlayerOrPet ? [Status ? Name:StatusColor ! Name:AggroColor] ] ][IsPet ? Name:ClassColor]
    
    [~IsPlayerOrPet ? Text(Level):DifficultyColor ! Text(Level):DifficultyColor] [~IsPlayerOrPet ? [IsMaxLevel ? Level:DifficultyColor ! Level:DifficultyColor] ! [IsPlayerOrPet ? Level:DifficultyColor] ] [IsEnemy ? Classification:Yellow ! Classification] [SmartRace] [PlayerClass:ClassColor] [DruidForm:Paren]
    
    [Guild?Text([Guild:IsEqual([Guild#player])?Fuchsia!Green][Guild])]
    
    [GuildNote:White]
    
    [IsEnemy ? Text(Hostile):HostileColor][IsFriend ? Text(Friendly):HostileColor]
    
    [~IsPlayer ? Status:StatusColor ! Status] [Zone]
    
    [Target ? Text(Targeting: ):Yellow]
    
    [ [IsPlayer || IsEnemy] ? PvP:Red]
    
    [IsPlayer ? Text(Talents: ):Yellow]
    
    -----
    
    [Realm:Bracket]
    
    [GuildRank:Yellow]
    
    [IsPlayer ? AFKDND]
    
    [IsPlayer#mouseovertarget ? [IsUnit#player(MouseOverTarget) ? Text(<<YOU>>):White ! Target:ClassColor#mouseovertarget] ! Target:White#mouseovertarget]
    
    [TalentSpec ? Text([TalentTree] ([TalentSpec]))]
    Posted in: AddOn HELP!
  • 0

    posted a message on XPBarNone
    It's fixed.
    Blizzard have changed something in :SetFrameLevel() which broke it.
    Posted in: AddOn HELP!
  • 0

    posted a message on FuBar TopScore
    I just checked out my alts Saved Variables and they seem show the same symptoms as the table posted above. Missing blank tables. I've deleted his SavedVariables, I expect that that will fix his issues. If it doesn't, I'll really try to hunt for a cause.
    Posted in: FuBar AddOns
  • 0

    posted a message on FPS and loading times
    Quote from HunterZ »

    WoW's graphics engine is now several years old

    Still runs like shit too. You'd get more bang for your buck if instead of buying that new graphics card, you went and bought a bat and wrapped it around the head of the guy responsible for the graphics engine in WoW.
    My hardware has been upgraded considerably since starting to play WoW all those years ago. I went to Molten Core the other day with 20 people, I still only got 15-20FPS.
    I don't think Molten Core has received anything new and fancy, so surely with a much better CPU and GPU than I had 3 years ago, I should have seen a big improvement going there with half the people.

    I think it actually ran at great speeds for a short while after TBC came out, then they added that "feature" where you could no longer target mobs behind walls.
    Posted in: General Chat
  • 0

    posted a message on Fubar_DPS
    Quote from Adynathor »

    AceAddon: AceOO-2.0: Library "Metrognome-2.0" does not exist.

    Install 'Metrognome' or make sure that the 'Metrognome-2.0' directory exists in the addons 'Libs' directory.
    Posted in: FuBar AddOns
  • 0

    posted a message on FuBar TopScore
    Quote from Kerecha »

    I have deleted my saved vars but after a few days the error comes back. (using latest build through WAU)

    In that case then, somebody else needs to come up with a reason why it's breaking. I'm tired of it, I didn't cause it and I'm (mostly) not bothered by it.

    Edit: Also, are you sure you've cleared out all of the SavedVariables? As well as the main saved variables file, there could be some Per Character saved variables lurking that might mess things up if you don't use the default profile on your characters.
    Posted in: FuBar AddOns
  • 0

    posted a message on FuBar TopScore
    Quote from mrbigtaco »

    ["Flame Shock"] = {
    ["normal"] = {
    ["target"] = "The Lurker Below",
    ["level"] = -1,
    ["class"] = "WARRIOR",
    ["amount"] = 761,
    },
    ["normalPvP"] = {
    ["target"] = "Karnivveros",
    ["level"] = 70,
    ["class"] = "WARRIOR",
    ["amount"] = 610,
    },
    },

    Looking at this and thinking about the error message and what that broken commit did, it seems very likely that that old commit is the cause of all of these messages.

    The broken commit registered a ton of defaults for everything which broke a part of the script which was supposed to create the various tables for the spell.
    Edit: Actually, I say it broke this code, it didn't. This code was still executed as it should have been, but the default empty tables weren't saved in the SavedVariables anymore, meaning after a reload of WoW, things would start to break.
    -- These checks start at line 452 in TopScoreFu.lua if you want to read the proper code.
    --<stuff to check for existance of a spell>
    --if self.db.char.hits[spell] == nil then
    --if spell_exists(spell) then
            self.db.char.hits[spell] = {
                crit = {},
                critPvP = {},
                normal = {},
                normalPvP = {},
                isHeal = isHeal,
            }
    --end
    --end

    Since your Flame Shock was probably created on the broken version, the crit tables don't exist because that version registered empty tables as a default values, and default values aren't saved.
    So, now in the proper working version, the bit of code isn't executed, because the 'self.db.char.hits[spell]' table already exists. And it SHOULD exist with all of the empty tables that are needed, but it doesn't because someone thought they could just change the default variables without knowing what was going on.

    So, in your case, I think you can fix the Flame Shock by adding entries like
    ["crit"] = {},
    ["critPvP"] = {},

    at the bottom of the table for the spell.
    Repeat as necessary for any other broken spells for whatever tables they happen to be missing.

    The easiest fix of course is to just delete your entire saved variables.
    Posted in: FuBar AddOns
  • 0

    posted a message on FuBar TopScore
    Quote from mrbigtaco »

    I have not tested this thoroughly, but I can't find any other abnormalities that could cause this problem, and the message only appeared when a new topscore occured for an ability that had a previous topscore saved with a -1 level.

    If this was the case, then everybody would have been seeing this issue for a VERY long time. UnitLevel(unit) returns -1 for anything with a '??' level, boss mobs in raid instances, for example.

    I actually found that one of my alts that I haven't played for a very long time gets this error message. I guess I ran the broken TopScoreFu briefly when playing as him. I'll try to see if I can break TSF a few times on that character sometime and work out what's causing it.
    Posted in: FuBar AddOns
  • 0

    posted a message on FuBar_BagFu
    Added. Defaults to false.
    Posted in: FuBar AddOns
  • 0

    posted a message on FuBar TopScore
    Quote from Syzgyn »

    Just to confirm, no one is officially supporting this addon anymore correct? I'm gonna start working on a rewrite for 2.4 if thats true.

    I'm the current maintainer for TopScoreFu.
    As far as I'm aware, the errors with 't' and 'tPvP' being nil were introduced a while back when someone other than myself made a commit to TopScoreFu. The commit was quickly reverted by someone else but anyone who ran that buggy version ended up with broken SavedVariables which seems to lead to these bugs that people are seeing.

    Since I don't get these errors myself (I never ran the broken TopScoreFu) it's very hard for me to fix them since I only have the random bug reports saying that "random variable was nil", without telling me what was happening at the time. So far, it seems that nobody has been able to give a proper guide to reproducing these bugs.

    Anyway, the most likely cause of this IS the broken SavedVariables, since the reports started coming in after that broken commit. If you think you cleared out all of your SavedVariables, perhaps you should take another look through every directory in the WTF directory to be super sure that you have.
    If you don't want to clear out all of the SavedVariables and you know what you're doing, you can probably just delete the broken records themselves from the SavedVariables files.
    Posted in: FuBar AddOns
  • 0

    posted a message on Instance Maps not Working
    Quote from OrionShock »

    how does one run said dataminer?

    It has been run and is in the process of being tested right now ;)
    Posted in: Map/Minimap AddOns
  • 0

    posted a message on Instance: Black temple
    I added the Black Temple to Cartographer earlier. The only boss note that currently exists is Naj'entus.
    The outdoor part with Supremus doesn't appear in the "normal" set of Black Temple files. I'll have to find where it is and see if I can display it along with the rest of the map.
    Posted in: Map/Minimap AddOns
  • To post a comment, please or register a new account.