• 0

    posted a message on SCT 6.0 / SCTD 3.0
    zophiel, you're gonna have to give me more details to help you =)
    Posted in: General AddOns
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    dafire, looks like you get latest of sctd_options, but not sctd. Please update both and let me know more info if you still get the error.

    Sirian, read the first post =) And yes buff fades will still display the - when 1.12 is out or you are on PTR.
    Posted in: General AddOns
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    Thereos, you'll need to use an SVN client to make sure you're getting all the externals properly.

    Zews, I think you are just having a case where I made the sliders values too large, and slider position is so small its hard to tell. The actual value/position should not be reseting. I'll be addressing this shortly by allowing you to manually enter a position, and bringing the sliders back down in manage ranges.

    Delsphynx, hmm that is an interesting issue. I'm using the built in panel handling of WoW, which I guess doesn't allow you to open one while dead. I'll have to do some playing around.

    Aileen, just so you know you can always make SCT/SCTD act and display just like they used to, I just changed the defaults up a bit so people can see better what all it offers now. To get SCTD to go back to the more static way, just unclick the "Use SCT Animation" option.

    Viviance, I'll be adding a way to do that in the event config soon. Bascially the ismsg property will be removed and you'll have a new frame property that you can set to frame1, frame2, or message.

    Posted in: General AddOns
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    Viviance, no there isn't currently a built in way to do this as the spam would be massive. You can certainly add it as a custom event though. See sct_event_config.lua.

    Sarinthal, the external settings are all there. Check your client settings, maybe you have grabbing them turned off?
    Posted in: General AddOns
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    Just commited several changes:

    - fixed SCTD reset bug
    - Added sample messages when changing some options
    - Added new "Sprinkler" animation
    - Added animation direction options to SCTD
    - Added count to numbered debuffs

    Posted in: General AddOns
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    Azgrim, yep that's it. It was my faulty thinking that a "false" value would evaluated to true...because for some dumb reason I was thinking its saying "if it doesn't have any value, then set it to default".

    I'll fix this soon as I can tonight and commit it. Thanks for pointing it out =)

    And there probably is a better way to do it, but being unfamiliar with AceDB, I wasn't sure how it would react if I registered a default values change after one has already been set. I play around with that after I get the inital fix out.
    Posted in: General AddOns
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    Thanks Sariash, that will help me track this down. Could you possibly post your SavedVariables\sct.lua file after that happened, or at least the info for the character you are on?

    The UpdateValues is where the problem is happening, its called both on ShowMenu and in OnInitialize. For whatever reason, some of the settings are not getting saved, or saved as nil, and on reload/login/menu open they are getting set to default. I puposely set all check box checks to 1 or false, so I'm not sure how they are getting set back to nil.

    Some of the ones that are reseting, could you try changing their colors, and see if the colors reset too?
    Posted in: General AddOns
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    Can you give me some more detail as to how to reproduce it? I tried everything i could think of yesterday and was never able to. New characters, multiple machines, etc...Can you try turning off all other Ace/Ace2 mods and see if you still get the issue? Are you using any Ace profiles? Can you see if you still get the issue if you go straight to the sctd options using /sctd menu?

    I'm really at a loss on this. If anyone wants to help trouble shoot its found on line 179 of sctd.lua. Its calls UpdateValues here incase the user has reset or copied characters. The UpdateValues updates any SCTD var that is currently nil. The only reason anything should be nil at that point is on a reset or char copy, so I'm not seeing why its resting options for people that haven't done that.
    Posted in: General AddOns
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    I have commited the localization fixes so update if you need them.

    EDIT: Nevermind, think I found the SCTD reset issue. Please get lastest from SVN and let me know. You may need to reset your options manually (with the button or slash command) to get everything working. If it still doesn't work for you after that, please try and list for me steps to reproduce. Thanks!
    Posted in: General AddOns
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    I'll have to take a look at the SCTD reseting problem. I didn't encounter this in my self testing. Wonder maybe if something changed in AceDB-2.0. Whatever it is, I'll try and have the fix out later today.
    Posted in: General AddOns
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    tazmanyak, thanks. I appear to have made the same error in all the non-english localization files. Will fix them all tonight.

    Iceroth, good idea. I'll see what I can come up with. Maybe clicking on an event will trigger a sample of it?

    Rasapian, aye I need to address this. Its the same issue Gorfob brought up. You can reset options if you really want 0 right now =)

    andreasg, as mentioned, the sct_evebt_config.lua file can handle this. I do plan on making an in game UI to add Custom Events, but its still a little ways off.

    m0j0, I'd say its pretty stable at this point. The events i mention in the original post are the only things that won't work on live server. They don't cause bugs, you just won't get the events. So really what I know doesn't work on live is: honor, reputation, buff fades, and the new Skill event. All these are using a new event that doesn't need parsing, but WoW only has in 1.12.

    zophiel, strange. I'll take a look.

    mattftw, buff fades currently don't work on live as I mention above.
    Posted in: General AddOns
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    I've updated the original post to include descriptions for those new to them =)

    Gorfob, I agree on the sliders and its on my list of things to make better. Was just trying to get this out the door. I'll either be provding text boxes or a way to drag the frames around.

    Tedeum, that's in over sight on my part. I'll add that option to SCTD. You could do that with vertical animation in the meantime though (maybe scrolling up on one side, scrolling down on the other).

    Rasapian, you can do that in SCT. Under spell options turn on the "Show all Power Gains" option.

    Roartindon, se7en, grab latest off the SVN and the print issue is fixed.

    Moonsorrow, thanks for those I'll get them fixed tonight. Also, if you have any new/better translations for it feel free to send them my way =)

    Posted in: General AddOns
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    SCT 6.0 and SCTD 3.0 are now in a release state

    What are they?

    SCT - adds incoming damage, heals, and events (dodge, parry, windfury, etc...) as scrolling text above you character model, much like what already happens above your target. For more info see here: http://www.wowinterface.com/downloads/fileinfo.php?id=3965

    SCTD - adds your outgoing damage to SCT. It provides a way for you to see your damage in a static location. This can be useful against large mobs like those in MC, Bosses, etc... For more info see here: http://www.wowinterface.com/downloads/fileinfo.php?id=4913

    SCT can be installed alone. SCTD must have SCT to be installed.


    Posted in: General AddOns
  • To post a comment, please or register a new account.