• 0

    posted a message on cyCircled - Circled buttons for more than just BT2
    Running Bongos and ItemRack, I get no skins and this error, twice, upon login:
    [2006/11/19 23:52:40-53-x1]: cyCircled\core.lua:371: attempt to index field `?' (a nil value)
    cyCircled\core.lua:371: in function `SkinEquipBorder'
    cyCircled\core.lua:189: in function `ApplySkin'
    cyCircled\core.lua:436: in function `ApplySkin'
    cyCircled\core.lua:421: in function `OnEnable'
    cyCircled\core.lua:76: in function `obj_method'
    AceEvent-2.0\AceEvent-2.0.lua:244: in function `TriggerEvent'
    AceEvent-2.0\AceEvent-2.0.lua:927: in function `event'
    AceEvent-2.0\AceEvent-2.0.lua:426: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:403>
    Posted in: General AddOns
  • 0

    posted a message on Automaton
    There are a couple of new repetitive rep turnins for the Argent Dawn. I've added them to the AutoGossip module; here's the code.

    For localizaton:
    	["Dark Iron Scraps"] = true,
    	["Crypt Fiend Parts"] = true,
    	["Bone Fragments"] = true,
    	["Core of Elements"] = true,
    	["Savage Frond"] = true,
    	["Savage Fronds"] = true,


    In AutoGossipData.lua:
    	[L["Bone Fragments"]] = {
    		items = { [L["Bone Fragments"]] = 30 }
    	},
    	[L["Core of Elements"]] = {
    		items = { [L["Core of Elements"]] = 30 }
    	},
    	[L["Crypt Fiend Parts"]] = {
    		items = { [L["Crypt Fiend Parts"]] = 30 }
    	},
    	[L["Dark Iron Scraps"]] = {
    		items = { [L["Dark Iron Scraps"]] = 30 }
    	},
    	[L["Savage Fronds"]] = {
    		items = { [L["Savage Frond"]] = 30 }
    	},


    The only caveat is that the Savage Fronds quest has a choice of rewards... all of these quests give you a token, either an Insignia of the Dawn or an Insignia of the Crusade, but the others don't give you a choice - two of them give a Dawn token, two a Crusade token. I guess to even out the fact that there were five quests for two rewards Blizzard decided to let players choose for the Savage Fronds turnin, as tokens are required in equal amounts of each for other things. I've just commented out the Savage Fronds part for my own use, as I couldn't think of a good solution, and Automaton was just taking the first of the two choices every time. Possibly remembering which token was chosen previously, and alternating between them, would work, but I don't know how much coding that would require.
    Posted in: General AddOns
  • 0

    posted a message on FuXPFu - (As inspired by Bant)
    I just wanted to share my small addition to FuXPFu, in hopes that maybe it'll be added to the official version and I can stop having to copy/paste it again every time there's an update. :P

    All it does is show you your total progress from 1 to 60 on two lines, one showing how far you've come from level 1, the other how far to go 'til level 60. It doesn't show if you are already 60, and of course it'll need to be updated for the expansion with however much XP is gained between 60 and 70. The code is based on code from a Titan Panel XP plugin I used before I switched to FuBar... there may be a more efficient way to set it up, but I'm fairly noob at Lua.

    In FuBar_FuXPFu.lua, insert after line 688 (just before the "end" line which is followed by the "if (self.db.profile.ShowRep) then" line:
    		if (UnitLevel("player") < 60) then
    			levelXP = {
    				0, 400, 1300, 2700, 4800, 7600, 11200, 15700, 21100, 27600,
    				35200, 44000, 54100, 65500, 78400, 92800, 108800, 126500, 145900, 167200,
    				190400, 215600, 242900, 272300, 304000, 338000, 374400, 413300, 454700, 499000,
    				546400, 597200, 651900, 710500, 773300, 840300, 911900, 988000, 1068800, 1154500,
    				1245200, 1341000, 1442000, 1548300, 1660100, 1777500, 1900700, 2029800, 2164900, 2306100,
    				2453600, 2607500, 2767900, 2935000, 3108900, 3289700, 3477600, 3672600, 3874900, 4084700
    				}
      			local currentLevel = UnitLevel("player")
    			local currentTotalXP = levelXP[currentLevel] + currentXP
    			local totalXPto60 = levelXP[60]
    			local totalXPto60pct = currentTotalXP / totalXPto60
    			local currentXPto60 = totalXPto60 - currentTotalXP
    			local currentXPto60pct = (currentXPto60) / totalXPto60
    			local totalGainedXPpct = floor(totalXPto60pct * 10000) / 100
    			local totalNeededXPpct = floor(currentXPto60pct * 10000) / 100
    			xp:AddLine(
    					'text', L["XP Since Level 1"],
    					'text2', string.format("%s (%3.0f%%)", currentTotalXP, totalGainedXPpct)
    				)
    			xp:AddLine(
    					'text', L["XP To Level 60"],
    					'text2', string.format("%s (%3.0f%%)", currentXPto60, totalNeededXPpct)
    				)
    		end


    And then in FuXPLocals.lua, add somewhere:
    	["XP Since Level 1"] = true,
    	["XP To Level 60"] = true,
    Posted in: FuBar AddOns
  • 0

    posted a message on GotWood?
    Alright, finally got around to getting some debug output for you.

    Scenario: I have no totems cast. I cast Strength of Earth totem. I cast Searing totem. Debug says stopping fire timer, but stops earth timer instead.
    Debug:
    (00:10:52643) Totem: Strength of Earth Totem 4
    (00:10:52645) Totemtimer started in view: Button earth Strength of Earth Totem
    (00:10:54674) Totem: Searing Totem 6
    (00:10:54675) Stopping timer for ele: fire (SetTotem)
    (00:10:54675) Timer started in view: Button fire Searing Totem

    A few minutes later I attempted the opposite (casting the fire totem first) and got the same result, only it said it was stopping the earth totem and stopped the fire totem instead.

    I then cast a series of all four elements, with these results (no timestamps because I don't feel like typing them, but I cast them all one right after the other):
    Totem: Strength of Earth Totem 4
    Totemtimer started in view: Button earth Strength of Earth Totem
    Totem: Grace of Air Totem 3
    Stopping timer for ele: air (SetTotem)
    [[stopped earth timer]]
    Totemtimer started in view: Button air Grace of Air Totem
    Totem: Mana Spring Totem 4
    Totemtimer started in view: Button water Mana Spring Totem
    Totem: Searing Totem 6
    Stopping timer for ele: fire (SetTotem)
    [[stopped air timer]]
    Totemtimer started in view: Button fire Searing Totem

    Let me know if there are any other things you want me to try.
    Posted in: General AddOns
  • 0

    posted a message on FuBar 2.0 in Trunk (Official thread)
    Apologies in advance if this is overlong; I wanted to include all relevant details, especially all the error messages. :p

    As I was running Scholo a bit ago on my shaman, FuBar began to act very strangely. First I noticed that PerformanceFu had gone missing - there was the space on the bar it should be in, but no text or icon was visible. I then discovered that about half of the plugins were not responding to mouseover or right-click, and FuBar itself wasn't responding to right-clicks. Then other plugins started vanishing too - HonorFu, then LocationFu. During a lull in the action, I reloaded my UI, and things seemed to be back to normal, with the exception that several plugins had forgotten their "display text" and "display icon" settings. But after a minute, I started getting more errors, and TransporterFu's right-click menu isn't appearing properly - it's appearing below the bar, off the screen. I moved the bar to the top of the screen and was able to see the menu, except it's all blank and about twice as long as it should be. Here are all of the errors captured by BugSack:

    Before the reload:

    #1 (x2): (note that I was not doing anything with PerfectRaidFu at the time; in fact, it wasn't even shown on the bar)
    Fubar_PerfectRaidFu\\PerfectRaidFu.lua:51: attempt to index global `PR_IconFrame' (a nil value)
    Fubar_PerfectRaidFu\\PerfectRaidFu.lua:51: in function `OnDisable'
    AceDB-2.0\\AceDB-2.0.lua:1153: in function `ToggleActive'
    FuBarPlugin-2.0\\FuBarPlugin-2.0.lua:423: in function `?'
    Dewdrop-2.0\\Dewdrop-2.0.lua:477: in function <...erface\\AddOns\\DewdropLib\\Dewdrop-2.0\\Dewdrop-2.0.lua:432>

    #2 (x1): (again, not doing anything at all with the bar when these occurred)
    FuBar\\FuBar_Panel.lua:823: attempt to perform arithmetic on a nil value\nFuBar\\FuBar_Panel.lua:823: in function `Update'
    FuBar\\FuBar_Panel.lua:1198: in function `CheckForOverlap'
    FuBar\\FuBar_Panel.lua:906: in function `Update'
    FuBar\\FuBar_Panel.lua:235: in function `init'
    AceOO-2.0\\AceOO-2.0.lua:468: in function `new'
    FuBar\\FuBar_Panel.lua:1192: in function `CheckForOverlap'
    FuBar\\FuBar_Panel.lua:906: in function `Update'
    FuBar\\FuBar.lua:1353: in function `Plugin_StopDrag'\nFuBar\\FuBar.lua:1157: in function <Interface\\AddOns\\FuBar\\FuBar.lua:1155>

    #3 (x1):
    FuBar\\FuBar_Panel.lua:823: attempt to perform arithmetic on a nil value
    FuBar\\FuBar_Panel.lua:823: in function `Update'
    FuBar\\FuBar.lua:1186: in function `Update'
    FuBar\\FuBar.lua:518: in function `sliderFunc'
    Dewdrop-2.0\\Dewdrop-2.0.lua:1678: in function <...erface\\AddOns\\DewdropLib\\Dewdrop-2.0\\Dewdrop-2.0.lua:1476>
    Dewdrop-2.0\\Dewdrop-2.0.lua:375: in function <...erface\\AddOns\\DewdropLib\\Dewdrop-2.0\\Dewdrop-2.0.lua:364>

    #4 (x1):
    FuBar\\FuBar.lua:1319: attempt to compare nil with number
    FuBar\\FuBar.lua:1319: in function `Plugin_StopDrag'
    FuBar\\FuBar.lua:1157: in function <Interface\\AddOns\\FuBar\\FuBar.lua:1155>

    After the reload:

    #1 (x1):
    Fubar_PerfectRaidFu\PerfectRaidFu.lua:51: attempt to index global `PR_IconFrame' (a nil value)
    Fubar_PerfectRaidFu\PerfectRaidFu.lua:51: in function `OnDisable'
    AceDB-2.0\AceDB-2.0.lua:1153: in function `ToggleActive'
    FuBarPlugin-2.0\FuBarPlugin-2.0.lua:423: in function `?'
    Dewdrop-2.0\Dewdrop-2.0.lua:477: in function <...erface\AddOns\DewdropLib\Dewdrop-2.0\Dewdrop-2.0.lua:432>

    #2 (x1) - when trying to right-click TransporterFu:
    FuBar_TransporterFu\TransporterFu.lua:160: attempt to index field `METHODS' (a nil value)
    FuBar_TransporterFu\TransporterFu.lua:160: in function `UpdateText'
    FuBarPlugin-2.0\FuBarPlugin-2.0.lua:273: in function `Update'
    FuBarPlugin-2.0\FuBarPlugin-2.0.lua:406: in function `Show'
    FuBarPlugin-2.0\FuBarPlugin-2.0.lua:964: in function <...\FuBarPlugin-2.0\FuBarPlugin-2.0\FuBarPlugin-2.0.lua:962>
    FuBarPlugin-2.0\FuBarPlugin-2.0.lua:982: in function `OnEmbedEnable'
    AceDB-2.0\AceDB-2.0.lua:1131: in function `ToggleActive'
    FuBarPlugin-2.0\FuBarPlugin-2.0.lua:384: in function `?'
    Dewdrop-2.0\Dewdrop-2.0.lua:477: in function <...erface\AddOns\DewdropLib\Dewdrop-2.0\Dewdrop-2.0.lua:432>

    #3 (x7):
    FuBar_TransporterFu\TransporterFu.lua:205: attempt to index field `ItemDesc' (a nil value)
    FuBar_TransporterFu\TransporterFu.lua:205: in function `OnTooltipUpdate'
    FuBarPlugin-2.0\FuBarPlugin-2.0.lua:310: in function <...\FuBarPlugin-2.0\FuBarPlugin-2.0\FuBarPlugin-2.0.lua:306>
    Tablet-2.0\Tablet-2.0.lua:2246: in function `children'
    Tablet-2.0\Tablet-2.0.lua:2256: in function `Open'
    Skinner\AddonFrames.lua:129: in function <Interface\AddOns\Skinner\AddonFrames.lua:127>
    <unknown>:
    Tablet-2.0\Tablet-2.0.lua:2380: in function <Interface\AddOns\TabletLib\Tablet-2.0\Tablet-2.0.lua:2374>

    #4 (x6):
    FuBar_TransporterFu\TransporterFu.lua:484: bad argument #1 to `pairs' (table expected, got nil)
    <in C code>: in function `pairs'
    FuBar_TransporterFu\TransporterFu.lua:484: in function `pairsByKeys'
    FuBar_TransporterFu\TransporterFu.lua:83: in function `OnMenuRequest'
    FuBarPlugin-2.0\FuBarPlugin-2.0.lua:858: in function <...\FuBarPlugin-2.0\FuBarPlugin-2.0\FuBarPlugin-2.0.lua:848>
    Dewdrop-2.0\Dewdrop-2.0.lua:1464: in function <...erface\AddOns\DewdropLib\Dewdrop-2.0\Dewdrop-2.0.lua:1415>
    Dewdrop-2.0\Dewdrop-2.0.lua:2021: in function <...erface\AddOns\DewdropLib\Dewdrop-2.0\Dewdrop-2.0.lua:1984>
    Dewdrop-2.0\Dewdrop-2.0.lua:2232: in function `Open'
    FuBarPlugin-2.0\FuBarPlugin-2.0.lua:901: in function `OpenMenu'
    FuBarPlugin-2.0\FuBarPlugin-2.0.lua:759: in function <...\FuBarPlugin-2.0\FuBarPlugin-2.0\FuBarPlugin-2.0.lua:757>
    FuBar\FuBar.lua:1151: in function <Interface\AddOns\FuBar\FuBar.lua:1145>
    Tablet-2.0\Tablet-2.0.lua:2400: in function <Interface\AddOns\TabletLib\T

    Also, earlier I logged off my shaman main, FuBar working fine, and onto my druid alt, where after the loading screen vanished I sat looking at a blank FuBar panel and a framerate of about 1 frame per 5 seconds, and hearing my computer struggling with something. I exited the game, deleted my FuBar.lua saved variables file, and logged back in (on the druid), and things were working fine.

    I am running these FuBar plugins: FuBar_AnkhTimerFu, FuBar_BattlegroundFu, FuBar_ClockFu, FuBar_DurabilityFu, FuBar_EmoteFu, FuBar_FactionsFu, FuBar_FriendsFu, FuBar_FuXPFu, FuBar_GreedBeacon, FuBar_GroupFu, FuBar_HonorFu, FuBar_LocationFu, FuBar_LogFu, FuBar_MailFu, FuBar_ModMenuTuFu, FuBar_MoneyFu, FuBar_oRA2CooldownFu, FuBar_PerfectRaidFu, FuBar_PerformanceFu, FuBar_RareTrackerFu, FuBar_RestFu, FuBar_SVIFu, FuBar_ToFu, TransporterFu, FuBar_VolumeFu

    And these mods that plug themselves into FuBar: BugSack/BugGrabber, Detox, TooltipExchange

    I haven't added any new addons between yesterday when FuBar was working fine, and today when it's started acting up. I did, however, use WinAceUpdater, which updated the following mods: Ace2, oCB, oCD, TooltipExchange, BabbleLib, Babble-2.2

    Any thoughts/solutions would be much appreciated. Thanks.
    Posted in: FuBar AddOns
  • 0

    posted a message on Fake email from WowAce.com
    Yeah, I just got the same thing. It doesn't appear to be a fake email, as it's actually a Private Message here when I log in. Just some guy ("RobertT") signing up to send spam messages to users. :(
    Posted in: General Chat
  • 0

    posted a message on GotWood?
    Getting several errors.

    When I die with "remove timers on death" checked, I get either:
    [2006/11/12 01:38:08-16-x2]: views\ButtonView.lua:113: attempt to index field `?' (a nil value)
    views\ButtonView.lua:113: in function `RemoveTotem'
    GotWood\GotWood.lua:321: in function `obj_method'
    AceEvent-2.0\AceEvent-2.0.lua:312: in function `TriggerEvent'
    AceEvent-2.0\AceEvent-2.0.lua:898: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:890>

    or
    [2006/11/12 02:04:32-16-x4]: views\CircleView.lua:203: attempt to index field `?' (a nil value)
    views\CircleView.lua:203: in function `Disable'
    GotWood\GotWood.lua:385: in function `SetView'
    GotWood\GotWood.lua:166: in function `func'
    Dewdrop-2.0\Dewdrop-2.0.lua:479: in function <...erface\AddOns\DewdropLib\Dewdrop-2.0\Dewdrop-2.0.lua:432>

    depending on which view I'm currently using.

    I also get this one:
    [2006/11/12 02:03:14-16-x2]: views\CircleView.lua:155: attempt to index field `buttons' (a nil value)
    views\CircleView.lua:155: in function `SetTotemDamage'
    GotWood\GotWood.lua:342: in function `obj_method'
    AceEvent-2.0\AceEvent-2.0.lua:312: in function `TriggerEvent'
    AceEvent-2.0\AceEvent-2.0.lua:898: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:890>

    when trying to switch from Circle view to Button or CandyBar view.

    Also, I don't get errors for this, but in Circle and Button views, the timers like to freeze a lot... it happens most of the time when another shaman casts a totem of the same element, and most of the time when my totem is destroyed - but not every time those happen, and sometimes they freeze when neither of those happen. I don't have any hard numbers to back this up, but it seems like in Button view, the earth and air timers freeze the most often, while in Circle view the earth and fire times freeze the most often. I've never seen the water timer freeze. For reference, my viewing order goes earth, air, water, fire.

    Finally, click recasting is no longer working.

    enUS client, latest version of all standalone libs (not using embedded).
    Posted in: General AddOns
  • 0

    posted a message on Buffalo
    Getting this error in the latest version (r14814) when trying to open the config:

    [2006/11/12 00:12:08-14-x9]: Buffalo\Buffalo.lua:39: attempt to index field `dewdrop' (a nil value)
    Buffalo\Buffalo.lua:39: in function `func'
    AceConsole-2.0\AceConsole-2.0.lua:1103: in function <...erface\AddOns\Ace2\AceConsole-2.0\AceConsole-2.0.lua:908>
    AceConsole-2.0\AceConsole-2.0.lua:1682: in function `value'
    FrameXML\ChatFrame.lua:2170: in function `ChatEdit_ParseText'
    FrameXML\ChatFrame.lua:1941: in function `ChatEdit_SendText'
    FrameXML\ChatFrame.lua:1963: in function `lOrig_ChatEdit_OnEnterPressed'
    LootLink\LootLink.lua:5414: in function `ChatEdit_OnEnterPressed'
    <string>:"ChatFrameEditBox:OnEnterPressed":2: in main chunk
    Posted in: General AddOns
  • 0

    posted a message on Denial 2 (bug report)
    Having a problem with r16520. I can't use the Wind Stones in Silithus, and can't talk to many NPCs. I tracked the problem down to the new method of setting alpha to 0 until the addon selects a gossip option... it doesn't seem to be restoring the alpha if it doesn't select anything. Using MoveAnything I am able to mouseover and see that the frame is there, I just can't see it. Holding down CTRL didn't fix the problem, nor did disabling gossip skipping for everything.
    Posted in: General AddOns
  • 0

    posted a message on GotWood?
    OptionalDeps have disappeared from the TOC file again this version (rev. 16547).

    I came to post that it wasn't working - no error messages, and the frame would appear, but it wouldn't detect totems, and wasn't saving settings - and noticed someone mention externals, so I went to check, and lo and behold, they're missing again. Added them, and everything's working.
    Posted in: General AddOns
  • 0

    posted a message on BugGrabber / BugSack -- Ace2'd
    Alright. Updated to the latest SVN versions, and the freeze on mouseover isn't happening anymore. Hopefully the random crash is also fixed! :P

    Also, I'm getting the same error as Gamefaq, but with different line numbers:

    BugSack\BugSackFu.lua:34: FuBarPlugin-2.0: You must provide self.title or self.name
    <evaluated>: in function `error'
    AceLibrary\AceLibrary.lua:106: in function <...nterface\AddOns\FuBar\libs\AceLibrary\AceLibrary.lua:37>
    AceLibrary\AceLibrary.lua:121: in function `assert'
    FuBarPlugin\FuBarPlugin-2.0.lua:84: in function `GetTitle'
    FuBarPlugin\FuBarPlugin-2.0.lua:305: in function `SetIcon'
    BugSack\BugSackFu.lua:34: in function `OnTextUpdate'
    FuBarPlugin\FuBarPlugin-2.0.lua:164: in function `UpdateText'
    FuBarPlugin\FuBarPlugin-2.0.lua:149: in function `UpdateDisplay'
    BugSack\BugSack.lua:449: in function `OnError'
    BugSack\BugSack.lua:220: in function `OnInitialize'
    AceAddon-2.0\AceAddon-2.0.lua:215: in function `InitializeAddon'
    AceAddon-2.0\AceAddon-2.0.lua:110: in function `obj_method'
    AceEvent-2.0\AceEvent-2.0.lua:213: in function `TriggerEvent'
    AceEvent-2.0\AceEvent-2.0.lua:919: in function <...face\AddOns\FuBar\libs\AceEvent-2.0\AceEvent-2.0.lua:911>
    Posted in: General AddOns
  • 0

    posted a message on BugGrabber / BugSack -- Ace2'd
    I have... a lot of mods. Around 150 installed, anywhere from 60-100 enabled depending on which character I'm on, so I'll spare you a full list. Unless you really want one. :P

    However, when only !BugGrabber, BugSack, and FuBar are enabled, it does happen. I will test and see if it happens without FuBar enabled... although since it happens when I mouseover the icon on FuBar, I'm guessing it won't. We'll see.

    Yep, happens without any errors in the database at all. At least, I'm pretty sure there aren't any - I'd just wiped the saved variables file, and didn't hear the little audio alert between the time I logged in and the time I moused over the icon and froze. I'll do more testing and see if I can get something to throw an error, and see what happens if I mouseover the icon then.
    Posted in: General AddOns
  • 0

    posted a message on BugGrabber / BugSack -- Ace2'd
    I am also having major problems with !BugGrabber. Am currently using the most recent SVN versions of !BugGrabber, BugSack, and FuBar.

    About 2/3 of the time when mousing over the BugSack icon on FuBar, WoW freezes up. I can move the mouse cursor around, and I can alt-tab out, but that's it. Task Manager shows WoW using 80-100 % CPU. The problem does not resolve itself, and I have to kill the process.

    Also, several times now I've had WoW crash at apparently random times, and in the error report, !BugGrabber.lua is listed in the memory dump section.

    Edit: I suppose I should add that the freezing does happen when only !BugGrabber, BugSack, and FuBar are enabled, and it does happen after deleting saved variables. As the crashing is random, I can't really test, but I'm guessing it'd happen under the same conditions.
    Posted in: General AddOns
  • To post a comment, please or register a new account.