CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on IceHUD
    Quote from zably »

    Better, but still one bug that I noticed. Interrupts seem to work, but now if you manually interrupt a spell quickly enough, ie, mash "2" then "w" real quick, the cast bar ignores the interrupt part, and you get a full cast bar, even though you're running forward. Probably due to lag? Like, maybe the interrupt occurs before the start cast event?


    Yeah, likely a lag issue. I'll take a look, but I'm not sure what can be done with the current setup for the castbar.

    Quote from zably »

    PS. You're my hero.


    Lol, just doing what I can to help keep this going. Besides, you did all the legwork in finding out the best way to solve the problem ;). I appreciate that.
    Posted in: Unit Frames
  • 0

    posted a message on IceHUD
    I was running through some of the older requests in this thread and saw a lot people asking for the text below the bars to be different or changed to their liking, so...I updated most bars with text underneath to use LibDogTag formatting in rev 59024. You can now customize the upper/lower text to whatever you want it to say based on Ace DogTags (for reference: http://www.wowace.com/wiki/LibDogTag-2.0/Tags ).

    I also added a missing Deformat reference in the embeds file so if anyone was having problems with previous revs (after the spell interrupt fix), grab the latest version.

    The next thing I plan on tweaking is text placement since people were asking for that too. I'll probably have a slider to adjust how far from the bar the text appears.

    Finally, I hope to add some OnClick behavior to the various bars so you can tweak what you want to happen when you click individual bars.

    All feedback welcome!
    Posted in: Unit Frames
  • 0

    posted a message on IceHUD
    Quote from zably »

    Added a quick line to send a message to chat when you get interrupted to test. Appears UNIT_SPELLCAST_INTERRUPTED doesn't trigger. I tried with kicks from a rogue, maybe other interrupts still work (doubt it, as I didn't notice CS/earthshock working earlier, but I was busy trying not to die, so might just have missed it).


    Try out r58991 whenever you get a chance. I implemented Quartz's method you posted earlier and from my limited testing (I don't usually use ice cast bar or pvp much ;)) it seems to be working properly. Let me know the results!
    Posted in: Unit Frames
  • 0

    posted a message on IceHUD
    Quote from zably »

    Yeah, the new version works great, thanks.

    I was looking through Quartz's code, because their cast bar still works, but I've never looked at LUA before, so I don't really know what I'm doing. From what I could see though, it looks like Quartz checks for an interrupt like this:

    function QuartzInterrupt:OnEnable()
    self:RegisterEvent("CHAT_MSG_SPELL_HOSTILEPLAYER_DAMAGE", 'CheckInterrupt')
    self:RegisterEvent("CHAT_MSG_SPELL_CREATURE_VS_SELF_DAMAGE", 'CheckInterrupt')

    while IceHud is doing a single line check for interrupt events:

    self:RegisterEvent("UNIT_SPELLCAST_INTERRUPTED", "SpellCastInterrupted") -- unit

    Of course, I have no idea if these are for different things, but if the IceHud event was changed last patch, or something?


    The casting stuff for IceHUD was indeed changed, but it was before I started messing with it :). They changed it a few months ago, so it's possible the new patch broke stuff. I'll take a look at how Quartz handles it. Thanks for the info!
    Posted in: Unit Frames
  • 0

    posted a message on IceHUD
    Quote from Parnic »

    Ok, looks like a problem trying to find SharedMedia-1.0 for some reason. I'm checking it out :).


    R58879 should have the fix for you. I disabled all other addons except IceHUD and was able to load it after the fixes in that revision. Thanks for the report!

    As for the castbar problem, I haven't experienced that myself as I usually leave the castbar off, but I'll look into it as well and see what I can turn up.
    Posted in: Unit Frames
  • 0

    posted a message on IceHUD
    Quote from zably »

    Not sure why, but the most recent revision (58796) won't work for me, at all. /icehud gives an error, and there's no visible hud, even though the addon screen immediately after login shows IceHud as enabled. I tried manually installing LibSharedMedia-2.0, but that didn't seem to have any effect either.


    Ok, looks like a problem trying to find SharedMedia-1.0 for some reason. I'm checking it out :).
    Posted in: Unit Frames
  • 0

    posted a message on IceHUD
    Finally got my SVN account setup and I've posted my changes in a branch. I've been using these changes locally for a LONG time (months) since iceroth refused to check them in when I contacted him. I'd appreciate anyone who can/is willing to check out my changes in my branch here:
    http://svn.wowace.com/wowace/branches/IceHUD/Parnic/IceHud
    Note that there are a couple of erroneous check-ins while I learned SVN...too used to perforce at work ;). I'd appreciate feedback from any and everyone. If no one has any problems with these changes after a week or so, I think I'll submit to the main line and try to keep the mod maintained.

    My changes are as follows:
    Added an option to any health/power bars that allow them to fade from a max value to a min value based on how full the bar is. These colors are configurable as max/min health and max/min mana under the 'colors' config section.
    Also added a rudimentary ThreatToTarget bar similar to the aforementioned mod that someone else wrote.

    Feedback welcome!
    Posted in: Unit Frames
  • 0

    posted a message on IceHUD
    Quote from Mecdemort »

    If you're going to make changes that you're unsure of then you should but them in a branch version.

    Sure, my post was more attempting to get people working on this thing again rather than letting it die. I have features that are fully functional on my local pc, I'm just not an Ace whiz :). I'll post when my changes are in a branch and ready for review.
    Posted in: Unit Frames
  • 0

    posted a message on IceHUD
    Quote from Iceroth »

    Not that there's been much support from me for this addon lately but I felt oblicated to post this final notice that I've cancelled my account and therefore there won't be any support for this mod from my part in the future.

    In light of this, I think I'll check in some changes that I've made locally to color bars based on how full they are. I'm pretty new to the ace libraries, so I may have done some of it incorrectly, but since iceroth didn't want to check this in himself and he's no longer working on it, I think I'll submit it. I would encourage anyone else who's done work on this (such as the Threat bar discussed earlier, apparently available here: http://www.wowinterface.com/downloads/info7773-IceHUDThreat.html ) to check in their changes as well. Let's take this over as a community and see what we can do with it :).
    Posted in: Unit Frames
  • 0

    posted a message on IceHUD
    Quote from Blozzom »

    I am trying to add a custom bar to IceHUD to display threat info using Threat-1.0.

    It's working ok so far:



    However, I am trying to make the bar gradient according to my current threat. I tried something like:

    IceHUD.IceCore:SetColor("ThreatCustom", 255, 255-threatPct, 0)

    in my Update function. But it doesn't work for some reason and freezes my WoW for several seconds.

    Any ideas? :)




    This is an awesome idea and I hope you're still working on it. I realize this post is coming a bit after you asked the question, but I've made a similar mod for bar coloration on my local machine for colorizing the filled amount based on what % it's at (red for low health, green for full, ...). The only difference in the code I'm using and what you've provided is that I'm calling self:SetColor inside the bar's update instead of calling it on IceCore. Have you tried that? (apologies if you've fixed this many moons ago :))
    Posted in: Unit Frames
  • 0

    posted a message on cyCircled - Circled buttons for more than just BT2
    Quote from CyberOto »

    Just updated to r48742 build and noticed that the hotkey position is always set to bottom right corner, no matter what is set in the skin.

    Reverted back to r46357 and all is fine.


    There were definitely some changes to cyCircled:SkinHotkey just today. I tried reverting that function to its previous state, but the hotkey placement seems to still be broken. Would be nice if cncfanatic could fix this up.
    Posted in: General AddOns
  • To post a comment, please or register a new account.