• 0

    posted a message on why does AceDB-2.0 save gigabits of info to my save file?
    thnx
    Posted in: General AddOns
  • 0

    posted a message on why does AceDB-2.0 save gigabits of info to my save file?
    i followed the tutorial,what am i missing?i did my variables the exact same way as the tutorial
    Posted in: General AddOns
  • 0

    posted a message on whats the most reliable method of returning spell name and rank?
    making a random sheep message mod and am having problems with unitcastinginfo,any other method i can use?
    Posted in: General AddOns
  • 0

    posted a message on what am i doing wrong?(simple script)
    they added trade skill to it a few patches back,thnx tho
    Posted in: General AddOns
  • 0

    posted a message on what am i doing wrong?(simple script)
    this always returns nil

    /script local spell, rank, displayName, icon, startTime, endTime, isTradeSkill = UnitCastingInfo("player");if spell~=nil then s="worked" else s="failed"end;SendChatMessage(s,"say") 
    Posted in: General AddOns
  • 0

    posted a message on what am i doing wrong?(simple script)
    i want to make different messages for each of the 3 poly spells(this is being called from the cast macro)

    /script local spell, rank, displayName, icon, startTime, endTime, isTradeSkill = UnitCastingInfo("player");SendChatMessage(spell,"say")


    Posted in: General AddOns
  • 0

    posted a message on trinket macro with sound fix
    this is my main spell macro,to give an idea what u can do with them


    #showtooltip Fireball
    /script RunSuperMacro("Unregister")
    /use [harm]13
    /use [harm]14
    /use 16
    /cast Combustion
    /stopcasting
    /script RunSuperMacro("Register")
    /castsequence reset=combat Fireball,Fireball,Fireball,Fireball,Fireball,Fireball,Fireball,Scorch
    Posted in: General AddOns
  • 0

    posted a message on trinket macro with sound fix
    for this to work u need ace2 library and supermacro mod

    download and install them both

    make 2 spuermacros name them unregister and register

    in UNREGISTER put

    /script UIErrorsFrame:UnregisterEvent("UI_ERROR_MESSAGE");
    /script SetCVar("Sound_SFXVolume", 0.0);


    in REGISTER put

    /script AceLibrary("AceEvent-2.0"):ScheduleEvent(function() SetCVar("Sound_SFXVolume", 1.0) end, 0.0);
    /script AceLibrary("AceEvent-2.0"):ScheduleEvent(function() UIErrorsFrame:RegisterEvent("UI_ERROR_MESSAGE") end, 0.1);


    in your hotbar spell macro put

    #showtooltip Arcane Explosion
    /script RunSuperMacro("Unregister")
    /use 13
    /use 14
    /script RunSuperMacro("Register")
    /cast Arcane Explosion


    if ur trinket has an error sound when u try to use it and u want rid of the sound,play with the 0.0 value in REGISTER supermacro untill it is gone,disable error speach in game if desired

    change arcane explosion to desired spell

    walla,trinket macro with no red error text and no asociated annoying sounds when it is pressed



    Posted in: General AddOns
  • 0

    posted a message on UiErrorFrame help
    solved it,hafta put in a .1 sec delay(used schedualevent ace function)
    Posted in: General AddOns
  • 0

    posted a message on UiErrorFrame help
    this in a macro with use trinkets between used to get rid of the item is not ready text,since patch it no longer does,no errors tho

    /script UIErrorsFrame:UnregisterEvent("UI_ERROR_MESSAGE");
    /use trinket
    /script UIErrorsFrame:RegisterEvent("UI_ERROR_MESSAGE");

    what do i need to change to make this work again?or did they nerf it completely?
    Posted in: General AddOns
  • 0

    posted a message on Instance Maps not Working
    had this same issue other day in SSC,tried to duplicate it in mana tombs and had no probs at all,then again tonight same thing in SSC
    Posted in: Map/Minimap AddOns
  • 0

    posted a message on OneBag 2.0.6026 [Released 7/28/2006]

          <OnShow>
            BankFrameItemButton_OnUpdate()
          </OnShow>


    Deleted those lines out and my errors went away, it dosn't appear to brake any functionality.


    did this one and texture didnt change when i moved items in the bank,but it got rid of the error popups

    	if not self.frame.bags[-1].colorLocked then
    		for k, v in ipairs(self.frame.bags[-1]) do 
    			self:SetBorderColor(v)
    			BankFrameItemButton_Update(v)
    		end
    	end

    Use that "fix" at your own risk!


    did this one on top of the other one and now seemingly all features functional and no errors,thnx guys
    Posted in: General AddOns
  • 0

    posted a message on OneBag 2.0.6026 [Released 7/28/2006]
    Quote from Myrathi »

    That'll get rid of the errors, yes, but it doesn't fix the problem. :(

    If you open your OBB and try to move items around, their border hilights will update but not the textures.

    I managed to fix (hack? :P) this in the OneBank\OneBank.lua file at around line 113 by adding a call to the new BankFrameItemButton_Update() function that Blizzard added (as a replacement to the now-missing *OnUpdate() function):

    	if not self.frame.bags[-1].colorLocked then
    		for k, v in ipairs(self.frame.bags[-1]) do 
    			self:SetBorderColor(v)
    			BankFrameItemButton_Update(v)
    		end
    	end
    It's definitely nothing more than a temporary hack, I think, as that loop seems to only run when the bag in question isn't "colorLocked" but it works for me, for now. I'll definitely be glad when an official fix is available. =)

    Use that "fix" at your own risk! :o


    tried this fix and same errors,i guess i have color lock enabled,donno wtf that is tho heh
    Posted in: General AddOns
  • 0

    posted a message on OneBank error
    author=OrionShock link=topic=1640.msg142491#msg142491 date=1190790648]
    i don't use LootLink but i had a different problem
    <string>:"BBankFrameItem[b]X[/b]:OnShow":1: attempt to call global '[i]BankFrameItemButton_OnUpdate[/i]' (a nil value)
    <in C code>: in function `Show'
    OneBank-2.0.36565\OneBank.lua:110: in function <Interface\AddOns\OneBank\OneBank.lua:110>
    <in C code>: ?
    AceEvent-2.0-49307 (Ace2):307: in function `TriggerEvent'
    AceEvent-2.0-49307 (Ace2):962: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:955>



    so i followed it back to onebag's template file, Lines 10-12

          <OnShow>
            BankFrameItemButton_OnUpdate()
          </OnShow>


    Deleted those lines out and my errors went away, it dosn't appear to brake any functionality.


    copy pasted that from onebag thread,gonna try it now
    Posted in: General AddOns
  • 0

    posted a message on OneBank error
    was wrong,it is repeated for bankitems 1-28
    Posted in: General AddOns
  • To post a comment, please or register a new account.