• 0

    posted a message on Localization namespaces not being added

    I just submitted a ticket about this, not seeing this thread, stating the same. The packager seems to be excluding all subnamespaces and the export page does not format them correctly.

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Notepad++
    Quote from Dridzt
    The only editors I know that try to do auto-formatting for Lua files "after the fact" (ie take messy unformatted code and put indents / newlines as appropriate) are:



    SciTE has the ability for auto indentation in Lua and, with a small script, post indentation of selected text.
    Posted in: General Chat
  • 0

    posted a message on Need your review
    Quote from Benalian
    I moved the libraries in the main addon. Now, to call the functions present in the options addon in the main what should I do?

    UnitScanner.lua
    USopt = LibStub("AceAddon-3.0"):NewAddon("UnitScanner_Options", "AceConsole-3.0", "AceEvent-3.0")

    UnitScanner_Options.lua(Core??)
    local USopt = LibStub("AceAddon-3.0"):GetAddon("USopt")


    I would think your options file would be for "options" not functions that would be better suited for the real "core" of the addon.
    Posted in: Lua Code Discussion
  • 0

    posted a message on curse.com comment notifications
    Maybe here:
    http://www.curse.com/my-profile/activity#t1:my-profile-subscriptions

    cog in upper left > My Curse > My Notifications

    Edit: hmm maybe those are only for project update notifications...
    Posted in: General Chat
  • 0

    posted a message on Crashing on Exit - Corrupts WTF
    I had a problem a quite awhile ago that on exit I would get an exception, this caused all saved var files that were open during the exception to have an extra CR LF at the first line...though I have been told this shouldn't have caused a problem upon restarting the game those saved var files where reported as corrupt and removed leaving me with new blank saved vars.

    So myself and a friend created a AU3 script to backup the WTF folder, parse each .lua file and remove the offending CR LF from the beginning of each file that contained it.

    I don't know if this is what is causing your problem or if anyone has even had a problem such as mine, but if you would like I could attach the AU3 file upon request.
    Posted in: General Chat
  • 0

    posted a message on Broker_InstanceInfo error
    you could add local self = InstanceInfo to the InstanceInfo.lua, but I would suggest just getting a different LDB plugin that handles the 10/25 norm and the 10/25 heroic format.

    SavedInstances or Am I locked out? work great and are actively developed.
    Posted in: AddOn HELP!
  • 0

    posted a message on Raid/Instance-ID at Fubar
    whoops, don't know how I managed that...at least the link was correct :p
    Posted in: Addon Ideas
  • 0

    posted a message on Raid/Instance-ID at Fubar
    You could just use Broker2Fubar and choose from one of the many RaidID LDB addons, I personally like and use SavedInstances.
    Posted in: Addon Ideas
  • 0

    posted a message on LuaTexts Official Thread
    I am sure there is a better way[PHP]
    if (string.len(Name(unit)) > 20) then
    TruncName = (string.sub(string.upper(Name(unit)), 1, 20) .. "...")
    else
    TruncName = string.upper(Name(unit))
    end
    return '%s %s%s%s',TruncName,Angle(AFK(unit) or DND(unit))[/PHP]
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    with pb4 using healthbar custom color negates all other color settings, such as tapped. Is there something I am missing? I would think that colors dead, dc and tapped should always take precedence over custom colors.
    Posted in: Unit Frames
  • 0

    posted a message on Distributing fonts with addons
    Quote from Elkano
    I'm not allowed to commit a batch script to svn so I'll have to find a solution for that, first.
    How about using a perl script for your lua file generation? Though not every windows user would have the ability to run this file it appears the svn server takes them.
    Posted in: General Chat
  • 0

    posted a message on Frequent Disconnects, help!
    Quote from Xinhuan
    There, you just listed your problem. WoW requires about 16 kb/sec down bandwidth when in a 25-man raid, and you only have 7k. Yes, that much activity and combat logs is generated from 25 people + the number of mobs nearby in active combat.

    You should bring up this issue with your Internet Service Provider.

    I noticed the same thing, but I would suspect he is using K to represent thousand(7000kbps). As far as I know the requirments for World of Warcraft is 56.6kbps(*6.6kBps) modem.
    Quote from WoW FAQ »
    Is the game playable over a dial-up connection?
    Yes, a 56.6k modem or higher is required.

    Though a broadband connection is recommended in other Blizzard system requirement FAQ's

    Edit: Slow poke post
    Posted in: AddOn HELP!
  • 0

    posted a message on UI Screenshots - Show us what you use!
    Solo IC


    Raid OOC


    Raid IC
    Posted in: General Chat
  • To post a comment, please or register a new account.