• 0

    posted a message on PlaySoundKitID
    Unless something has changed since I put the page up on wowpedia for PlaySoundKitID you should be able to stop the sound by using the returned sound handle (2nd return) with StopSound
    Posted in: AddOn HELP!
  • 0

    posted a message on Direction Arrow/Healbot compatability
    He probably means this addon
    http://www.wowace.com/addons/direction-arrow/

    It has an alpha that appears to be 6.x compatible, I was never a user of the addon myself so can't say anything further.

    An arrow on raidframes addon that covers a very specific niche (recent versions also allow enabling in-range arrows too) and works great (as all Gello's addons) is Mouseover Out of Range Pointer

    That might be a good target for tweaking, expanding on the feature and I expect it will work on any unit frame that resolves to a valid unitID.
    Posted in: Addon Ideas
  • 0

    posted a message on Adventurer's Guide Addon Idea/Request
    This would make sense as an in-game addon companion to http://www.wowhead.com/planner

    But then since addons can't be monetized I'd expect the server-side stuff that the addon would need to get to make its suggestions to come under premium features.

    In any case I'd say the best chance of this happening realistically would be as an extra feature of the wowhead client (working with an in-game addon to bring the planner recommendations in-game).

    Maybe pitch your idea to them.
    Posted in: Addon Ideas
  • 0

    posted a message on Equipment Set Overlay
    EquipSee: http://wow.curseforge.com/addons/equipsee/files/
    Posted in: Addon Ideas
  • 0

    posted a message on pkgmeta -- Specifying Git repo subfolders?
    So you have a mess on your hands
    Not entirely relevant but always useful :D
    Posted in: General Chat
  • 0

    posted a message on WeakAuras2 problem
    Grab the bottom left corner with the mouse and drag it out.

    In the future avoid alt-tabbing out of the game with the options window showing,
    but if it happens again now you know how to fix it.
    Posted in: AddOn HELP!
  • 0

    posted a message on Missing icons when switching to full screen
    That is most likely an issue with your gfx card/drivers not handling a restart of the graphics engine properly.

    I used to have that issue with an older card as well as when doing /reloadui and alt-tab out of wow before the loading screen finishes (ie the drawing of textures when entering the world was happening in a background application)

    I don't think you can do anything in the game to "solve" this, it's on the hardware/driver side.
    Posted in: AddOn HELP!
  • 0

    posted a message on Why won't this work???
    Quote from Linera
    MyUIVersion does save to savedvariables.
    I have Lua errors turned on in Interface Options. I get no error messages with my addon.
    In other words your problem has been solved from my very first reply but you chose to ignore it.
    The secure template doesn't contain the visual elements of a button.
    You need to also inherit from a template that provides those or add all the textures and stuff manually.

    I have given you examples of how to do multiple inheritance already and Phanx has added more details.
    Posted in: Lua Code Discussion
  • 0

    posted a message on Why won't this work???
    I don't have access to the game to test, only thing that looks wrong in your code is that "Center" in SetPoint?
    Not sure if it's case sensitive but try "CENTER".

    My first comment is absolutely a problem with your original code but maybe there's more I can't spot.

    Where / when is that snippet called?
    Are you sure it is running?

    What happens if you purposely make the button a global (this is bad) just for testing purposes and run the snippet from the command-line?

    Example:
    /run myAwfulGlobalBtn = CreateFrame("Button", "myButton", UIParent, "SecureActionButtonTemplate,ActionButtonTemplate")
    /run myAwfulGlobalBtn:SetAttribute("action", 1)
    /run myAwfulGlobalBtn:SetSize(50,50)
    /run myAwfulGlobalBtn:SetPoint("CENTER",UIParent,0,0)
    /run myAwfulGlobalBtn:Show()
    Posted in: Lua Code Discussion
  • 0

    posted a message on Why won't this work???
    SecureActionButtonTemplate is not a visible template.
    You can inherit from multiple templates in the CreateFrame call or you'll have to add the button textures, text etc manually.

    Example:
    local btn = CreateFrame("Button", "myButton", UIParent, "SecureActionButtonTemplate,ActionButtonTemplate");

    or
    local btn = CreateFrame("Button", "myButton", UIParent, "SecureActionButtonTemplate,UIPanelButtonTemplate");
    should both create secure buttons that are also visible.
    Posted in: Lua Code Discussion
  • 0

    posted a message on Modifying EditBox text /tar command blocked by Blizzard.
    Several slash commands are secure or protected or requiring a hardware event or a combination of those (all the target variations, focus, trade, etc etc)

    You cannot mess with those and not get taint and action blocked errors.

    What you can do however is detect the "/" (start of a command) in a message and whether what follows is a secure command and avoid handling those cases.

    You can look at my LineSplit addon for an example.
    I don't do transliteration but it's a similar problem and it's small enough for the code to be easy to follow.
    Posted in: Need Help?
  • 0

    posted a message on localize double quotes
    You can escape the double quotes with \" or use the alternate string delimiters.
    1. 'random example \"quote\"'
    2. [[random example "quote"]]
    Posted in: Lua Code Discussion
  • 0

    posted a message on Could I borrow one reward point? :(
    I'll spot you one.
    (It's not a loan btw, don't be silly :P)
    Posted in: Need Help?
  • 0

    posted a message on Custom marks on the main map
    HandyNotes
    Posted in: AddOn HELP!
  • To post a comment, please or register a new account.