• 0

    posted a message on SmartRes2 Official Forum
    Neither of those is correct the way that line originally was is correct. target is undefined in the verifyUnit() function as is unit in the 2nd function when you changed everything else to unitId.
    Posted in: General AddOns
  • 0

    posted a message on SmartRes2 Official Forum
    Also the reason it is saying everyone is alive is that you defined the variable AFTER the code that uses it. Should be:

    local raidUpdated
    
    function SmartRes2:RAID_ROSTER_UPDATE()
        raidUpdated = true
    end


    It is still trying to res the person I just ressed though.
    Posted in: General AddOns
  • 0

    posted a message on SmartRes2 Official Forum
    Well one definite problem is:

    tinsert(waitingForAccept, unit)

    Should be formatted like this:

    waitingForAccept[target] = { target = target, sender = sender, endTime = doingRessing[sender].endTime }
    Posted in: General AddOns
  • 0

    posted a message on ZOMGBuffs Official Thread
    Hmmm I have turned PP comms back on and haven't been seeing issues anymore. Same for my guildies.
    Posted in: General AddOns
  • 0

    posted a message on SmartRes2 Official Forum
    And they didn't all release I assume?
    Posted in: General AddOns
  • 0

    posted a message on tomQuest2
    Thanks:)
    Posted in: General AddOns
  • 0

    posted a message on tomQuest2
    Any chance of adding a global font that applies that font to all possible font choices?
    Posted in: General AddOns
  • 0

    posted a message on LibHealComm-4.0
    Assuming it gets tagged of course.
    Posted in: Libraries
  • 0

    posted a message on Friend/Guild list broker addon??
    Me too.
    Posted in: AddOn HELP!
  • 0

    posted a message on LibQTip
    "|c00FFFF00"
    Posted in: Libraries
  • 0

    posted a message on LibQTip
    Hmm looking at his code seems pretty much the same. Guess I will do it the old fashioned way lol.
    Posted in: Libraries
  • 0

    posted a message on LibQTip
    Here's a code bit that doesn't seem to change the line color:

               local r,g,b = 0,1,0
                local y, x = tooltip:AddLine()
                tooltip:SetCell(y, 1, data.name)
                tooltip:SetCell(y, 2, SecondsToTime(time, db.precision))
                tooltip:SetLineColor(y, r, g, b)
                tooltip:SetLineScript(y, "OnMouseDown", mod.HandleTTClick, data.name) 
    Posted in: Libraries
  • 0

    posted a message on LibQTip
    How do you get SetLineColor(), SetCellColor() etc to work? Or do they only work on prototypes? Don't seem to do anything for me?
    Posted in: Libraries
  • 0

    posted a message on HeadCount - Raid attendance and loot tracker
    Quote from Meebo

    I made sure to run taint logging prior to a full run to see if there was a mod causing it issues but all i got was MorgDKP2 causing taint to the FriendsFrame


    Really?
    Posted in: Raid AddOns
  • 0

    posted a message on Just a few more questions, please
    One problem I see is that englishclass is capitalized so your keys in self.resSpells should also be capitalized. Are you using self.resSpells for something else? Could just change it to ["PRIEST"] = true,["ROGUE"] = false etc and save some spell lookups.
    Posted in: Lua Code Discussion
  • To post a comment, please or register a new account.