• 0

    posted a message on Internal server error when trying to push mercurial

    It's not critical for me, just inconvenient.

     

    Still happening today :(

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Internal server error when trying to push mercurial

    So I was able to push a few successful changes after the migration using hg (so I know it has worked before), but today all I'm getting are these same 500 errors. No changes to the settings on my end. :(

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Packaging Errors with the new repo

    Just curious, have you changed to filter pulldown on the Files Page for "Status" to something other than "Normal"?

     

    With the original issue I was reporting at first I thought the packages were disappearing into the ether, but changing the Status display showed that they were actually rejected.

    Posted in: WoW Sites Feedback
  • 0

    posted a message on New packager
    Quote from curseuser1 >>

     

     

    Now I have to make a new account on GitHub or BitBucket to go along with my curse.com and curseforge.com accounts?  Do I really need more accounts just to publish my mods?  How is this better?

     Just FYI, Curse hosted repos are still there, under settings -> source. Select "Curse Forge" then select use existing, create new svn/mercurial/git, or restore archived
     
     
    Posted in: WoW Sites Feedback
  • 0

    posted a message on Packaging Errors with the new repo

    @Torhal ok, so removed the latest tag,  added it again tagging as "v2.7.1.1-Beta", and pushed to trigger the packager. The system attempted to create two packages, calling the first "v.2.7.1.1-Beta-nolib" which was "rejected for being duplicate", the second was called "v.2.7.1.1-Beta" which was packaged successfully and appears on the file list as approved now. I have no idea why the packager attempted to create that first "nolib" package.

     

    So one bit of weirdness that remains, even though the tag contained "Beta" as a keyword, the package has flagged the file as "Release" in the file list and is now being pushed via the curse.com website and curse client in the release line instead of the beta line >.<

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Packaging Errors with the new repo

    @Torhal will give it a try here in just a bit and report back. 

     

    @curseuser1 they show up in the notifications button on the top right of the screen. They seem to clear after you log out of your session though. You should also get a daily digest with the same reports that show up in the notifications. 

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Packaging Errors with the new repo

    So I updated my repo in SourceTree from the old ssh://hg@hg.curseforge.com format to the new repo, https://repos.curseforge.com/wow/prospect-me/, and I keep getting failures on the packaging when I try and push a new release.

     

    From my end, nothing structural has changed - the directory structure and files are all the same. When I browse the remote in SourceTree, it appears as though everything has been pushed successfully, but I've gotten a few different errors from Curse Forge. The main error seems to be about some invalid file or empty folder in a root directory and something to do with a toc.xml error, but when I browse the repo directly I don't see anything that looks out of the ordinary.

     

    There's also some weirdness in the way tags and build names are being created and flagged on the files, but that's secondary to actually getting things packaged.

     

    Is there something I'm missing? Or is this just growing pains from the migration?

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Bag Ends
    Thank you contrebasse! I was thinking about sending you a PM since you did the first bit of the translation for the earlier version, but I didn't want to bother you :)

    I speak a bit of french, but am nowhere near fluent enough to provide a natural sounding translation. For example, the best translation I could think of for "outline" was "encercler" but I think "bordure" is way better :)
    Posted in: General AddOns
  • 0

    posted a message on Bag Ends
    That's what I thought, but Phanx said:

    Quote from Phanx
    Currently, anyone trying to put in translations has to switch back and forth between the locale they're working on, and English, to see what the actual text should be.


    Maybe I misunderstood?
    Posted in: General AddOns
  • 0

    posted a message on Bag Ends
    Yeah - changing the way the localization variables are handed is on my to do list (as I mentioned in my previous post), unfortunately it's a matter of time and energy more than anything. I'm going to end up with a table method (L["Count Full Bag Slots"], etc) when I get around to making the change.

    I thought the curse localization table site showed the key + the original language (english) + context all on the same screen? I haven't really used it much other than for this project.
    Posted in: General AddOns
  • 0

    posted a message on Bag Ends
    Lots of changes! If anyone happens to speak a foreign language, I'd greatly appreciate any translations people may have: http://wow.curseforge.com/addons/bag_ends/localization/

    v1.0 includes changes to the way bags are colored and adds support for bank bags (among other things)!
    v1.1 - Adds basic LDB support since I had a couple of people ask about it.

    Bag Ends does not include Data Broker, the user must have a display addon (like Bazooka) installed for the functionality to work. Currently Data Broker display mirrors the standard bag info display.
    Posted in: General AddOns
  • 0

    posted a message on Bag Ends
    Uploaded Bag Ends v0.9.3, it's awaiting approval on curse forge.

    This version supports localization. I set it up using a legacy method, so i'll probably end up changing/updating it later to something a little sleeker - but it works.

    If anyone feels like translating a few strings: http://wow.curseforge.com/addons/bag_ends/localization/
    Posted in: General AddOns
  • 0

    posted a message on Bag Ends
    For the purpose of my evaluation calls in the draw update 1/nil evaluates the same as true/false - that being said, it's good to know should a bool ever become mandatory further down the road :)
    Posted in: General AddOns
  • 0

    posted a message on Bag Ends
    New version of BagEnds up (0.9.2) - now handles slash commands! :)

    I cleaned up some of the configuration update stuff too. I think i was half asleep when I coded it originally >.<

    if(BagEndsColorToggle:GetChecked()) then
    BagEndsConfig.colorText = true
    else
    BagEndsConfig.colorText = false
    end


    became

    BagEndsConfig.colorText = BagEndsColorToggle:GetChecked()


    Genius, I know... ;)
    Posted in: General AddOns
  • 0

    posted a message on Bag Ends
    Put up a new version (0.9.1) with some code clean up and added the tooltips.

    Still needs more clean up, but it's a work in progress :)
    Posted in: General AddOns
  • To post a comment, please or register a new account.