• 0

    posted a message on Skinner

    In reply to Jncl:

     It works now! The color seems weird (it's just plain white, instead of regular blue), but I'll take it.
    Thanks a lot for putting so much effort into this.
    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Ok, so now the bar kinda shows, but it doesn't move. It shows as if it was full all the time. (might not be noticeable because the key is just started in the screenshot, but it stays just the same even when the time is about to expire).

     

     

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    In reply to Jncl:

     Probably the MoveAnything (which is also what gave me the ability to see the framestack).
     It didn't work when MoveAnything was disabled tho. If that's any help.
     
    From what I was able to gather, the actual non-skinned bar is the one that says ScenarioChallengeModeBlock.StatusBar
    Posted in: General AddOns
  • 0

    posted a message on Skinner

    In reply to Jncl:

     Is this the thing you need?

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Hi there. Not sure if it's any helpful for me to remind you constantly, but the Mythic+ timer bar still doesn't show even after latest changes. I take it's a tough one to solve.

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Mythic+ Timer Bar still doesn't show. Other bars work just fine.

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Getting this a lot lately. Seems related to BNet toasts when player login:

     

    20x Skinner\UtilFuncs.lua:615: attempt to index field 'sf' (a nil value)
    Skinner\UtilFuncs.lua:615: in function <Skinner\UtilFuncs.lua:614>
    (tail call): ?
    [C]: in function `Play'
    FrameXML\AlertFrames.lua:700: in function `AlertFrame_PlayOutAnimation'
    FrameXML\AlertFrames.lua:734: in function `AlertFrame_PlayOutroAnimation'
    FrameXML\AlertFrames.lua:742: in function `AlertFrame_PlayAnimations'
    FrameXML\AlertFrames.lua:748: in function `AlertFrame_ShowNewAlert'
    FrameXML\BNet.lua:294: in function `ShowToast'
    FrameXML\BNet.lua:306: in function `AddToast'
    FrameXML\BNet.lua:67: in function <FrameXML\BNet.lua:59>

    Locals:
    this = <unnamed> {
    0 = <userdata>
    animOut = <unnamed> {
    }
    Play = <function> defined =[C]:-1
    OnFinished = <function> defined @FrameXML\SocialToast.lua:3
    }
    (*temporary) = nil
    (*temporary) = nil
    (*temporary) = nil
    (*temporary) = "attempt to index field 'sf' (a nil value)"

     

     

    Posted in: General AddOns
  • 0

    posted a message on Skinner

     

    Quote from Jncl >>

     

    Update ObjectivesTracker Status bars code

     

    beta7.27219.2

     Should that have fixed the Mythic+ timer I mentioned? Just asking because I see it still empty. Not sure if perhaps it's a different kind of bar, since other things like quests and % trackers (even the M+ trash % tracker) works just fine.
     
    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Any idea why the bar for the Mythic+ timers (the bar) doesn't show? Not sure if it's a bug or some addon is conflicting. 

     

    Here's the example 

     

    EDIT: Disabled every addon but skinner, Ace and Shared Media , and the bar still doesn't show, so it doesn't look like an addon comflict (I use AngryKeystones so I thought that could be it).

    EDIT2: Enabled BugSack while everything else was disabled, and no bugs show.

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    In reply to Jncl:

     Seems to have fixed the class-colored gradient just fine.
    Thanks again!
    Posted in: General AddOns
  • 0

    posted a message on Skinner

    In reply to Jncl:

     Awesome. Thanks for looking into it. I'll report once the new version is out.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Quote from Jncl >>

    In reply to Metallan:

     Hi,
        I'm not seeing this behaviour, the Class Coloured Gradient changes when I change character class between a druid and a rogue. It may be a conflict with another Addon.
     
     I think the issue could be related to me changing something to the color (like alpha I think) after choosing class-colored. Even if I change chars it remains the same one. If I uncheck and check the option in a different char, it acquires the new color, but it persists after changing to a different one (even if the second time I uncheck/check I touch nothing else).
    So, in short, I think what happened was this:
    1. I selected class-colored gradient on a first char (class #1)
    2. Changed the color that was just selected (make it darker, change alpha, something)
    3. Swap to a different class char number 2
    4. Notice it was previous (class #1) color.
    5. Uncheck class colored gradient, check it again. Gradient becomes class #2 colored.
    6. Swap to any other class char #3. It still has previous (class #2 color).
    7. Repeat steps 5 and 6 forever and ever.
     
    Perhaps that's intended, perhaps it's something that can be fixed. I'll try and see if resetting everything back to default values fixes the gradient.
    Hope this helps.
     EDIT: I was tinkering with the options and the code a bit, and it seems as if it works properly ONLY if the class-colored border is also selected. Around line 144 the code for the gradient checks for
    if self.prdb.ClassColour and self.prdb.ClassClrGr
    And it seems like ClassColour is actually the class-colored border option.
    EDIT2: Confirmed that removing that condition from the if solves the issue with the gradient. Not sure if it breaks anything else. (doesn't seem like it).
    EDIT3: Seems like the same happens with class-colored Tooltips, but not with the background, so I'm not sure if that's intended or not. Just letting it out there so you can check it.
    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Not sure if it might be something related to other settings, but when I choose "Class-colored gradient", and then switch characters, the gradient remains with the color of the class I was playing when I enabled the setting.

    Posted in: General AddOns
  • To post a comment, please or register a new account.