CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on AdiBags - a bag addon
    Would love to have the guild bank window look the same as the character bag and bank windows. Its so huge, ugly and unfiltered compared to the awesome ones from AdiBags.
    Note, I'm not asking to be able to remotely view the guild bank(I would NOT want that due to high resource useage), just when its opened to have the same skin and filter options as the character bag and bank windows.
    Otherwise, very very cool indeed.
    Posted in: General AddOns
  • 0

    posted a message on ElkBuffBars v2 (finally Ace3 version)
    Quote from Nandini
    You may have mouse input disabled on the player debuffs group. Try checking that option.


    I feel like an idiot, I found that out a few hours later after posting.
    Thanks though, now everything is perfect :D
    Posted in: General AddOns
  • 0

    posted a message on ElkBuffBars v2 (finally Ace3 version)
    I love this addon, makes it so much easier to keep your dots etc as it shows them so much more clearly than the std. UI.

    The only thing I would request is that when you hover the mouse pointer over the player debuffs that the tooltip appears explaining what that debuff is, it works for debuffs I place on my target but not debuffs placed on myself, I like to read the spell tooltips sometimes to see how to react to a debuff placed on me, that's why.

    Thanks!
    Posted in: General AddOns
  • 0

    posted a message on RaidBuffStatus
    I just did a 10 and 25 man vault back to back with all possible classes, no problems, did not try whispering people though.
    Also tried mousing over those two previously problematic icons when solo, no errors either, very nice!
    Posted in: Raid AddOns
  • 0

    posted a message on RaidBuffStatus
    Hi there, awesome, you changed it so fast.
    I did try r212 in EoE and it works fine, although to be honest I had already changed the global variable names in the GiveMe... addons so they weren't conflicting anymore anyway.

    What I'm saying is that RBS hasn't been broken by you changing the variable types.
    The only remaining errors I get in r212 as before are the "peoplegotvigilance" and "slackingpaladinsnames" ones.

    Good work thus far, this is definitely one sweet raiding addon, I have some guildies jokingly annoyed with me for pointing out they are missing flasks/well fed buffs etc :)

    If you want I can go back and re-install the original GiveMe... addons to see if the global variable conflict is resolved, I just didn't think it necessary.
    Posted in: Raid AddOns
  • 0

    posted a message on RaidBuffStatus
    Your welcome, I thought the more information I give the better you can locate the issue which you did, that's great.

    I run a lot of addons and try new ones all the time so I guess that's why I eventually ran into this problem.

    I ran a 25man Naxx and a 10man Naxx today and turned the other addon off so I could use RBS, very nice, good job!

    Now that you pointed out the problem I'm just going to go and rename that variable in GiveME... so that I can use both, until you work in one of those fixes you mentioned.

    Thanks!
    Posted in: Raid AddOns
  • 0

    posted a message on RaidBuffStatus
    To answer your question I am using an English Client

    Ok, so, after about 2 hrs and 50 login/logout attempts and help from guildies who were willing to be guinea pigs I found out the following ;D

    (the below is related to version 3.86 with libs)

    I started off testing with ONLY RBS addon enabled.

    If not in a raid when you mouse over the icon in Pic: RBS 2 you get the following error:
    [2009/04/05 12:02:16-1971-x1]: RaidBuffStatus-3.86\Buffs.lua:1103: attempt to get length of field 'peoplegotvigilance' (a nil value)


    If not in a raid when you mouse over the icon in Pic: RBS 1 you get the following error:
    [2009/04/05 12:02:53-1971-x4]: RaidBuffStatus-3.86\Buffs.lua:2889: attempt to get length of field 'slackingpaladinsnames' (a nil value)


    If in a raid but no paladin is present when you mouse over the icon in Pic: RBS 1 you get the following error:
    [2009/04/05 12:02:53-1971-x4]: RaidBuffStatus-3.86\Buffs.lua:2889: attempt to get length of field 'slackingpaladinsnames' (a nil value)


    Now, it seems that I found the culprit addon that is conflicting with RBS.
    When the "GiveMe" range of macro addons such as GiveMeHealth, GiveMeMana etc. are on I have the conflict.
    I am currently using version 1.52 beta which is the latest and obtained from http://wow.curse.com/downloads/wow-addons/details/giveme.aspx

    I can use the GiveMe... addons fine with many addons but not RBS, likewise, I can use RBS fine with many addons but not GiveMe...

    When RBS and GiveMe... are enabled I get the following error when logging in:
    [2009/04/05 12:36:34-1983-x3]: RaidBuffStatus-3.86\Core.lua:1621: bad argument #1 to 'pairs' (table expected, got number)
    RaidBuffStatus-3.86\Core.lua:1621: in function `ReadRaid'
    RaidBuffStatus-3.86\Core.lua:1254: in function `DoReport'
    RaidBuffStatus-3.86\Core.lua:2607: in function `?'
    CallbackHandler-1.0-3:146: in function <...ist\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:146>
    <string>:"safecall Dispatcher[1]":4: in function <[string "safecall Dispatcher[1]"]:4>
    <in C code>: ?
    <string>:"safecall Dispatcher[1]":13: in function `?'
    CallbackHandler-1.0-3:91: in function `Fire'
    AceEvent-3.0-3:73: in function <...s\AckisRecipeList\libs\AceEvent-3.0\AceEvent-3.0.lua:72>


    *Note above that the addon "AckisRecipeList" is mentioned, well, specifically the "AceEvent-3.0.lua. If I disable AckisRecipeList then the error simple mentions the next addon which uses the AceEvent-3.0.lua library so its a library related issue and not specific to an addon itself.

    When RBS and GiveMe... are enabled I get the following error when I click on the minimap button to open RBS (the result is that RBS will not open):
    [2009/04/05 12:36:38-1983-x1]: RaidBuffStatus-3.86\Core.lua:1621: bad argument #1 to 'pairs' (table expected, got number)
    RaidBuffStatus-3.86\Core.lua:1621: in function `ReadRaid'
    RaidBuffStatus-3.86\Core.lua:1254: in function `DoReport'
    RaidBuffStatus-3.86\MiniMap.lua:52: in function <Interface\AddOns\RaidBuffStatus\MiniMap.lua:46>


    Comments to the above errors:

    The strange thing is as far as I can tell the GiveMe addons do not use any ACE libraries so I'm not understanding where the conflict is coming in.

    Just guessing but I think the errors shown in Pics RBS 1 and RBS 2 are simply due to some kind of lack of check of whether one is in a raid or if a paladin is present or not, or if that code is present then for some reason its not currently working as planned.

    I'm interested to hear your thoughts on what could be the conflict. Both your RBS and GiveME... are such great addons it would be wonderful to get them working at the same time.

    Pic: RBS 1 (below)

    Pic: RBS 2 (below)
    Posted in: Raid AddOns
  • 0

    posted a message on RaidBuffStatus
    Thanks for getting back to me.

    I have tried installing both from WoW Matrix and also manually downloading and installing from wowace.com, never from curse or using the curse client.

    I always use the version with the library included.
    The version from which the errors posted above originate is 3.86, although I've tried many different versions over the months.

    I am going into a Naxx run right now (and so wish I had this addon working too, lol) so I'll have to try my hand at disabling all my other adds except RBS after the run.
    I have many many ace addons so far all working in harmony so I'll try and see if i can find out if it is indeed a conflict with another.

    I will report my findings asap, most likely by tomorrow midday depending on the length of this run.
    Posted in: Raid AddOns
  • 0

    posted a message on RaidBuffStatus
    Hi, I really like the looks of this addon and have tried many similar.
    I have actually tried this addon many times of the last year but never have I been able to get it to work, always many many errors for me, each time I try a new version I make sure to delete the .lua file from the wtf folder.

    Anyway, today I tried the latest version and decided to post to see if I can get this running once and for all, here are the first few errors:

    [2009/04/04 12:36:06-1958-x4]: RaidBuffStatus-3.86\Buffs.lua:1103: attempt to get length of field 'peoplegotvigilance' (a nil value)


    [2009/04/04 12:39:07-1958-x3]: RaidBuffStatus-3.86\Core.lua:1621: bad argument #1 to 'pairs' (table expected, got number)
    RaidBuffStatus-3.86\Core.lua:1621: in function `ReadRaid'
    RaidBuffStatus-3.86\Core.lua:1254: in function `DoReport'
    RaidBuffStatus-3.86\Core.lua:2607: in function `?'
    CallbackHandler-1.0-3:146: in function <...ist\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:146>
    <string>:"safecall Dispatcher[1]":4: in function <[string "safecall Dispatcher[1]"]:4>
    <in C code>: ?
    <string>:"safecall Dispatcher[1]":13: in function `?'
    CallbackHandler-1.0-3:91: in function `Fire'
    AceEvent-3.0-3:73: in function <...s\AckisRecipeList\libs\AceEvent-3.0\AceEvent-3.0.lua:72>


    [2009/04/04 12:41:19-1958-x3]: RaidBuffStatus-3.86\Buffs.lua:2889: attempt to get length of field 'slackingpaladinsnames' (a nil value)


    [2009/04/04 12:42:15-1958-x2]: RaidBuffStatus-3.86\Core.lua:1621: bad argument #1 to 'pairs' (table expected, got number)
    RaidBuffStatus-3.86\Core.lua:1621: in function `ReadRaid'
    RaidBuffStatus-3.86\Core.lua:1254: in function `DoReport'
    RaidBuffStatus-3.86\Core.lua:2553: in function `ToggleCheck'
    RaidBuffStatus-3.86\Core.lua:2885: in function `ButtonClick'
    RaidBuffStatus-3.86\Buffs.lua:2138: in function <Interface\AddOns\RaidBuffStatus\Buffs.lua:2137>

    Any insight would be appreciated, if you need more info, let me know.
    Posted in: Raid AddOns
  • 0

    posted a message on ag_unitframe question
    I also downloaded and tried it yesterday and abandoned it because of that reason, seems to not support party targets as standard and I could find no extension/plugin to give it that capability either.
    Posted in: AddOn HELP!
  • To post a comment, please or register a new account.