• 0

    posted a message on Need-to-know Addon for classic?

    The author "Kitjan, lieandswell" update the addon called Need To Know (NTK), and did so recently for 8.0 client.

    However there has been no news about the addon for classic client and it didnt work on beta test.

     

    Anyone who can assist or know any updates that might give me some hopes?

     

    /MB

    Posted in: AddOn HELP!
  • To post a comment, please or register a new account.