CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on Postal Drop Down List No Longer Works (Addendum) Seems That Log In Times (CRZ Maybe) Might Be Having An Impact On The Addon.

     

    One other thing:

     

    I've noticed a pattern with Postal as well.

     

    The Addon works during the day (it's been working for me since around 8:00 A.M. E.S.T Today), but it stops working at night (sometime after 7:00 P.M. E.S.T.). Postal has consistently followed that same pattern on December 22, 23, 24 and 25. It's working now (December 26 A.M.), but I'll have to log into the game later on tonight to see what happens.

     

    I'm wondering if CRZ might be having an impact on the functionality of the Addon (I know that sounds strange, but it's Blizzard... so who KNOWS whether or not that's the case).

     

    It's an odd pattern... I'm just trying to consider all of the possibilities so to "rule out" what may be or is not the problem.

     

     Addendum:

     

    Today (December 26th, 2019) Postal was working in the morning (I logged in at around 8:00 A.M. E.S.T.)  and it continued to work throughout the day. I logged in again at approximately 7:00 P.M. (E.S.T.) this evening and the Addon was no longer working.

     

    I'll log in tomorrow in the A.M. to see what happens, but based on the pattern that I've been following I suspect that Postal will be working again in the morning.

     

    Morning update:

     

    Logged into the game at 5:00 A.M (E.S.T.) December 27th. Postal was working again.

     

    Posted in: AddOn HELP!
  • 0

    posted a message on Postal Drop Down List No Longer Works (Addendum) Seems That Log In Times (CRZ Maybe) Might Be Having An Impact On The Addon.

    Thanks for letting me know that.

     

    I sent a PM to Nevcairiel with the hope that I might receive a response which will provide me with some sort of information (which will let me "fix" the Addon so that it's usable all of the time).

    Posted in: AddOn HELP!
  • 0

    posted a message on Postal Drop Down List No Longer Works (Addendum) Seems That Log In Times (CRZ Maybe) Might Be Having An Impact On The Addon.

    I sent a private message to the developer earlier today. At this point Postal is buggy and inconsistent insofar as functioning properly is concerned.

     

    Fact is, sometimes it works but MOST of the time it doesn't (as I mentioned in an earlier post, this addon malfunctions even if it's the only one installed in the game).

     

    I'm HOPING that Xinhuan (the developer) might take a look at it and see what the issue(s) might be.

     

    If I could fix it on my own I would, but when it comes to Lua/XML I don't have a clue.

    Posted in: AddOn HELP!
  • 0

    posted a message on SexyMap - A tiny bundle of minimap awesomeification

    I'm too sexy for my map.

    Posted in: Map/Minimap AddOns
  • 0

    posted a message on Postal Drop Down List No Longer Works (Addendum) Seems That Log In Times (CRZ Maybe) Might Be Having An Impact On The Addon.

    So I started to have problems with Postal once again. It's buggy at this point, and doesn't want to work with WoW 8.2.5.

     

    After I got all of my Addons straightened out and reconfigured, I noticed that Postal would work on occasion but would STOP working once I exited the game the game and logged back in.

     

    I was thinking that there might have been a conflict between Postal and one of my other Addons, so I did the following:

     

    Saved my Interface and WTF Folders for both Retail and Classic to an entirely different drive.

     

    Uninstalled Retail and Classic from my PC, and completely deleted the WoW Game folder from the Program Files (86) Folder (all traces of WoW being installed on my PC were eliminated).

     

    Did a clean install of WoW Retail (didn't install Classic yet... I wanted to make sure that there were absolutely NO conflicts whatsoever).

     

    Once Retail was installed I logged into the game (on my Main) long enough to create a new Interface/Addons Folder... which would be needed for Twitch.

     

    Installed three and ONLY three Addons from Twitch: BugGrabber, BugSack, and Postal. With Postal as really being the only Addon installed into my Addons Folder (as you know BugGrabber and BugSack are specifically designed to discover any Addon errors)... I got plenty of them (Drop Down List STILL wouldn't work).

     

    I have no idea what any of this means, but I did notice that if I disabled the Black Book (and re-enabled it) I would always get error messages... and if I attempted to use the drop down menu the same thing would happen.

     

    Anyway... maybe you can figure all this out. I can't make heads or tails of it:

     

    8x FrameXML\FriendsFrame.lua:2294: attempt to index local 'accountInfo' (a number value)

    FrameXML\FriendsFrame.lua:2294: in function `CanCooperateWithGameAccount'

    Postal\Modules\BlackBook.lua:370: in function `SortAndCountNumFriends'

    Postal\Modules\BlackBook.lua:457: in function `initFunction'

    FrameXML\UIDropDownMenu.lua:76: in function `UIDropDownMenu_Initialize'

    FrameXML\UIDropDownMenu.lua:1060: in function `ToggleDropDownMenu'

    Postal\Modules\BlackBook.lua:41: in function <Postal\Modules\BlackBook.lua:36>

     

    Locals:

    accountInfo = 8

    (*temporary) = nil

    (*temporary) = nil

    (*temporary) = "attempt to index local 'accountInfo' (a number value)"

    playerFactionGroup = "Horde"

     

    FrameXML\FriendsFrame.lua:2294: in function `CanCooperateWithGameAccount'

    Postal\Modules\BlackBook.lua:370: in function `SortAndCountNumFriends'

    Postal\Modules\BlackBook.lua:457: in function `initFunction'

    FrameXML\UIDropDownMenu.lua:76: in function `UIDropDownMenu_Initialize'

    FrameXML\UIDropDownMenu.lua:1060: in function `ToggleDropDownMenu'

    Postal\Modules\BlackBook.lua:41: in function <Postal\Modules\BlackBook.lua:36>

     

    Locals:

    accountInfo = 8

    (*temporary) = nil

    (*temporary) = nil

    (*temporary) = "attempt to index local 'accountInfo' (a number value)"

    playerFactionGroup = "Horde"

     

    5x Postal\Modules\BlackBook.lua:57: Usage: RegisterEvent("eventname", "methodname"): 'methodname' - method 'AddAlt' not found on self.

    [C]: ?

    ...ack\Libs\CallbackHandler-1.0\CallbackHandler-1.0-7.lua:112: in function `RegisterEvent'

    Postal\Modules\BlackBook.lua:57: in function <Postal\Modules\BlackBook.lua:25>

    [C]: ?

    [string "safecall Dispatcher[1]"]:3: in function <[string "safecall Dispatcher[1]"]:3>

    [C]: ?

    [string "safecall Dispatcher[1]"]:9: in function <[string "safecall Dispatcher[1]"]:5>

    (tail call): ?

    ...acePostal\Libs\AceAddon-3.0\AceAddon-3.0-12.lua:558: in function <...acePostal\Libs\AceAddon-3.0\AceAddon-3.0.lua:551>

    (tail call): ?

    Postal\Postal-v3.6.0.lua:207: in function `func'

    FrameXML\UIDropDownMenu.lua:910: in function `UIDropDownMenuButton_OnClick'

    [string "*:OnClick"]:1: in function <[string "*:OnClick"]:1>

     

    34x FrameXML\FriendsFrame.lua:2294: attempt to index local 'accountInfo' (a number value)

    FrameXML\FriendsFrame.lua:2294: in function `CanCooperateWithGameAccount'

    Postal\Modules\BlackBook.lua:370: in function `SortAndCountNumFriends'

    Postal\Modules\BlackBook.lua:457: in function `initFunction'

    FrameXML\UIDropDownMenu.lua:76: in function `UIDropDownMenu_Initialize'

    FrameXML\UIDropDownMenu.lua:1060: in function `ToggleDropDownMenu'

    Postal\Modules\BlackBook.lua:41: in function <Postal\Modules\BlackBook.lua:36>

     

    Locals:

    accountInfo = 8

    (*temporary) = nil

    (*temporary) = nil

    (*temporary) = "attempt to index local 'accountInfo' (a number value)"

    playerFactionGroup = "Horde"

     

     

     

     

    Posted in: AddOn HELP!
  • 0

    posted a message on Postal Drop Down List No Longer Works (Addendum) Seems That Log In Times (CRZ Maybe) Might Be Having An Impact On The Addon.

    Hello:

     

    I BELIEVE that I may have figured out what the problem is... not sure for a fact, but I'm PRETTY sure.

     

    Although both Postal and Altoholic are out of date, they both seem to work just fine.

     

    The PROBLEM that I came across is the process in which Addons are updated (if a player uses Twitch or Minion).

     

    Since WoW Retail and WoW Classic are BOTH located in the Program Files (x86) World of Warcraft Game Folder (if you're using Windows 10) , Twitch and Minion get "confused" on occasion, and save Classic Addons into the Retail Addons Folder, and Retail Addons into the Classic Addons Folder.

     

    I noticed this ESPECIALLY on Minion.

     

    Turns out that BOTH my Classic and Retail Addons were royally screwed up (and badly I might say) for this reason.

     

    Once I figured that out I reinstalled Classic WoW (and updated my Classic Addons) and THEN installed Retail WoW (and updated my Retail Addons).

     

    After doing so, Postal, Altoholic, and all my other Addons in BOTH Games (outdated or not) worked just fine.

     

    Moral of the story for other players... if you play both Classic and Retail WoW (and use a service like Twitch or Minion to update your Addons), double check (triple check if you have to) that what you're downloading is going to the CORRECT Addon Folder for the right version of the game.

     

    Figured I'd just throw that tidbit of information out there.

     

     

     

    Posted in: AddOn HELP!
  • 0

    posted a message on Postal Drop Down List No Longer Works (Addendum) Seems That Log In Times (CRZ Maybe) Might Be Having An Impact On The Addon.

    According to the game (Retail) two addons that I use; Altoholic and Postal are both outdated (even though on Twitch they are both listed as "up to date").

     

    Well the drop down list for Postal has stopped working. I did a bit of an experiment to see if any other addon(s) might be causing any kind of conflict.

     

    I removed my Interface and WTF Folders from the WoW Retail folder (I just slid them over to my desktop and so when I logged into WoW I no longer had any addons or lua files that might have been interfering with Postal/Altoholic).

     

    Next I installed a new copy of both addons, and so when I logged into Wow Retail, those were the only two addons that the game identified as running.

     

    Following that I started to log into each one of my characters. Normally (at least in the past anyway) Postal would give me a drop down list of each character once I logged into them... and the drop down list would be available on each character (and provide me with the names of each alt regardless of the realm) after I logged into each respective character.

     

    But Postal didn't give me a drop down list at all... didn't even recognize any of my alts whether the alts were on the same realm as my main, or on a different realm.

     

    Altoholic (even though it's "outdated"), on the other hand, registered all of my alts on each realm that I play on.

     

    Now I don't know if Postal isn't providing me with a drop down list because I'm not doing something right (has something changed with the addon which requires me to select something in the addon menu? If so, I didn't see anything).

     

    Or has Postal stopped providing me with a drop down list because it's outdated and has to be upgraded to work with the current game release version?

     

    I have no idea.

     

    Posted in: AddOn HELP!
  • To post a comment, please or register a new account.