• 0

    posted a message on Autobar (Toadkiller)
    Hey Toadkiller, thanks for this great addon!

    I have a pet peeves. For some weeks now (I don't remember the exact version), the weapon buff category no longer rearrange on use even though I have the check-box checked.

    I would appreciate it if you can have a look into this.

    TIA.
    Posted in: General AddOns
  • 0

    posted a message on TradeskillInfo Official Thread
    Well, I make no promice either but I have looked at TSI a bit the first time wmrojer took a little leave of absence (BTW man, thanks for all you've done).

    Right now, I believe that he used a script to extract the recipes from WoWHead or something like that. I'll have a look this weekend to see if that can be replaced by PT3 classes. If someone can do it before me though, go right ahead.

    As for rewrite, it might be a good idea medium or long term but for now, we should look into a way to make the existing TSI up to date and fully usage fast. I saw yesterday that some Jewelcrafting designs were missing and I'm thinking other stuff must be missing to.
    Posted in: General AddOns
  • 0

    posted a message on Crafting DB for all professions on all charakters?
    TradeSkillInfo does what you want I think. It list all possible recipes from all trade and also keep track of which character (alts) can do them.

    For example, if someone ask you for a +15 Agi enchant on boots, you open TradeSkillInfo, search Agi or something like that (click directly on the trade skill) and you will see the mats and which one of your character knows how to do it or could eventually learn it.

    I use it all the time.
    Posted in: Addon Ideas
  • 0

    posted a message on PeriodicTable-3.0
    Quote from Thortok2000 »

    Quote from LaoTseu »

    Quote from Thortok2000 »

    Quest items can be found with this filter:
    http://www.wowhead.com/?items&filter=cr=5:85:6;crs=1:1:1;crv=0:0:0;ma=1

    I think gear can probably just be sorted on ArkInventory's end, doesn't need PT3 to handle it.

    The quest items category used in Autobar are for "usable" quest items like the Bomb in the Skyguard bombing run. I can see a Quest Items category useful for ArkInventory but Autobar need the subcategory of Quest Items that need to be activated or used. I don't believe there is a way to query WoWHead for those.


    Wow, this is way cool! The third query is not really object that are to be used for quest but the first two seam to cover it all.

    Is there a way to query the database and get a list of ItemID? Maybe with a little Perl script or something?

    That's easy. Takes 3 filters, though.

    http://www.wowhead.com/?items&filter=cr=107:5;crs=0:1;crv=Use:0
    http://www.wowhead.com/?items&filter=cr=107:6;crs=0:1;crv=Use:0
    http://www.wowhead.com/?items&filter=cr=107:85;crs=0:1;crv=Use:0
    Posted in: Libraries
  • 0

    posted a message on PeriodicTable-3.0
    Quote from Thortok2000 »

    Quest items can be found with this filter:
    http://www.wowhead.com/?items&filter=cr=5:85:6;crs=1:1:1;crv=0:0:0;ma=1

    I think gear can probably just be sorted on ArkInventory's end, doesn't need PT3 to handle it.

    The quest items category used in Autobar are for "usable" quest items like the Bomb in the Skyguard bombing run. I can see a Quest Items category useful for ArkInventory but Autobar need the subcategory of Quest Items that need to be activated or used. I don't believe there is a way to query WoWHead for those.
    Posted in: Libraries
  • 0

    posted a message on XLoot
    Quote from OrionShock »

    wtb Waterfall config screen :D

    You can use Niagara for that but I really don't think XLoot needs a Waterfall screen. I know that I prefer the Dewdrop one for it since it's so simple and clean. Your millage may vary for that :-).
    Posted in: General AddOns
  • 0

    posted a message on XLoot
    Since you are taking suggestion :-).

    Here's a little modification I did so that when you type /xloot, you get the option dialog instead of the command line thingy. If you really want the command line thingy, you can type /xlootc.

    In XLootOptions.lua, I replaced:

    	self:RegisterChatCommand({ "/xloot" }, self.opts)


    with

    	self:RegisterChatCommand({ "/xlootc" }, self.opts)
    
    	self:RegisterChatCommand({ "/xloot" }, function()
    		XLoot:OpenMenu(XLootFrame)
    	end)
    Posted in: General AddOns
  • 0

    posted a message on ItemValue
    This sounds very nice. I'll try it tonight.

    Are there any plans for an API that would allow another addon query ItemValue with a particular link and a particular settype? It would be real great. I'm trying to maintain ArmorCraft that allow you to compare an item with all of your alts but the valuation of the items is sadly broken and need to be completely change or rewritten. ItemValue appear to be doing the hard part of the valuation so it would be very nice to be able to use it from other addons (if you don't mind).

    Best
    Posted in: General AddOns
  • 0

    posted a message on XLoot
    Quote from Xuerian »

    LasoTseu: I'll work on that sometime, I don't remember what I changed to mess up the export handler, but I'm aware it's borked. Thanks for the alert.


    I did this to fix it:
    output = output..string.format("drop|item|%d|%d|%s|%s|%s\n", v.time, v.count, id, name, link)


    The only difference with your code is that I replace a %d for a %s for name.
    Posted in: General AddOns
  • 0

    posted a message on XLoot
    Quote from Xuerian »

    Loot monitor not working is indeed caused by SEE-Loot not getting loaded. I had a few problems with this in development, though I thought I had them fixed, seeing as I call SEE-Loot at the start of monitor.

    Farook: The offending function is called a good bit, but I don't see why it would complain. Either way, I've added a simple check before the fact that it exists... (It's calling a blizzard function depending on a blizzard value... I don't see what the big malfunction could be)

    Edit: Reverted change. Didn't help things. Try re-installing XLoot?

    LaoTseu: See above, though it doesn't do much to help. I'll Tryan look into it.

    As far as Monitor, when it DOES work, miscounting, well... I found I was adding 1 instead of the number picked up for items, so let's see if this helps it be any more accurate.




    Thanks for looking into this. I'll do more testing but I saw that you add a "AceLibrary("SpecialEvents-Loot-1.0")" a the top of XLootMonitor.lua. I think that might solve the problem. I tried it again and now SPE-Loot loads even if I install without externals. I mean that I don't have to force load it, it loads by itself like it should. Thanks a bunch.

    I have found a new problem though. When I try to export for copy, I get the following error:
    [2007/06/04 22:54:08-1767-x1]: XLootMonitor-0.7.38432\XLootMonitor.lua:350: bad argument #5 to 'format' (number expected, got string)
    XLootMonitor-0.7.38432\XLootMonitor.lua:350: in function `ExportPSV'
    XLootMonitor-0.7.38432\XLootMonitor.lua:278: in function `func'
    Dewdrop-2.0-38450 (DewdropLib):643: in function <...erface\AddOns\DewdropLib\Dewdrop-2.0\Dewdrop-2.0.lua:582>
    Posted in: General AddOns
  • 0

    posted a message on Quartz: Modular Casting Bar
    Quartz is working very well for me except for one little annoyance. Often, in particular with the tradeskill bar, Quartz doesn't display the correct Icon. The text is always accurate though. For example, if I open my tailor craft sill window, select Netherweave Bolt and press the create all button, the icon shown to the left of the training skill bar is that of the Netherweave Net instead of the Netherweave Bolt even though the text on the bar says Netherveave Bolt.

    It's like the icon displayed is whatever was first selected when I open the trade skill window and before I choose what I really want to do.

    It's really an annoyance now that I know about it but at first it scared the hell out of me because I though I had selected the wrong thing to make :-).

    Best
    Posted in: General AddOns
  • 0

    posted a message on Sanity 2.0
    I'm using version 33714 (April 25th) which is the last version before there were two addons. It is working for me with all the latest libraries.

    If you tried a more recent version and went back to this one, you should manually remove the SanityItemCache directory from your \World of Warcraft\Interface\Addons directory. You should probably also delete the Sanity2.lua and SanityItemCache.lua file in your \World of Warcraft\WTF\Account\<account name>\SavedVariables directory. Problem with table being nil are often the result of corrupted save variables files or change of save variables files format.
    Posted in: General AddOns
  • 0

    posted a message on XLoot
    OK, more testing on my lib issue with XLoot.

    If I install XLoot without external and load SpecialEventsEmbed, XLoot Monitor and XLoot history do not work.
    If I install XLoot without external and load SpecialEvents-Loot-1.0, XLoot Monitor and XLoot history work.

    Posted in: General AddOns
  • 0

    posted a message on XLoot
    I did one more test, if I use XLoot with external, Monitor and History start working again.

    o_O

    I'll leave that to the experts.

    Best
    Posted in: General AddOns
  • 0

    posted a message on XLoot
    I have the same issue that X-buZZ has. Since the 2.1.0 patch, I never see the XLoot Monitor display.

    I tried adding the following line at the top of the AddLoot function.

    function XLootMonitor:AddLoot(recipient, item, count)
    	XLoot:Print("AddLoot01: recipient = %s, item = %s, count =%s", recipient, item, count)


    I also added more print inside the function but none are ever print. It's like AddLoot is never called. From what I understand, addloot is called from event that are created by the SpecialEventsEmbed library by parsing the combat log (I'm guessing here). Is it possible that Blizz changed a setting and some message are no longer seen by SpecialEvents or that some other mod "steal" the combat log lines and SpecialEvents never see them (wild speculation here).

    I created a level 1 character and only loaded Xloot and BugGrabber. I try killing stuff in the starting zone and nothing in the monitor and nothing in the history. Seems it's not a side effect from another addon.

    Of note, here are the libraries that are loaded with xloot and buggrabber (I installed the without external version and use !!StandAlone):
    • Ace2
    • AnchorsAway
    • Deformat-2.0
    • DewDrop-2.0
    • FuBarPlugin-2.0
    • SharedMedia-1.0
    • Tablet-2.0

    None of the SpecialEvents libraries are loaded. I try adding SpecialEventsEmbed or SpecialEvents-Loot-1.0 to the OptionalDeps of XLootMonitor.toc but it didn't help.

    I'm at the end of my knowledge of SpecialEvents there. I can't find in the .lua code where the SpecialEvent-Loot library is loaded so I don't understand how it can be used without loading it. I was expecting an AceLibrary statement or a mixin. But like I said, I'm at the end of my knowledge here.

    Anyways, if there is anything more I can do to help you debug, let me know.

    Best and thanks for the great addon.
    Posted in: General AddOns
  • To post a comment, please or register a new account.