CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on Build problem with MountMacro

    Any news on this?

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Unsupported URL

    I had the same issue. With the migration, the source server name, and in the case of git, the whole source URI is different than what it used to be. You need to go to your project site, select source and cut and paste the new URI, and replace the old one.

     

    If you use TortoiseGit, you need only the URL part. For example, if the command for the project is "git clone https://repos.wowace.com/wow/aboutis aboutis", you need to set your source (or origin) to https://repos.wowace.com/wow/aboutis.

     

    It might be worth it to start with a fresh clone, although just changing the source worked well for me.

     

    Hope that helps.

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Build problem with MountMacro

    Thanks Torhal.

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Build problem with MountMacro

    I've tried a few more times and I'm still unable to have the builder generate a package.

     

    Here are all the builds that failed with the same Unhandled error while processing revision: xxx

     

    https://www.wowace.com/dashboard/builds/8568

    https://www.wowace.com/dashboard/builds/8583

    https://www.wowace.com/dashboard/builds/8671

    https://www.wowace.com/dashboard/builds/8674

    https://www.wowace.com/dashboard/builds/8676

     

    I'm not sure what to do next. Is there somewhere I can open a ticket about this?

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Build problem with MountMacro

    Hi guys, I've been trying to update my project MountMacro. Twice now, the build failed with an Unhandled error while processing request.

     

    Here's the link to the build and the project.

     

    It's probably worth mentioning that this is the first time I pushed revision to that project since the site has been converted from the old WoWAce.

     

    I will appreciate any help I can get to solve this.

     

    Thanks

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Packager issues with Git tags
    Quote from Nevcairiel
    All Git tag issues i'm aware of usually come from converting SVN to Git and pushing old tags to the repository. I've never seen any project that originally started out as Git screwing that up, unless you suddenly push a long list of tags in one go, I suppose.


    I was surprised too. That's why I wanted to write down the whole series of events in case it was relevant. I guess there is the possibility that while trying to fix the scripts for the converted projects, something was broken for older ones? Or, it might be something else altogether and conversion had nothing to do with it in the first place.
    Posted in: General Chat
  • 0

    posted a message on Packager issues with Git tags
    Quote from Phanx
    Stassart (who is currently helping me out with Grid) is able to run it under Windows using (I think) the git-bash that's installed with the Git for Windows package. You may want to ping him for details.


    Thanks again Phanx, I'll play with that and ping Stassart if need be.
    Posted in: General Chat
  • 0

    posted a message on Please bring SexyCooldown back
    I used to be a SexyCooldown user. Sometime in the past, I don't remember why exactly, I had to find a replacement. So, just in case SexyCooldown doesn't get updated, or while waiting for it to be updated, you should be able to use Raven to create counters very similar to SexyCooldown.

    I still hope that SexyCooldown will be updated.
    Posted in: Addon Ideas
  • 0

    posted a message on Packager issues with Git tags
    Hi everyone,

    I've decided to start a new thread since I had kind of hijacked the "Curse building issue (Grid)".

    The story so far:
    - I've converted two projects from SVN to GIT. They are ShuckIt
    - I have three other active Git project: MountMacro, Aboutis, and Sylabus
    - All of these are on WoWAce
    - For quite a while, AllPlayed was generating a zip file for every tag when I did a push even if it was only an alpha build. Furthermore, The oldest package (v30100-1) was pickup as the most current by the Curse addon manager which made Curse users unable to install the most recent version of the addon
    - I've erased all the tags on the AllPlayed project. This didn't immediately solve this issue since there was some kind of "cache" at the packager level and the packager still created .zip files for all the tags that used to be there.
    - A week later (yesterday), I tried creating a release tag again and pushing it for AllPlayed. The only the current version .zip files were generated. (Yea!)
    - I thought my woes were over and started giving some love to the other projects. The MountMacro project was already tagged as v70000-1-beta-1 for a while now so I decided to tag it for release (v70000-1). The packager generated three zip files: MountMacro-v70000-1-beta-1.zip, MountMacro-v70000-1-beta-1-nolib.zip, and MountMacro-v70000-1-nolib.zip.
    - Since no v70000-1.zip file was generated, the Curse addon client doesn't show the current release.

    It's worth mentioning that MountMacro has always been a Git project (no conversion were done). The v70000-1-beta-1 tag was pushed on July 27. In this case, the older tags didn't generate files. I have no idea why MountMacro-v7000-1.zip was not generated. Also, the AllPlayed appears to be building properly for alphas but I haven't pushed any new tags there.

    Phanx was kind enough to point me to a packager that I could run myself but I don't have access to a Unix Shell environment so it will take me some time to implement that workaround.

    Any ideas on what I should do next? Any other authors have similar problems? Is there a place to log tickets with the Curse dev. instead of just posting here?

    Sorry for the long post. I wanted to write down all the details that I could remember in case it is helpful for finding the problems.

    Best
    Posted in: General Chat
  • 0

    posted a message on Curse building issue (Grid)


    Thanks Phanx, I'll look into it. :-)
    Posted in: General Chat
  • 0

    posted a message on Curse building issue (Grid)
    Quote from ZeldoKavira
    Hey!

    I've sent it over to the dev team to clear the cache of your project so that it can get the new copy w/o tags, but they may not look at it until tomorrow :(

    Thanks,
    Zeldo


    Thanks for your help, just let me know when it's done.
    Posted in: General Chat
  • 0

    posted a message on Curse building issue (Grid)
    Here's the status for now. I've removed all tags in both ShuckIt and AllPlayed. I did new local clones and I validated that all the tags have been removed.

    In ShuckIt, I was able to get a new Alpha done and everything seems OK. I then tag the HEAD as v70000-1-beta-1 and the beta release was processed properly. It appears the problem is solved for ShuckIt.

    In AllPlayed, when I did a normal push to generate a new Alpha, the packager generated all the zip files for the tags I used to have. The new alpha is generated but the project site displays v30100-1 as the current release.

    Any clues on what I should try next?
    Posted in: General Chat
  • 0

    posted a message on Curse building issue (Grid)
    found a way to delete the remote tags with TortoiseGit. All the tags have been nuked.
    Posted in: General Chat
  • 0

    posted a message on Curse building issue (Grid)
    Done for both projects.

    Note that deleting the tags on my clone and doing a git push doesn't remove the tags on the WoWAce repositories.
    Posted in: General Chat
  • 0

    posted a message on Curse building issue (Grid)
    Quote from ZeldoKavira
    Heyo,

    Can you delete all of your old tags (and push)? Once this is done I'll have the packager kicked into not doing this anylonger. I can't wait for the new packager to be ready :(



    Thanks,
    Zeldo


    I guess you mean only keep the latest release tag? Otherwise, I'm guessing I won't have anything release.

    I'll puch once wihtout tag at all on both AllPlayed and ShuckIt, and wait for a message from you before adding new tags.
    Posted in: General Chat
  • To post a comment, please or register a new account.