CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    lejordet, I don't suppose you're going to start playing WAR and update this EXCELLENT app to support WAR addons? I've been a huge fan of WUU for a long time. Sad that I can't use it for WAR now. Either way, thanks for an invaluable app.
    Posted in: Updaters
  • 0

    posted a message on DoIKnowYou?
    This addon is exactly what I was looking for but i can't use it cause I use prat. I'd give my left nut if you could work on the prat compatibility. *beg*
    Posted in: General AddOns
  • 0

    posted a message on OOP in Lua
    I think it's for hunters.
    Posted in: Lua Code Discussion
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    what happened to the update button?
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Quote from lejordet »

    Do you have any proxies set up? WUU will use your system proxies (for Windows, the same proxy as MSIE is set up to use).


    Nope. No proxies. It was working great for a long time. Then a few versions ago it would start giving me the urlopen error at random. I could reboot and it would work again. Now it seems to give the error every time. Even after a reboot. What's strange is the one right before 1.6.445 worked fine for awhile, then this morning it kept giving urlopen error so I upgraded to 445 and that still gives urlopen error. If I copy and paste the URL to a browser it works fine.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    I'm getting the urlopen error now even after a fresh reboot. I'm using 1.6.445 right now but it was doing the same thing with the previous version as well. What am I doing wrong?
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    I'm intermittently getting the urlopen error and I have to reboot to get it to work again. Can you look into it pretty please and also what process needs to be killed do you think to get that working again? I'm in windows. I don't see anything named similar to WUU or wxpython or anything. Error I get is:

    (WARN) Download of http://files.wowace.com/XLoot/XLoot-r51401.zip failed: Error downloading file: <urlopen error (11001, 'getaddrinfo failed')>

    The URL is fine, and if I reboot it works fine. I'm assuming some process is getting stuck open and python isn't letting it try to get another urlopen going. I'm talking out of my butt cause I don't know python at all, but thats what it seems like to me.

    BTW, I love you for changing the N's to -'s.. That made it sort nice :)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Thing I don't like is when you do a scan, then sort by the update column. It puts Y's at the top, then N's, then E's. Would love to not have to scroll to select both the Y's and the E's.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    You made me happy in my pants making a single click do ascending sort. Any chance you could take that one step further and put the wowace addons that only need an external updated (the E's) up top as well? Thanks again for your excellent work.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Thanks for the quick response lejordet. I just tried closing WUU while a version check was going with threading disabled and got a python error:

    Traceback (most recent call last):
     File "WUU.py", line 2715, in OnClose
     File "WUU.py", line 1512, in saveUISettings
     File "WurmCommon.pyc", line 133, in outMessage
     File "WUU.py", line 2930, in logMessage
     File "WUU.py", line 2881, in log
     File "wx\_core.pyc", line 7563, in Yield
    wx._core.PyAssertionError: C++ assertion "wxAssertFailure" failed at ..\..\src\msw\app.cpp(680) in wxApp:Yield(): wxYield called recursively


    Other than that, I'm loving the no threads. It actually does things in order so if it does have problems I know where it left off and I don't have to re-do them all! :)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    I absolutely love WUU, but it's been flaky as hell for me lately. Using 1.5.403 now and I have multiple issues.

    First, if you try to do anything while an update or version check is going, it locks up. Only way to fix it is to end the task.

    Second, it keeps telling me I've changed things and asks me to save settings even if I don't change jack. Sometimes even if I hit No to the dialog asking if I want to save changes, the status bar says it's saving settings and locks up. Again, I have to end the task to quit.

    Third, WowAce addons don't seem to be downloading anymore. An example:

    2007-09-27 14:19:41: (WARN) Download of http://files.wowace.com/FuBar_VolumeFu/FuBar_VolumeFu-r49727.1.zip failed: Error downloading file: <urlopen error (11001,'getaddrinfo failed')>

    If I copy and paste that URL into a browser, it works just fine.

    Any help would be appreciated. I hate manually updating addons.

    Oh ya, it's also scrolling the list in strange ways now. If you do an update it'll randomly scroll the list of mods to somewhere else. Not always the top of the list either.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Ya, the WUU page says curse works again with 1.5.371 but it doesn't seem to be working for me either. Trying to update CEnemyCastBar says no download URL the first time you try to update it, then causes WUU to pretty much hang if you try it a second time.

    I don't know why it hangs if you try it twice, that'd be a leo job, but to fix the downloads edit site_re.txt and change

    curse_realdl	<a\shref="([url]http://media.+?[/url])">Select\sfastest\smirror


    to

    curse_realdl	<a\shref="([url]http://media.+?[/url])">Choose\sa\smirror


    Also, what's the new red/pink highlighting on some of my 'related' mods?

    I notice you have a known bug on the wiki about sorting by Upg. I'd give you my first born child if you made it put the Y's at the top on the first click. I may or may not have kicked my cat a few times because I have to click it twice :P

    Excellent work. Thanks very much for keeping this app updated.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    well i feel stupid. coulda sworn i went looking for this a few weeks ago when something wasn't working but couldn't find it.. oh well. thanks again.

    One note, since I updated to the beta version i'm getting an error when I scan online versions. It seems to be popping up when it gets to checking Enchantrix.

    wxPython:stdout/stderr
    ----------------------
    Exception in thread Thread-1:
    Traceback (most recent call last):
    File "threading.pyc", line 460, in __bootstrap
    File "WUU.py", line 269 in run
    File "Wurm.pyc", line 396, in sync
    File "Wurm.pyc", line 947, in getOnlineModVersion
    UnboundLocalError: local variable 'htm' referenced before assignment

    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    I appreciate the work you've done and how quickly you usually update the regex's when curse and others change the layout of their sites, however I'm curious if it would be extremely difficult to keep the regex's in a seperate text file so we could try updating them ourselves if we want. Would be nice to be able to keep our WUU working if you get sick or mauled by murlocs and are unable to release a new version.
    Posted in: Updaters
  • To post a comment, please or register a new account.