CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on Pitbull estimated heals bug - Anyone seen this?
    Come to think of it, the target of target I created doesn't have a healthbar, just a portrait and a name. Maybe I've got it turned on for that. Thanks - I'll see if thats the case.
    Posted in: Unit Frames
  • 0

    posted a message on Pitbull estimated heals bug - Anyone seen this?
    I posted this in a thread that I thought was a related issue but it appears that it's not. I get 5-6 UI errors every time I cast a Shaman healing spell on myself while in combat. I added a bug to Jira for this but I wanted to see if anyone else had seen this issue as it has persisted through a few versions of Pitbull for me.

    {["message"] = "PitBull_EstimatedHeals\\EstimatedHeals.lua:227: attempt to index field 'healthBar' (a nil value)\n<in C code>: ?\n<in C code>: in function `UseAction'\nInterface\\FrameXML\\SecureTemplates.lua:266: in function `SecureActionButton_OnClick':\n<string>:\"*:OnClick\":1: in function <[string \"*:OnClick\"]:1>\n(tail call): ?:\n<in C code>: in function `securecall'\nInterface\\FrameXML\\SecureStateHeader.lua:998: in function <Interface\\FrameXML\\SecureStateHeader.lua:979>:\n\n ---",
    ["type"] = "error",
    ["time"] = "2007/10/04 23:41:58",
    ["session"] = 102,
    ["counter"] = 3,
    }, -- [1]
    {
    ["message"] = "PitBull_EstimatedHeals\\EstimatedHeals.lua:141: attempt to index field 'healthBar' (a nil value)\nPitBull-2.0r50612\\PitBull.lua:3404: in function <Interface\\AddOns\\PitBull\\PitBull.lua:3399>\n<in C code>: ?\nLibRockTimer-1.0--51719 (FuBar):289: in function <...Ons\\FuBar\\libs\\LibRockTimer-1.0\\LibRockTimer-1.0.lua:227>\n\n ---",
    ["type"] = "error",
    ["time"] = "2007/10/04 23:41:58",
    ["session"] = 102,
    ["counter"] = 42,
    }, -- [2]
    Posted in: Unit Frames
  • 0

    posted a message on [Pitbull] estimated healing broken in 2.2?
    I've been having this same problem with estimated heals since long before the 2.2 patch. The green estimated heal bar will display when I'm healing others or heal myself out of combat, but every time I try to heal myself in combat I get 10-12 errors in my bugsack saying that it "cannot find the index of healthbar, nil value" or something similar (will add full trace once i figure out how to get it when i'm not in-game - are bugs saved to a log somewhere?).

    Is this a common problem that I just haven't been able to find a fix for yet or does this sound like something with my addon setup?

    Edit: Sorry I'm using Pitbull version +50612.2
    Posted in: Unit Frames
  • To post a comment, please or register a new account.