CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on Router suggestions
    My router is getting a bit long in the tooth, but still works fine for everything I do. I run a Buffalo-Technolody WHR-HP-G54, and even though it is only 10/100 on the wired side and b/g on the wireless side it does have one invaluable feature: it can be flashed with custom firmware.

    The Tomato firmware is really well designed and gives all the features you could even think of wanting to use.
    Posted in: General Chat
  • 0

    posted a message on Combatlog Randomly breaks
    Quote from HunterZ
    The issue persists through UI reload. I never logged out last night to try that method of "fixing" it. Is dropping to the character screen enough, or do you need to drop to the login screen?


    Dropping back to the character select screen will fix the issue
    Posted in: General Chat
  • 0

    posted a message on Combatlog Randomly breaks
    Quote from Tekkub
    "Fast scan" ties up the name queries for a long time, that kills *any* chat messages from users you didn't "know" before the scan started... I don't think it's really related to the combat log bug, it's always been this way.


    I also kills the combat log for me. I run MSBT and after a fast AH scan I get no events firing, even events from myself (heals, buffs, etc).
    Posted in: General Chat
  • 0

    posted a message on Combatlog Randomly breaks
    I usually find that my combat logs break in 2 situations:

    - logging directly into Dalaran at peak times there is a chance the combat log just won't start, or updates can be delayed for a few minutes before I'm spammed with events.

    - After a fast AH scan everything just dies for a few minutes with a 50/50 chance of the combat log coming back without a relog.

    Both situations involve heavier than normal client/server traffic.
    Posted in: General Chat
  • 0

    posted a message on LibHealComm-4.0
    It's in my copy of LibHealComm-4.0 as well, I'm wondering if anyone else is seeing the modifier applied correctly?
    Posted in: Libraries
  • 0

    posted a message on LibHealComm-4.0
    I just did a test and the 5% healing bonus from Luck of the Draw is not being added in LibHealComm-4.0 v1.5.5-release.

    Sat in Dalaran unbuffed the estimated value for a renew tick is 1424, and that matches the actual healed amount.

    After a PuG finished I clicked off all buffs apart from Luck of the Draw and cast renew again. The estimated value for a renew tick was 1424 again, but the actual healed amount was 1664.

    I'm pretty sure the modifier is being applied correctly in oUF_HealComm4, but a second opinion is always helpful.
    Posted in: Libraries
  • 0

    posted a message on LibHealComm-4.0
    Quote from Adirelle
    I haven't noticed this UnitAura change, is there a discussion about it somewhere ?


    It's the first I've seen of this too. both wowwiki and wowprogramming pages on UnitAura have been updated with the new return parameters though.

    Another thing I've noticed is that I don't believe the Luck of the Draw buff is being correctly detected by LibHealComm-4.0.
    Using v1.5.5-release in any PuG now the estimated figures for my holy priests heals are under the actual values by a significant margin. This is on an enGB client, btw.
    I'll try to post some actual figures tonight, renew seems to be a good test of consistent healing output.
    Posted in: Libraries
  • 0

    posted a message on LibHealComm-4.0
    While the library should not return 0 the current check works if the return value was 0.
    If the library return 0 and the check was "if not incheals ..." then some crud calculations would occur.

    Not worth changing the code now, even if there was a cast-iron guarantee the library will never return 0.
    Posted in: Libraries
  • 0

    posted a message on LibHealComm-4.0
    If nil was returned then the boolean logic would then check the next case until it found one that gave a valid output, which would be the "or 0".
    I've done testing on the updated version for a month or so and I've not seen any crashes when performing the comparison on line #49, so I can't see where any change would be necessary.

    thanks for looking though
    Posted in: Libraries
  • 0

    posted a message on LibHealComm-4.0
    Thanks for the suggestion Adirelle, but I think that change is not necessary. The master branch is effectively just a place-holder currently, as a major change to how the addon works is going to be released with the upcoming patch 3.3 going onto the live servers.

    You can check it out on the "version2.0" branch at http://github.com/Evilpaul/oUF_HealComm4/tree/version2.0
    Posted in: Libraries
  • 0

    posted a message on LibHealComm-4.0
    Quote from Shadowed
    Small bug in the compression code, basically if a GUID has \254 followed by any combination that is \250 or higher it will fail to decompress due to some special characters that have to be converted to something else to prevent parse errors. Granted, it's fairly rare and still took ~2 months to even pop up again.

    Right now all versions of the library already have debug code, so the change won't specifically cause hard errors in old versions of the library, but it will tell them it failed to find the GUID (capped at once/5 minutes).

    I'm going to push a version that suppresses any errors if it fails to decompress a GUID and then after the fix is more tested I'll push the actual fix.


    Hmmm, I may have seen this bug myself but ignored it as a possible bug in my oUF layout. I had the debug report from LibHealComm-4.0 indicating that it could not find raid11.
    I did a '/tar raid11' and it selected a rogue who was in the 2nd group of my unit frames. The rogue should have been in position 7 or 8 rather than 11 so I ignored the error, also being a rogue I did not expect them to be producing any healing output...
    I can't remember the name of the rogue but i'm pretty sure their name began with a variation of the character X with some type of special modifier.
    Posted in: Libraries
  • 0

    posted a message on LibHealComm-4.0
    My guess is that this post and this post probably cover most of it.


    My feeling is that is people lag out due to too much comm traffic then there is something other than LibHealComm causing it.
    If it really is an issue then make LibHealComm-4.0 totally optional to your addon. It's then the users choice to install the library and put up with the traffic it causes.
    Posted in: Libraries
  • 0

    posted a message on Bazooka
    I had to adjust the positioning by -1 to the Left and 1 to the Top. After that the gap issue I was seeing has been resolved.
    Posted in: Data Broker AddOns
  • 0

    posted a message on Bazooka
    I've checked with the latest release version and everything looks OK.

    thanks again
    Posted in: Data Broker AddOns
  • 0

    posted a message on Bazooka
    Very nice addon.

    I've created a couple of tickets for some minor things I've seen, and I've also got a question.
    Would it make sense to use statusbar textures from LibSharedMedia rather than background textures?
    Posted in: Data Broker AddOns
  • To post a comment, please or register a new account.