• 0

    posted a message on Ackis Recipe List
    Quote from Ackis
    The tooltips should already show on the +/-... try it out again?



    Yes the tooltip shows on the +/- icon and that's fine, but it also shows when hovering over each line in the list. I'm always using the scroll wheel to scroll lists and to do that I have to place the mouse cursor on top of the list. However, this makes the tooltip popup and obscure a large part of the list so I can't read it. As far as I can tell there is no way to scroll the list with the mouse wheel without the tooltip popping up which is highly annoying. An option to turn this off would be really appreciated.
    Posted in: General AddOns
  • 0

    posted a message on Ackis Recipe List
    Quote from Ackis

    Strata/frame level: Make a ticket... I don't quite get what to do here. I've played around and can't figure out something that works well.

    Tooltips: The "data overload" is something I'm looking at for tooltips. One thing I adjusted was filtering out the opposite faction trainers no matter what settings you have.

    Filtering vendors: Opposite factions vendors will be filtered if you change the display to be your own faction only.


    By the "frame level" I just mean that it would be nice if your window opened on top of the tradeskill window instead of being underneath it. I am using Skillet and when I click the "Scan" button your window opens up underneath the Skillet window.

    Yes, the window can be moved and arranged so it's not a huge problem, but it looks like a bug when the dialog floats underneath other things on screen. Since it is a dialog it should have a quite high frame level (higher than Skillet since you open it from the Skillet window). Hope that makes sense?

    The tooltips already look a bit better and I see you added the ingredients list again! Hooray! :D

    Another thing...Would it be possible to only show the tooltips when hovering the plus icon? I find it to be a bit in the way when hovering over the item text. It obscures the whole upper part of the list... Maybe it's possible to show the tooltip somewhere else on screen to avoid hiding the list items?

    Anyway, thanks for a great addon!
    Posted in: General AddOns
  • 0

    posted a message on ArkInventory v3
    Quote from specific
    Check your bag display...when AI upgraded a couple weeks ago, one of my bags set itself to not display. It's trivial to just re-enable displaying of the bag.


    Yes! That solved the problem! Since I normally don't show the bag changer bar I didn't notice that one bag had been switched off during the profile upgrade. Quite a tricky issue... Thanks for helping out!
    Posted in: General AddOns
  • 0

    posted a message on Ackis Recipe List
    First of all, thanks for a nice addon. I have 3 issues though I would like to bring up:

    * Frame strata/level
    I don't know if this has been brought up before but I'm having some problems with the recipe list being hidden behind other frames. I would like to show it next to the crafting window but it is shown underneath the quest tracker which is quite annoying.

    Would it be possible to set the frame strata to be DIALOG and raise the level a bit so that it is shown on top of other UI widgets. That would make sense I think. Or introduce a setting for it so that people can decide what strata and level to place the frame in.

    * Cluttered tooltips
    I miss the functionality of the old UI where you could see the ingredients of recipes by simply hovering over the plus icon. The new interface pops up a very large tooltip with lots of information but that part is missing. I also find the large tooltips very intrusive. Smaller tooltips like in the old UI is much more user friendly. You still have the ability to see all details when expanding the items. That would be a much neater UI imho. Right now it's the same information in the tooltip as when expanding so I don't really see the point of having the expanding thing at all...


    * Other faction recipe vendors
    It would be really sweet to be able to hide vendors that are of the opposite faction (either horde or alliance), since they are usually not of interest.
    Posted in: General AddOns
  • 0

    posted a message on ArkInventory v3
    Since version 3 I've been having a really strange problem with items not being displayed. For example, ArkInventory currently does not show my "Pungent Seal Whey" at all. I've also experienced that it showed one stack of Adamantite Shell Machine although I had 3 stacks. Yesterday I got a gem from a party member and it just disappeared!

    Now the funny thing is that when I switch to "Edit mode" everything works as it should and the items are shown correctly. They are sorted in the correct bars and everything seems fine. But when I switch back to normal mode they are gone. And the quick search cannot find the hidden items either.

    This is a seriously weird problem and I'm not sure what's causing it.

    I've tried creating a completely new profile with no changes at all to the settings but the same thing happens. Items are not shown.

    Any help is appreciated because I really like ArkInventory and want to use it! :)
    Posted in: General AddOns
  • 0

    posted a message on ZOMGBuffs Official Thread
    Quote from Zeksie »

    Mmm, no. You missed the changes I put into modulePrototype, Raid and blessings modules. Which now check raid/party changes as this does, but in the modules rather than core.

    Moving the check state thing to core is not really necessary imo. Could you test it out as-is without your changes.


    The problem is this code in the CheckState method:

    if (state ~= z.state) then
    z.state = state
    self:OnStateChanged(state, reason)
    end

    In the prototype class z points to core (ZOMGBuffs), which means that z.state updates the state in core. When the first module notices a state change it will write the new state in core. When the second module processes its events and calls CheckState it will not go into the if-statement because it also checks the state in core (which is already updated by the previous module) so it does not detect any state change at all.

    In my opinion the logic is flawed and that is why I moved it to core instead. I thought it was better to let core handle it and just notify all interested modules about the state change. Maybe you want to change it so that every module keeps its own state flag and calls CheckState by themselves and that's fine too. Just make it work :).
    Posted in: General AddOns
  • 0

    posted a message on ZOMGBuffs Official Thread
    Quote from Zeksie »

    I added the PARTY_MEMBERS_CHANGED. The rest of the code has changed a little since you posted that, so if you could update and check it that would be cool :)


    Sure! I have made a patch against revision 81980 that you should be able to apply using TortoiseSVN to get it working. I have attached it to this post.

    Please don't hesitate to ask if you have any questions about my modifications. (I have only tested it in parties, not in raids.)
    Posted in: General AddOns
  • 0

    posted a message on ZOMGBuffs Official Thread
    Hi Zeksie!

    Have you had a chance to look at the problem with the templates auto-switch feature? I posted a fix back here: http://www.wowace.com/forums/index.php?topic=11887.msg230115#msg230115

    I also posted a bug report to the Curseforge page http://wow.curseforge.com/projects/zomgbuffs/ but I'm not sure you watch it that much?

    If you need any help reproducing the bug I'd be happy to help. I'm holding off updating ZOMGBuffs just to keep my little patch intact so it can switch templates for me... :)

    /Pontus
    Posted in: General AddOns
  • 0

    posted a message on ZOMGBuffs Official Thread
    Quote from Laren »

    Any update on this? It seems only to switch one template.


    I have taken a look at the problem with ZOMGBuffs failing to switch templates automatically and I think I have fixed it. At least it works now for switching between solo/party. I haven't yet tried the other modes.

    Ok, this is going to be a bit technical now. If you just want the "hotfix" you can download my two patched script files attached to this post and extract them in the ZOMGBuffs folder. The patch is based on revision r78152.1.


    * BUG INFO
    The first problem with the auto switching is that ZOMGBuffs does not listen to the PARTY_MEMBERS_CHANGED event so I corrected that.

    The second problem is that the CheckStateChanged() method is run for each loaded module but it changes a global state variable, so only the first module gets to see the state change. Since the state is indeed global it should not be checked for each module. I therefore moved out the CheckStateChanged() method to the ZOMGBuffs.lua file and it is now run only once when your group is updated, and IF the state changes it signals this to all buffing modules.

    There is also a typo in ZOMGBuffs.lua so it listens for RAID_ROSTER_UPDATED instead of RAID_ROSTER_UPDATE which is the correct name of the event. I'm not doing any raids so I have no idea what kind of problems this may yield. Just thought I'd point it out. I have corrected that in my patch as well.

    I cleaned up ZOMGModulePrototype.lua and removed some things that were no longer needed. I hope I did not break anything! :)

    Posted in: General AddOns
  • To post a comment, please or register a new account.