• 0

    posted a message on A challenge for the Boys/Girls
    make a cast sequence Find mineral find herb and spam it as you fly around. thats what i used to do
    Posted in: Addon Ideas
  • 0

    posted a message on Deadened - modular Reliquary of Souls helper
    K Could say this my first official mod hehe.

    This should work with default UI.

    replace the Deadened.lua with the one from the attachment or add this to it:
    function Deadened:SCRIPT_HOOK(this)
     if ( event == "UNIT_SPELLCAST_START" or event == "PLAYER_TARGET_CHANGED") then
      if arg1 == "target" then 
    	  local spell, rank, displayName, icon, startTime, endTime = UnitCastingInfo(arg1)
    	  if not Deadened:IsDeaden(displayName) then
         self.hooks[this]["OnEvent"](this)
    	  else
     		 local spell, rank, displayName, icon, startTime, endTime = UnitCastingInfo(arg1)
    	 	 self:Alert(("%s casting %s (%s) sec"):format(UnitName(arg1), displayName, ("%2.1f"):format((endTime-startTime) / 1000 )))
    	  end
    	 end	
    	end	
    end


    ADD at the end of Deadened.toc

    Modules\DefaultUI.lua


    Since the default doesn't register the event but react to the OnEvent i had to use HookScript and it's a bit different handeling then the Register event style so need to add this piece of code. maybe this can be added to SVN. i'll check later whats the frame for the nameplate one to hook the script
    Posted in: Raid AddOns
  • 0

    posted a message on Deadened - modular Reliquary of Souls helper
    found the fix

    embeds.xml

    <Script file="Libs\ParserLib-3.0\Parser-3.0.lua"/>

    Should be

    <Script file="Libs\Parser-3.0\Parser-3.0.lua"/>
    Posted in: Raid AddOns
  • 0

    posted a message on Deadened - modular Reliquary of Souls helper
    some poeple have this problem sayign the parser can'T be found. i ziped my working version and still doens'T work for them
    Posted in: Raid AddOns
  • 0

    posted a message on Worldmap Toggle while in combat cause a taint from cartographer
    The name is just Cartographer

    but in the Packages section when it'S installed
    Posted in: AddOn HELP!
  • 0

    posted a message on Worldmap Toggle while in combat cause a taint from cartographer
    Cartographer pack from wowaceupdater

    It was the only addon activated at the time of the test.

    Posted in: AddOn HELP!
  • 0

    posted a message on Worldmap Toggle while in combat cause a taint from cartographer
    I can reproduce it with only Cartographer active. Deleted my WTF Cartographer options.

    Engage combat, doesn't matter what your fighting. Open world map then close it. Your UI should now be gone (you need to ALT Z to bring it back up) Also it pop a Addon action blocked error.
    Posted in: AddOn HELP!
  • 0

    posted a message on Worldmap Toggle while in combat cause a taint from cartographer
    1/17 18:25:45.062 Global variable ChatFrame_MessageEventHandler tainted by Cartographer - Interface\AddOns\Cartographer\libs\LibRockComm-1.0\LibRockComm-1.0.lua:1355
    1/17 18:25:45.062 Execution tainted by Cartographer while reading ChatFrame_MessageEventHandler - Interface\FrameXML\ChatFrame.lua:2054 ChatFrame_OnEvent()
    1/17 18:25:45.062 ChatFrame2:OnEvent()
    1/17 18:25:45.062 An action was blocked in combat because of taint from Cartographer - UIParent:Show()
    1/17 18:25:45.062 Interface\FrameXML\UIParent.lua:1249 <unnamed>:SetUIPanel()
    1/17 18:25:45.062 Interface\FrameXML\UIParent.lua:1318 <unnamed>:HideUIPanel()
    1/17 18:25:45.062 Interface\FrameXML\UIParent.lua:1048
    1/17 18:25:45.062 <unnamed>:SetAttribute()
    1/17 18:25:45.062 Interface\FrameXML\UIParent.lua:1619 HideUIPanel()
    1/17 18:25:45.062 Interface\FrameXML\WorldMapFrame.lua:663 ToggleWorldMap()
    1/17 18:25:45.062 TOGGLEWORLDMAP:1
    1/17 18:25:45.062 RunBinding()
    1/17 18:25:45.062 WorldMapFrame:OnKeyDown()



    This is with only Cartographer running. So no other addon interfering
    Posted in: AddOn HELP!
  • 0

    posted a message on ag_UnitFrames - suggestions, requests and temp fixes thread
    i'm on BC client
    Posted in: Unit Frames
  • 0

    posted a message on ag_UnitFrames - suggestions, requests and temp fixes thread
    Using Revision 18974 from the branche i get this error when i enter the game


    [2006/12/04 11:36:09-7-x1]: <unknown>:
    AceEvent\AceEvent-2.0.lua:916: in main chunk

    ---

    This error is catched by !BugGrabber and BugSack.

    Only have those 3 addon loading:
    ag_UnitFrames
    BugGrabber
    BugSack

    anyone have an idea?
    Posted in: Unit Frames
  • To post a comment, please or register a new account.