• 0

    posted a message on ButtonFacade (was LibButtonSkin-1.0)
    Quote from Phanx »

    Well, I don't know what the problem with SBF is, since it works fine for me. Does it happen if you have only ButtonFacade and SBF enabled (i.e. log out, delete SVs, log in, set stuff up, log out, log in)?


    I did not try disabling everything and then attempting to see if ButtonFacade would work with SBF. As I said though, I've since taken up using Buffalo, and actually rather prefer it in a few ways, but regardless of that, I still need to reconfigure the appearance of my buffs and debuffs every time I log in or reload my UI.
    Posted in: General AddOns
  • 0

    posted a message on ButtonFacade (was LibButtonSkin-1.0)
    Update: I've switched from Bongos3 to Dominos, and the ActionBars are keeping their settings... SBF and Buffalo won't. Buffalo2 doesn't appear to support or be supported by ButtonFacade as I saw no way to adjust the settings there. I've reinstalled both SBF, Buffalo and Buffalo2 numerous times, and none of them are saving my color/appearance settings at all :(
    Posted in: General AddOns
  • 0

    posted a message on ButtonFacade (was LibButtonSkin-1.0)
    I'm currently using Bongos3 and Buffalo. I switched from SBF but honestly prefer Buffalo now anyway, so it doesn't "appear" to be related. It's obviously something else going wrong. I'll delete ButtonFacade, Buffalo and Bongos3, delete their SavedVariables settings and see if I can get my settings to survive a reload.

    And, yes I've noticed that the settings don't always match the GUI, which is also happening when I relog or reload my UI, but if they still kept the look on my screen itself, I wouldn't have even worried about it in the first place :)
    Posted in: General AddOns
  • 0

    posted a message on ButtonFacade (was LibButtonSkin-1.0)
    Interesting, that's something that I did not realize. However the problem that I am having remains the same. Where ever these settings are supposed to be being saved to, they are quite clearly not being. I have installed Bongos3_ButtonFacade from www.wowace.com. I have ButtonFacade and ButtonFacade_Caith installed, and I am using Buffalo. My situation was the same while I was using Bartender4 and SBF as well. So I guess my question becomes now, what am I doing wrong? I am really at a loss here, and I so love my UI when the skinning work I've done is working, rebuilding the color scheme every time I reload my UI or log out of the game, while it has become second nature, isn't the most convenient. I love ButtonFacade, I just want to be able to save my settings!

    Thanks,

    William Katz (Hadrin, Doomhammer)
    Posted in: General AddOns
  • 0

    posted a message on ButtonFacade (was LibButtonSkin-1.0)
    I am having a problem with ButtonFacade not saving my settings. Every single time I reload my UI, or logout, I lose all of my color settings which is getting frustrating. I'm attempting to use a black "border" and "glow" color for my buffs and buttons, while using a red "border" and "glow" color for my debuffs, and purple for the temporary buffs on my weapons. This is using Bongos3 and Buffalo as the mods I am attempting to skin. The skin I'm using is ButtonFacade_Caith.

    This is what ButtonFacade.lua looks like in my SavedVariables folder:

    ButtonFacadeDB = {
    	["namespaces"] = {
    		["ButtonTest"] = {
    			["profileKeys"] = {
    				["Hadrin - Doomhammer"] = "Hadrin - Doomhammer",
    				["Caliansus - Doomhammer"] = "Caliansus - Doomhammer",
    			},
    			["profiles"] = {
    				["Hadrin - Doomhammer"] = {
    				},
    				["Caliansus - Doomhammer"] = {
    				},
    			},
    		},
    		["Bongos"] = {
    			["profileKeys"] = {
    				["Hadrin - Doomhammer"] = "Hadrin - Doomhammer",
    				["Caliansus - Doomhammer"] = "Caliansus - Doomhammer",
    			},
    			["profiles"] = {
    				["Hadrin - Doomhammer"] = {
    					["Class"] = {
    						["Gloss"] = 1,
    						["Skin"] = "Caith",
    					},
    					["Pet"] = {
    						["Gloss"] = 1,
    						["Skin"] = "Caith",
    					},
    					["ActionBar"] = {
    						["Gloss"] = 1,
    						["Skin"] = "Caith",
    					},
    				},
    				["Caliansus - Doomhammer"] = {
    					["Class"] = {
    						["Gloss"] = 1,
    						["Backdrop"] = true,
    						["Skin"] = "Caith",
    					},
    					["Pet"] = {
    						["Gloss"] = 1,
    						["Backdrop"] = true,
    						["Skin"] = "Caith",
    					},
    					["ActionBar"] = {
    						["Gloss"] = 1,
    						["Backdrop"] = true,
    						["Skin"] = "Caith",
    					},
    				},
    			},
    		},
    	},
    	["profileKeys"] = {
    		["Hadrin - Doomhammer"] = "Hadrin - Doomhammer",
    		["Caliansus - Doomhammer"] = "Caliansus - Doomhammer",
    	},
    	["profiles"] = {
    		["Hadrin - Doomhammer"] = {
    		},
    		["Caliansus - Doomhammer"] = {
    		},
    	},
    }


    My primary point of confusion is... where is the color data supposed to be stored? Because while I'm not expert, there appears to be no color information in the above code, which only leads me to believe that everytime I adjust my settings in Warcraft, nothing regarding the colors I want is being saved to this file. What is the syntax for including color data, and perhaps I can input that data on my own by hand. The same thing happened when I was using SBF instead of Buffalo and I assumed it had to do with SBF wanting to include it's own colors.

    Any ideas?
    Posted in: General AddOns
  • 0

    posted a message on Error since updating to 1.9.44.671 just a few moments ago
    Ever since WAU came up and told me that it had updated to the latest version and needed to restart, this is the error that I've gotten. I've uninstalled, reinstalled, rebooted, reset the WINSock Catalog... So I'm a little lost. Is this a problem with the update? The server? Am I losing my mind? Well, maybe, but... back to the WAU ;)

    WAU Version (1.9.44.671) assembly version (1.9.44.37013)
    Auto-retry of addon list load
    Error During Download: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it
      at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
      at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
      --- End of inner exception stack trace ---
      at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
      at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)
      at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)
    Error During Download: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it
      at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
      at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
      --- End of inner exception stack trace ---
      at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
      at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)
      at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)
    Complete
    Error During Download: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it
      at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
      at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
      --- End of inner exception stack trace ---
      at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
      at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)
      at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)
    Error During Download: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it
      at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
      at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
      --- End of inner exception stack trace ---
      at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
      at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)
      at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)
    Posted in: Updaters
  • To post a comment, please or register a new account.