• 0

    posted a message on Request: itemcache.wdb creater/filler?
    Thank you Elkano, I'll give it a try.

    Edit: Works perfectly! Thanks!
    Posted in: Addon Ideas
  • 0

    posted a message on Request: itemcache.wdb creater/filler?
    I'm sorry to have bumped this thread if it's not allowed to reply to things that are older than a year, I was not aware of that rule.
    However, I do not believe the request was unrelated, as it is specifically talking about exactly the thing I need, I merely mentioned a way to ensure as few as possible false requests due to only requesting PT logged IDs. And as I said, I was fully aware of the disconnect risk.

    At any rate, sorry to have disturbed you for this, apparently I will have to continue using sniff to get each item one by one.

    Regards
    Quin
    Posted in: Addon Ideas
  • 0

    posted a message on Request: itemcache.wdb creater/filler?
    Greetings,

    Apologies for dragging up this old thread, but it is the only one I found that gets the closest to what I am personally searching for.

    Basically, using Mendeleev and Cartographer InstanceLoot I get a lot of unknown numbers after a patch, even after I load up all my chars, check tradeskills, scan the AH, etc. and am forced to click link after link, or Sniff my way through the itemids in a very slow fashion.

    Due to my server (Silvermoon EU), I also have very little doubt that nearly all items possible will be loaded into the server cache within a fairly short time after restarts.
    If possible, could someone manufacture a small addon that scans for running through the PeriodicTable ids so that the info gets dropped into the local itemcache?
    I am fully willing to accept all disconnects that happen, provided that the scans can continue at the point where they left off.

    Regards
    Quin
    Posted in: Addon Ideas
  • 0

    posted a message on X-Perl Thread
    Greetings,

    During various encounters it has consistently bugged me why I couldn't always select the vehicles I was riding in.
    Doing some testing, I realized that it does work properly, but it seems like the targeting portion of the name plate was somehow switched around.

    To clarify, if I click on anything clickable (portrait, health/mana bars) it will properly target my vehicle. However if I try to click on the name plate, it attempts to target myself, which doesn't work on various combat vehicles (such as the drakes at Malygos). On the other side, doing the same on the pet frame (that shows me) will target myself in most parts, but the vehicle if I click on the name plate.

    If possible, I hope you can fix this, so targeting gets less of a hassle using XPerl, as I like them otherwise, and would hate to have to look for something new just because I get confused during the heat of the battle to select the proper thing.

    Regards
    Quin
    Posted in: Unit Frames
  • 0

    posted a message on Ackis Recipe List
    Ackis, the reason people are getting the error with LibAboutPanel is because they are updating without externals, and WAU or others that do the same check the embeds.xml for references to the embedded libraries used, download and installs those seperately, and then delete the content in that file so there are no attempts of WoW to load those embedded libraries anymore.

    Since LibAboutPanel is not on the wowace svn, it cannot be downloaded, but the updaters still clear out the contents of the embeds.xml, hence, prevent the actual embed from loading.

    The embeds.xml was initially set up I believe to standardize the whole issue with using externals or not so that it wasn't the toc being edited anymore, but the embeds.xml.

    I can suggest two ways of fixing this for all those that use externals instead of embeds:
    * Upload LibAboutPanel to the SVN so it can be grabbed automatically from there.
    * Place the embed loading of LibAboutPanel back into the toc instead of the xml.

    Hope that helps.

    Regards
    Quin

    PS: At least jWoWUpdater doesn't delete the embedded version of LibAboutPanel inside the libs folder, so instead of downloading it from here, the users can just move that folder out into the main Addons folder and load it that way.
    Posted in: General AddOns
  • 0

    posted a message on SilverDragon error if Notes are disabled
    The following message occurs if you enable nothing but SilverDragon, Cartographer Notes, and their dependencies, but disable the option for showing those notes within the SilverDragon settings.
    [2008/05/20 10:47:19-2485-x1]: Cartographer_Notes-2.0\Notes.lua:3372: bad argument #1 to 'rawget' (table expected, got nil)
    AceAddon-2.0-57245 (Ace2):926: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:919>
    <in C code>: ?
    AceEvent-2.0-66043 (Ace2):260: in function `TriggerEvent'
    AceEvent-2.0-66043 (Ace2):910: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:903>

    I had recently disabled the option of showing those notes because they're basically just all over the place. I understand the desire to have the rares shown wherever they are seen, but it makes any reasonable location gathering fairly difficult with the way the notes tend not to be just where the rares path, often because of either coordinate bugs, or because the mobs were pulled away.
    Unfortunately, above error pops up all the time if I turn off this option, while the addons themselves don't show any further issues.

    Hopefully someone can fix at least the error, so that the setting doesn't generate the error message anymore.

    Regards
    Quin
    Posted in: AddOn HELP!
  • 0

    posted a message on BigWigs - The Eye
    Quote from Funkydude »
    Quote from Nitra »
    I didn't see any bars in Al'ar last night at all.
    Would it be possible to add them in for the platform changes as well?

    no

    Just out of curiosity, why not? I'd also like to encourage the addition of the Al'ar platform changes so that we know when the adds are incoming.

    Currently, I prefer BigWigs over DBM, but there are a few bars (and some other special attacks from bosses such as Maulgar) that I see are present in DBM but not in BW. Mostly for us in the raid it doesn't matter, because I don't announce, and the raid leader uses DBM to do just that, but when he's offline and I'm standin, it's a trifle disconcerting to miss those warnings.

    I'm aware that you want to reduce spam, however, in some cases the spam is preferable. You could just set some of the options to default off if that's really a problem.

    You're doing great work with this, and I hope you keep it up. I also hope that you can find it in yourself to add this or that :)

    Regards
    Quin
    Posted in: Raid AddOns
  • 0

    posted a message on Instance Maps not Working
    I'd like to add a little bit to this issue that I haven't seen yet.
    This issue seems to be vary a bit, sometimes I can view the instances, other times not. I haven't yet been able to find out when this happens, but I did notice that whenever this manifests, that the "how to use" text in the upper left corner of the map (but not the zone info from another part of Cartographer) will be overlaid by the active map itself (those areas that are also covered by the FoW).

    Map notes themselves work normally, as does every other part that I personally have in use, InstanceMaps is shown as active, and no LUA errors appear, so I can't give any of that. The instance maps simply don't show once this bugs (no matter if by clicking them in the list, or the auto-select once you enter that one). Occasionally I noticed that it actually shows the whole outland map, but all the notes themselves are from Zangarmarsh (while in SSC), and if I right click it actually zooms out to what I could see, then I can zoom back in.

    Beyond that, I can't add anything else, though if you have ideas I should try out, I'll do that.

    Regards
    Quin
    Posted in: Map/Minimap AddOns
  • 0

    posted a message on Omen - Bug Reports and Suggestions
    Quote from Dssurge »
    I think what you want is Target of Target threat if selected target is friendly?

    Not exactly, what if the target is not targeting a mob, but another friendly?
    Quote from OrionShock »
    ...?
    Omen/Threat Tracks everything on a Per-Target-Basis. there is no "Master Target" like in KTM
    but for healing there is what's known as "Global-Threat" and i think a "Global + Current Target" threat view would be in order for healers...

    I'm very aware of that, and it's great, I don't want that to change. It's when you target something not a mob, a friendly NPC or Player that all you get is the global threat and that doesn't show anything but your own (I tested this yesterday on Nightbane, with 3 healers, it only showed me).
    Quote from Nickenyfiken »
    I think i understand what you mean. Although I'm not playing as healer anymore this sounds like a good idea. Not sure about the automatic part though.

    The automatic was an idea that I saw because of the auto-reset of threat based on BigWigs notifications. It's not the core of this idea though.
    Quote from Skyboat »
    More like a sticky target option would be better.

    Sticky targeting is pretty much exactly what I was trying to say. The ability to set a specific target to show threat on, even if you do not have that one selected. Or actually, to have that one show if you don't have any mob selected, as you might want to show the threat on a different mob temporarily inbetween.

    Regards
    Quin
    Posted in: Raid AddOns
  • 0

    posted a message on Omen - Bug Reports and Suggestions
    For the healers here who wish to see their threat compared to the tank and the dps, is there a chance you could implement a sort of master target? Not like with KTM, since the targets are individual anyway, more like this:
    When you do not have any target, or a friendly target selected, show the threat of everyone on the master target. That way, healers do not have to have the boss selected to get their threat values compared to others. It would also be nice if this master target could be automatically set on the boss when engaged, and/or be individually changeable by everyone, so they can have their own (thinking OT healers on Maulgar fight eg.)
    Doable?

    Regards
    Quin
    Posted in: Raid AddOns
  • 0

    posted a message on Chronometer (Ace2'ed AceTimer)
    With the patch, the two timers for Shamans' Healing Stream Totem and Mana Stream Totem have been doubled from 60 to 120 seconds. With the latest update today you haven't changed these, so in case you missed this tidbit...

    Regards
    Quin
    Posted in: General AddOns
  • 0

    posted a message on sRaidFrames: Alternative CTRA raid frames
    Quote from Saroz »

    screenshot or it didn't happen.

    This is with my entire interface active.
    http://www.revo-guild.it/revolution/interfaceall.jpg
    And this is, just to show that it's not something else interfering, with only sRF active.
    http://www.revo-guild.it/revolution/interfacesrf.jpg

    Also, I have tested a bit more, while making these screenshots, and Gift of the Naaru doesn't always cause the jump, only occasionally, though I couldn't figure out why that was.

    Regards
    Quin
    Posted in: Unit Frames
  • 0

    posted a message on sRaidFrames: Alternative CTRA raid frames
    I searched as well as I could, but was unable to find out if this was addressed anywhere previously, so please apologize if it has and point me in the right direction.

    The problem I have encountered is in regards to Shamans (me), their Earth Shield, and the buff counter for it.
    When I cast ES on anyone in a raid, the symbol appears perfectly on the frame, however the counter for the buff is somehow stuck in the center of the screen. Checking the options didn't bring any help in this regard. The counter works just fine, but since I have SCT in that same area, it overlays quite a bit, and I often miss the counter expiring.
    Confusingly, the counter frame jumps over the draenei heal (Gift of the Naaru) buff icon if I cast it on the same target as my earth shield, and remains there even after the heal is gone, on top of the ES icon, until I recast the shield, at which point it resets back to the center of the screen. My belief is that the anchor is somehow wrong here, but that's merely a guess.

    Is there any reason why this is happening that might have to do with my setup, or is this a bug you have been unaware of?

    Regards
    Quin
    Posted in: Unit Frames
  • 0

    posted a message on Is ACP still mantained?
    I've been testing this out a few days now, and couldn't find any issues with how it works, thank you for your efforts.
    The only thing I would suggest to make this easier (while keeping the overrides) would be to either add checkboxes for the NoChild and NoRecurse options, or alternatively, add a help screen and/or change the commands to something a bit easier to enter (such as /acp nochild yes/no). Personally, since ACP doesn't any longer use chat commands, I think the checkboxes would be best, but I'll leave that to your discretion.

    Thanks again for the help.
    Regards
    Quin
    Posted in: General AddOns
  • 0

    posted a message on Is ACP still mantained?
    Quote from sylvanaar »

    Im adding a check so you can bypass this behaviour.

    do /script ACP_Data.NoRecurse = true

    then reload your UI to save it

    I tested this, only ACP active, and unfortunately, it errors out every time I attempt to click on a checkbox next to any of the addons listed. I can open the window, and navigate it fine, the box seems checked at first, but scrolling clears it again, and no settings are changed. Returning the value to 'false' again clears this problem.
    Interface\AddOns\ACP\ACP.lua:566: attempt to call global 'EnableAddon' (a nil value)

    from the wow-error, or here, the BugSack catch, once enabled:
    [2007/03/13 11:44:31-343-x1]: ACP\ACP.lua:566: attempt to call global 'EnableAddon' (a nil value)
    ACP\ACP.lua:868: in function `AddonList_Enable'
    <string>:"ACP_AddonListEntry10Enabled:OnClick":2: in function <[string "ACP_AddonListEntry10Enabled:OnClick"]:1>
    
     ---


    Unfortunately, due to this error, I am unable to verify if this would fix what I perceive to be the problem.

    A bit further testing today though showed, that the recursively activated addons do not trigger any addons that depend on that recursively activated addon. It's merely if I manually switch it on, that any addons dependent on it will activate. So if I turn on FuBar_Clock, it only turns on FuBar and the libraries used by FuBar and FuBar_Clock (or any subsequent dependencies, if there were any), but not anything else.
    On the other hand, if I turn on FuBar, every addon that depends on FuBar will activate as well (not just those that FuBar itself needs to run) and those in turn activate all main and optional (libraires) dependencies. The recursive activating isn't the problem really, it's the backward recursive activation that is.

    Essentially, in my current setup this means I turn on FuBar, which enables the FuBar libraries, plus BattlegroundFu, HonorFu, SWStats2Fu (which enables SW_Stats itself), ClockFu, PerformanceFu, BagFu, oRA2CooldownFu (which enables oRA2), BigWigs Tablet Bars (for testing purposes installed, which then enables BigWigs), etc. etc. You see the pattern here I hope. All libraries used by those addons get activated as well, but not anything that depends on those recursively activated addons gets turned on; eg. BigWigs Nefarian Counter, which only needs BigWigs to run doesn't activate.

    Hope this helps to narrow it down a bit more.
    Regards
    Quin
    Posted in: General AddOns
  • To post a comment, please or register a new account.