• 0

    posted a message on Skinner
    I am getting the following lua errors on startup with Skinner version b5.16309.3:

    Error #1:

    Message: Interface\AddOns\Skinner\PlayerFrames.lua:1330: attempt to index field '?' (a nil value)
    Time: 11/25/12 00:38:51
    Count: 1
    Stack: (tail call): ?
    [C]: in function `xpcall'
    Interface\AddOns\Skinner\UtilFuncs.lua:115: in function <Interface\AddOns\Skinner\UtilFuncs.lua:109>
    (tail call): ?
    Interface\AddOns\Skinner\AddonFrames.lua:153: in function <Interface\AddOns\Skinner\AddonFrames.lua:22>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
    (tail call): ?
    Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:164: in function <Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:138>

    Locals: <none>

    Error #2:

    Message: Interface\AddOns\Skinner\SkinMe\FramesResized.lua:18: attempt to call global 'GetNumRaidMembers' (a nil value)
    Time: 11/25/12 00:38:52
    Count: 1
    Stack: (tail call): ?
    [C]: in function `xpcall'
    Interface\AddOns\Skinner\UtilFuncs.lua:115: in function <Interface\AddOns\Skinner\UtilFuncs.lua:109>
    Interface\AddOns\Skinner\UtilFuncs.lua:214: in function `checkAndRunAddOn'
    Interface\AddOns\Skinner\AddonFrames.lua:269: in function <Interface\AddOns\Skinner\AddonFrames.lua:221>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
    (tail call): ?
    Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:164: in function <Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:138>

    Locals: <none>

    Error #3:

    Message: Interface\AddOns\Skinner\Skinner.lua:221: table index is nil
    Time: 11/25/12 00:38:52
    Count: 1
    Stack: Interface\AddOns\Skinner\Skinner.lua:1351: in function <Interface\AddOns\Skinner\Skinner.lua:1316>
    Interface\AddOns\Skinner\Skinner.lua:1408: in function `skinDropDown'
    Interface\AddOns\Skinner\SkinMe\Armory.lua:78: in function <Interface\AddOns\Skinner\SkinMe\Armory.lua:4>
    (tail call): ?
    [C]: in function `xpcall'
    Interface\AddOns\Skinner\UtilFuncs.lua:115: in function <Interface\AddOns\Skinner\UtilFuncs.lua:109>
    Interface\AddOns\Skinner\UtilFuncs.lua:214: in function `checkAndRunAddOn'
    Interface\AddOns\Skinner\AddonFrames.lua:269: in function <Interface\AddOns\Skinner\AddonFrames.lua:221>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
    (tail call): ?
    Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:164: in function <Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:138>

    Locals: <none>


    Despite these errors, the addon seems to actually work otherwise.
    Posted in: General AddOns
  • 0

    posted a message on PitBull 4.0
    Quote from cremor
    Yes, you can configure different colors.


    I just found it under the Colors -> Cast Bar settings; I was looking under Layout Editor -> Bars -> Cast Bars tab. Thanks for the heads-up.
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    Two quick questions - if they have been asked before, please forgive, but the thread is 180 pages. :)

    - Does the cast bar support showing when a spell can be interrupted? On the default Blizz frames, you see a shield next to the castbar and a border around it. While I would not expect the same indicator for PB's cast car, being able to see if the spell can be interrupted (color, different texture, etc.) would be nice.

    - I am sure I may be unpopular for asking this question, but when will the party configuration options be fixed?

    Thank you for your time.
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    I was messing with the 20090601203155 alpha. I noticed that it had a fix for the default cast bar popping up/not staying hidden. This seemed to work well on my DK, but for some reason, it did not work as well on my hunter. On my hunter, if I went into and out of combat and performed any action with a cast time, the default Blizz bar would show up. If I rehid it in the P4 options (uncheck and then recheck), it would stay hidden until the next time I got into and out of combat. I am not sure why I did not see this on my DK. I will double check my addon listings/differences to see if that could have been a factor. Keep up the excellent work.

    [EDIT] It was an addon conflict with LD50_abar that was causing the cast bar to pop up post-fix. Ignore if you have not done so already. :)
    Posted in: Unit Frames
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    I was wondering Prat worked with IgnoreMore (http://www.wowinterface.com/downloads/info5186-IgnoreMore.html) . According to that author, Prat causes issues with its ability to ignore users. I was not sure if this had been addressed or if it was a problem to begin with. I'd like to use IgnoreMore with Prat, but if it doesn't work, then I won't bother. Thanks for your time.
    Posted in: General AddOns
  • 0

    posted a message on IceHUD
    If I set the player health and mana bars to disappear when I have no target, the corresponding text does not disappear if I lock the upper and lower text to 100% alpha. The bars will disappear, leaving the numbers in the normal location. If I turn off lock lower/upper text alpha, the text disappears when the bar disappears.
    Posted in: Unit Frames
  • 0

    posted a message on Quartz: Modular Casting Bar
    The four swing timers that I have tried - quartz, ld50_abar, slammer, and attack bar timer - all have the same issue. I actually tried them all at the same time on my warrior on a practice dummy. They all had the exact same behavior as I have described above.
    Posted in: General AddOns
  • 0

    posted a message on PitBull 2.0
    I am having an issue in Pitbull 3.0. I am attempting to configure unit frames when in "Party" mode. Any drop-down lists under "All Units" will not change their selection. For example, let's say you're trying to change the Health format from Absolute to Absolute Short. If I go under All Units/Texts/Health, the format choice for Absolute Short is listed. If I expand the list and click Absolute Short, the listbox does not change its value. If I then go to a single unit frame, i.e., Player/Target/Party, and do the same action, the type changes. What is weird is that if I change said option Player and then go to All Units, the option is changed.

    Please note that this only seems to happen on listboxes under All Units. Sliders, text boxes, and other forms of input do not seem to have this issue. I was not sure if this was a bug or a recent change to Pitbull that I was not aware of.
    Posted in: Unit Frames
  • 0

    posted a message on Quartz: Modular Casting Bar
    The following issue has to do with swing timer portion of Quartz. It is unfortunately common to all swing timers due to changes in Slam and I believe Steady Shot. See below:

    This addon has issues when warriors use Slam. Since Slam no longer resets the swing timer, any use of it will cause the timer to be off until the next autoswing. Here is an example with a 3.5s 2H:

    * I autoswing. The timer shows 3.5s and counts down.
    * With 3.0s, I start a slam, which has a 1.5s cast time untalented.
    * I perform Slam with essentially 1.5s left on the swing timer.
    * The swing timer reset to 3.5s. This is the part that is now wrong.
    * About 1.5s later, I autoswing. The swing timer resets again, showing 3.5s left. It is now in sync again.

    This may also be an issue with hunters and steady shot as I believe it follows similar behavior. Both Slam and (I believe) Steady Shot now push back the autoattack/autoshot in the case of overlap instead of consuming it. Let me know if you have any questions or if the description did not make any sense.
    Posted in: General AddOns
  • 0

    posted a message on Fence
    Anyone able to get this to work in 3.0.2? I attempt to Ctrl+LeftClick items into the Auction House window and get nothing. This worked without issue before. I am not sure if it is me/my setup. However, I tried with only Fence running and it failed as well.
    Posted in: General AddOns
  • To post a comment, please or register a new account.