• 0

    posted a message on Beta
    Yup, been trying my addon in beta, a few changes to cope with but latest version is working (and should be fine in normal too). Event system has changed a little no longer getting "GROUP_ROSTER_UPDATE" as it was.
    Posted in: Need Help?
  • 0

    posted a message on Beta
    I just got into beta, just wondering when the beta support is coming?
    Oh I guess that depends on when blizz make addons available :s
    Posted in: Need Help?
  • 0

    posted a message on How to make my addon compatible with Curse Client?
    And using the GIT capability or others will get it improved even faster
    Posted in: General AddOns
  • 0

    posted a message on tracking /rolls
    Basically this should do it (if you are still having issues, only just seen the post)...
    ChatFrame_AddMessageEventFilter("CHAT_MSG_SYSTEM",chatevent)
    
    function chatevent(self,event,arg1,arg2, ...)
    	if event=="CHAT_MSG_SYSTEM" then
    		local name, roll, low, high
    		found = strfind(arg1,"rolls",1,true)
    		if found~=nil then
    		_,_,name, roll, low, high = string.find(arg1, "(%a+) rolls (%d+) %((%d+)%-(%d+)%)$")
    		DEFAULT_CHAT_FRAME:AddMessage(name.." rolled "..roll)
    	end
    end

    I find google quite handy for finding stuff, but also "wowwikki/World_of_Warcraft_API" and wowinterface.

    Tho if you google something like "getting rolls in wow" you'll get a list of information on rolls. if you try "wow lua getting rolls" you'll get better information closer to what you actually want.
    Posted in: Need Help?
  • 0

    posted a message on Download button
    Hosted the image externally and added it to the description. Looks fine on curseforge again (will see how curse.com handles it when it updates)
    Posted in: Need Help?
  • 0

    posted a message on Download button
    Hmm, sorry to be a pain. but my other addon (Random Healing addon) I've uploaded an image and it show perfectly fine on curseforge, but curse.com is showing a blank image which if I check the image url says 404.
    Should I just delete and reupload? because I've checked other addons and there doesnt appear to be an issue with jpg's or width's that arent multiples of 16 (or odd widths). was uploaded 2 days ago.

    Edit: All working now, nm :) (just changed the description slightly and I guess that made it update on curse)
    Posted in: Need Help?
  • 0

    posted a message on Download button
    Just done some checks, it doesnt like unannotated tags thats all. Thats why my git was saying it failed. Not a big issue
    Posted in: Need Help?
  • 0

    posted a message on Download button
    yep, just took a little while to update I guess :)
    Posted in: Need Help?
  • 0

    posted a message on Download button
    And I made a git tag, v1.01 it seems to have propagated to the curse.com site, but still no download button. Maybe a more compatible client is a good idea :) (my git client said the push had failed too)

    Edit: or I could just stick with uploading zip file manually, which isnt necessarily a bad thing.
    Posted in: Need Help?
  • 0

    posted a message on Download button
    Umm, I dont have to use Git, which would you say is best for curse? (or simplest to use with or without going command line not that that isnt an option)
    Posted in: Need Help?
  • 0

    posted a message on Download button
    Thanks, I'll edit my windows git ui to do that if I can work out how :)
    Posted in: Need Help?
  • 0

    posted a message on Download button
    I've made an addon, uploaded it to curse. Its showing in the curse client but there's no download or install via curse button on its web page vss. Anyone any idea what I've done wrong? or am I just being impatient? (just to be clear it's all working fine in the client, just not the web page)
    Posted in: Need Help?
  • To post a comment, please or register a new account.