• 0

    posted a message on CowTip - a tooltip addon - Official Topic
    Thanks ElykNosrac! That worked perfectly :)
    Posted in: General AddOns
  • 0

    posted a message on CowTip - a tooltip addon - Official Topic
    I'm trying to figure out how to display the Classification color for rares as fuchsia, elites as gold, rare elites as gold (bold if possible) and bosses as red (bold if possible) but I'm having trouble figuring out DogTags conditional statements.

    I also copied the [Level:DifficultyColor] tag from the above poster but the level text never changes color.

    Any help would be appreciated :)
    Posted in: General AddOns
  • 0

    posted a message on wowace.py - lightweight, cross-platform addon updater
    Its working perfectly now, thanks!

    On a side note, the embeds.xml file is still trying to load the shared library's. I commented it out in bartender, bigwigs, ora2, itempricetooltip, incubator, cartographer, skinner, candybar, specialeventsembed, prat, automation, bulkmail2, quartz, pitbull and threat-1.0 *catches breath* and now I'm not receiving any loading errors in my FrameXML.log nor any error messages in game. From what I've read this also increases loading performance.

    Just wanted to let ya know, maybe you can comment those out as well ;)
    Posted in: Updaters
  • 0

    posted a message on wowace.py - lightweight, cross-platform addon updater
    After checking out the errors it seems that some of my addons are being loaded before the librarys they require are being loaded and are throwing an error.

    I went through each addons TOC file, that was throwing an error, and made a 'Dependencies' line and copy/pasted the 'X-Embeds' listing.

    Example
    Bigwigs:
    ## X-Embeds: Ace2, FuBarPlugin-2.0, Babble-2.2, CandyBar, DewdropLib, PaintChipsLib, SharedMediaLib, Waterfall-1.0
    ## Dependencies: Ace2, FuBarPlugin-2.0, Babble-2.2, CandyBar, DewdropLib, PaintChipsLib, SharedMediaLib, Waterfall-1.0
    
    Prat:
    ## X-Embeds: Ace2, Babble-2.2, FuBarPlugin-2.0, GloryLib, DewdropLib, TabletLib, Deformat, SharedMediaLib
    ## Dependencies: Ace2, Babble-2.2, FuBarPlugin-2.0, GloryLib, DewdropLib, TabletLib, Deformat, SharedMediaLib


    Now everything loads fine. Maybe you could just replace 'X-Embeds' with 'Dependencies' and get rid of 'embeds.xml' in the loading section?
    Posted in: Updaters
  • 0

    posted a message on wowace.py - lightweight, cross-platform addon updater
    Decided to run a force update on everything and here are the errors I'm getting:
    1)
    [2007/06/20 17:35:29-184-x1]: Prat\Prat.lua:418: Cannot find a library instance of SharedMedia-1.0.
    Ace2\AceLibrary\AceLibrary.lua:470: in function `AceLibrary'
    Prat\Prat.lua:418: in main chunk
    
    2)
    [2007/06/20 17:35:29-184-x1]: AceOO-2.0-38641 (Ace2):627: FuBarPlugin-2.0: FuBarPlugin-2.0 requires Dewdrop-2.0.
    Ace2\AceLibrary\AceLibrary.lua:100: in function `error'
    FuBarPlugin-2.0-40574:885: in function `OnInstanceInit'
    AceOO-2.0-38641 (Ace2):627: in function `init'
    AceAddon-2.0-40893 (Ace2):778: in function `init'
    AceOO-2.0-38641 (Ace2):463: in function <Interface\AddOns\Ace2\AceOO-2.0\AceOO-2.0.lua:436>
    (tail call): ?:
    Prat\extras\PratFu.lua:147: in main chunk
    
     ---
    
    3)
    [2007/06/20 17:35:29-184-x1]: Prat\extras\PratWaterfall.lua:35: Cannot find a library instance of Dewdrop-2.0.
    Ace2\AceLibrary\AceLibrary.lua:470: in function `AceLibrary'
    Prat\extras\PratWaterfall.lua:35: in main chunk
    
     ---
    
    4) --> I get 35 of these messages, just referencing different LUA files, thoufht I'd keep it small for you ;) <--
    [2007/06/20 17:35:29-184-x1]: Prat\Prat_Modules\extras\Presets.lua:48: attempt to call method 'RequestModuleName' (a nil value)
    
     ---
    
    39)
    [2007/06/20 17:35:30-184-x1]: SpecialEvents-Loot-1.0\SpecialEvents-Loot-1.0.lua:14: SpecialEvents-Loot-1.0 requires Deformat-2.0.
    SpecialEvents-Loot-1.0\SpecialEvents-Loot-1.0.lua:14: in main chunk
    
     ---
    
    40)
    [2007/06/20 17:35:52-184-x1]: PitBull-r40890\Banzai\Banzai.lua:73: PitBull_Banzai requires the library Banzai-1.1 to be available.
    AceAddon-2.0-40893 (Ace2):760: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:753>
    <in C code>: ?
    AceEvent-2.0-40601 (Ace2):232: in function `TriggerEvent'
    AceEvent-2.0-40601 (Ace2):910: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:903>
    
     ---


    BugGrabber gives me a 1m cooldown warning because I'm receiving a poop-ton of errors.

    -Edit-
    Added a BugGrabber log with 119 errors :S
    Posted in: Updaters
  • 0

    posted a message on wowace.py - lightweight, cross-platform addon updater
    With this new version I'm having a problems with Skinner. All the SkinMe entries seem to get commented out, probably because they don't exist and the user is expected to copy the ones they want from AddonSkins.

    Also Prat/Pitbull and SpecialEvents-Loot are all telling me they cant find library instances.

    Commenting gone too far? :P
    Posted in: Updaters
  • 0

    posted a message on Skinner
    Request:
    Under Outfitter.lua the outfitter button isn't placed in the nicest of places and won't work while using mobileframes. I request the 'OutfitterButton' moveObject line be change to
    self:moveObject(OutfitterButton, "+", 33, "+", 7)

    as it looks more pretty :)



    Thanks
    Posted in: General AddOns
  • To post a comment, please or register a new account.