• 0

    posted a message on Adding text to player tooltips
    This is how I am making my functions.

    function MyAddon:DoStuff()
    
    do stuff
    
    end
    
    
    Posted in: Need Help?
  • 0

    posted a message on Adding text to player tooltips
    Thank you, I believe this will work well, I seem to be having issues, the problem is I am getting attempt to call MyFuncName a nill value error, I keep getting these errors when I try to call most of my functions, I am new to LUA, any idea what I might be doing?
    Posted in: Need Help?
  • 0

    posted a message on Adding text to player tooltips
    I am trying to add a string of text such as completed achievements number in the hover over player tooltip, I have the code for that working but need to put it in a event handler and have not been able to find a mouseover event to add, any suggestions would be great.
    Posted in: Need Help?
  • 0

    posted a message on AceAddon-3.0 name already exists error
    Sorry I didnt get this in last post, the question is why am i getting this error?
    Posted in: Need Help?
  • 0

    posted a message on AceAddon-3.0 name already exists error
    Also if you could answer this question about the following error i have:

    ERROR
    1x AceLocale-3.0: Infinity: Missing entry for 'The message':
    Infinity-1.0\core.lua:12: in main chunk


    CODE core.lua
    local L = LibStub("AceLocale-3.0"):GetLocale("Infinity")
    
    local options = {
        name = "Infinity",
        handler = Infinity,
        type = "group",
        args = {
            msg = {
                type = "input",
                name = L["Message"],
                desc = L["The message"],
                usage = L["<Your message>"],
                get = "GetMessage",
                set = "SetMessage",
            },
            showInChat = {
                type = "toggle",
                name = L["Show in Chat"],
                desc = L["Toggles the display of the message in the chat window."],
                get = "IsShowInChat",
                set = "ToggleShowInChat",
            },
            showOnScreen = {
                type = "toggle",
                name = L["Show on Screen"],
                desc = L["Toggles the display of the message on the screen."],
                get = "IsShowOnScreen",
                set = "ToggleShowOnScreen",
            },
        },
    }
    
    local defaults = {
        profile =  {
            message = L["Infinity"],
            showInChat = false,
            showOnScreen = true,
        },
    }


    local-enUS.lua
    local L = LibStub("AceLocale-3.0"):NewLocale("Infinity", "enUS", true)
    
    -- Chat commands
    L["gearscore"] = true
    L["wh"] = true
    
    L["Infinity"] = true -- default message
    
    L["Message"] = true
    L["The message to be displayed when you get home."] = true
    L["<Your message>"] = true -- usage
    
    L["Show in Chat"] = true
    L["Toggles the display of the message in the chat window."] = true
    
    L["Show on Screen"] = true
    L["Toggles the display of the message on the screen."] = true


    Any help would be great, thank you.
    Posted in: Need Help?
  • 0

    posted a message on AceAddon-3.0 name already exists error
    Well I have to say I am glad I came here to ask, I was almost going to give up on incorporating ace into my addon, thanks guys.

    And yes that was it Xin, thank you again.
    Posted in: Need Help?
  • 0

    posted a message on AceAddon-3.0 name already exists error
    Yes I do, Checking now to see if error is there, thank you i will reply back if it helps.
    Posted in: Need Help?
  • 0

    posted a message on AceAddon-3.0 name already exists error
    No matter what name I use it does the same thing, any ideas?
    Posted in: Need Help?
  • 0

    posted a message on AceAddon-3.0 name already exists error
    local AddonName = LibStub('AceAddon-3.0'):NewAddon('AddonName', 'AceEvent-3.0', 'AceConsole-3.0')
    
    function AddonName:OnInitialize()
    
    	--AddonName:Print("AddonName Initialize!")
    	
    end
    
    function AddonName:OnEnable()
    
        --AddonName:Print("AddonName Loaded!")
    	
    end
    
    functionAddonName:OnDisable()
    
        --AddonName:Print("AddonName Unloaded!")
    	
    end
    
    


    With the above code i get a error that AddonName exist already, any idea what I might be doing wrong?
    Posted in: Need Help?
  • To post a comment, please or register a new account.