• 0

    posted a message on ZOMGBuffs Official Thread
    I fixed LibSink2 support today so that it actually worked, however it wont let me commit it to the svn. Below is the pastey link of it if someone would like to commit it.

    http://ace.pastey.net/89187
    Posted in: General AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from Arkive »

    Ah, I didn't realize it scanned the spellbook. Yea, I totally understand not adding that in now. That said, would it be possible to add a "All spells/abilities" checkbox to the cooldown plug-in page so if it's checked it will automatically track cooldowns for all abilities? This would have the benefit of tracking cooldowns of spells you haven't learned yet, which the plug-in does not do (I leveled a mage to 6 just to test before sticking my foot in my mouth...heh). It would also help those who respec every so often, and partially with the compilation issue since I don't have a 70 of every class to create preconfigured profiles for.


    Maybe I dont understand what you are trying to setup for other classes in the compilation? Do you wish to setup the frames and how they interact? Or do you wish to setup what spells are tracked for every class?
    Posted in: Raid AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from Arkive »

    Well, I did a little testing thinking it might be class-specific settings in cooldowns or another plug-in not playing nice with other classes having different savedvariables. No such luck. Tried every possible way to initialize a profile before loading (reset from profiles menu; login -> logout to save default profile -> log back in, etc)...nothing. The only thing of noteworthiness I found was that I didn't need to use the Load Profile-C, then A, then C method. Just loading Profile-C twice in a row seemed to work fine. I don't know if there are any side effects from doing it that way that you noticed in your testing, but if not, until the glitch is worked out, you could always have the profile function run the db load command twice. If there are some glitches associated with doing it that way, maybe include a dummy profile that it copied in first when the load profile command is run?

    I'd also like to throw out an idea. Perhaps on pages that have options specific to the class you're playing (ie. cooldowns), have a dropdown for each class' options, but default the dropdown to the class being played so it's still as intuitive as it is now. That way you can assign and preserve all the settings for every class in each profile. This would go a long way to helping compilation authors incorporate your mod in so they don't have to create and configure a profile for every class. I will grant this has the negative effect of increasing the savedvariables size as well as diverting attention away from something that might actually need fixing v/s something that would just be nice to have.


    I will be continuing to look into why the profile switching acts the way it does. Adding in a class specific dropdown allowing you to access all class cooldowns/abilities in cooldown watch will never occur. The amount of bloat that would add into the plugin is insane because it does not store cooldowns what so ever. The cooldowns that you have access to track are scanned from your spellbook upon loading, there is not a table of them or anything. De|Buff Watch does have a table though so that may be possible sometime in the future. However the issue I see with it is that honestly, every class will want different spells tracked. For a UI compilation I would recommend just setting up the default bars, frames, etc, rather than setting up their personal spell tracking settings as those are things that are unique to each individual player rather than a per class basis. The settings for what bars go where by categories are saved under the frames settings I believe, so this should not conflict anything when porting from class to class. ie: All Cooldowns will goto the same frame regardless of the cooldowns that are tracked. Once I get the next beta version of AbilityWatch pushed, I will spend the next week figuring out why the profiles are acting the way they are and a perminant fix to allow proper profile porting via the Ace3 profile system.
    Posted in: Raid AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from Furian »

    The RBM.LUA contains the following:
    I hope this helps, I've found a way arond the problem by unselecting the 'Filter by Category' option, this allows proper saving of settings. If it's selected the category goes to AbilityWatch again and I have to manually reset the filters.

    Also, is the ':: Cooldown' part of the label removable currently?


    I recommend renaming that file to like RBM.lua.bak and starting your game fresh. It is somehow still trying to use the RBM 1.0 settings in 2.0 (which shouldnt be possible). The first line of 2.0+ savedvariables files is
    RBM2_DB = {


    The ":: Cooldown" will be removable in the next release.

    Quote from Arkive »

    Not sure if this related to Furian's issue or not, but I'm having problems copying profiles. If I go into a new character and try to copy the profile of the configured character, it creates the bars block with the correct names, but places all of them at the default location on top of one another and applies no settings (this includes bar options, x/y offset, filtering, etc).


    I am aware of the issue, however I believe it is an Ace3 problem rather than RBM's because of how the bug occurs. If you select a different profile then reselect the one you want to use it will use properly. ie:

    You have ProfileA, ProfileB, and ProfileC. You want to use ProfileC. So you select ProfileC, select ProfileA, then select ProfileC again and it will have the settings and positioning properly stored. I have spent days trying to figure out why this occurs on changing profiles but not when reloading/logging in the game as it does the EXACT same process, but alass I could not figure it out.
    Posted in: Raid AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from Furian »

    Firstly, the addon is on it's way to brilliance. Good job.

    I'm having a problem I'd like to ask a question about. Currently there seems to be a bug with my various frames not saving settings. For example, I have a frame named Drums for the Drumwatch rotation, however, when relogging the settings are changed to AbilityWatch. I of course use seperate frames for those, but everything seems to display AbilityWatch after relogging.

    I read that someone else had a similar problem with another plug-in, I couldn't find a solution to his problem.

    Another question I have is with regard to the possibility of have the ':: Cooldown' part of the Label removed, is this possible currently?

    Can you please post your WTF/<AcctName>/SavedVariables/RBM.lua file?
    Posted in: Raid AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from jrkilroy »

    The cooldowns page is the only that gives me any trouble. I can enable and configure all the other modules without issue.



    Alright, I will see if I can find an issue that would be causing it. Thanks for the reply.

    Quote from septor »

    I'm not about to read through 21 pages to see if this has already been asked. I posted this on the curse page, but feel this may get more attention here:

    Is it possible to reformat the label text? Instead of displaying:

    Humar the Pridelord :: Curse of Agony

    I want it to display:

    Curse of Agony

    I don't need to know that the curse is on Humar since I have Humar as my target.

    There is an option in De|BuffWatch to disable the targets name.

    Quote from Faridoon »

    When I log into wow I get these three errors,

    [2008/06/07 17:18:26-335-x1]: RBM-2.0.6\Core.lua:330: Usage: AceDBObject:RegisterNamespace(name, defaults): 'name' - a namespace with that name already exists.

    Let me know if there is anything else I can do to help keep this the great addon it has become.

    Apparently a few people are starting to have this issue. I will try and see why it is just now being caused. I noticed that you still had TestSuite installed. I recommend uninstalling all old RBM mods (plugins, cores, configs) and reinstalling from scratch. The entire core has chanced since TestSuite was used (1.0) and there is a lot of improvements however using old plugins/modules can and will cause a LOT of problems.

    Quote from gmedina »

    Currently i can track a debuff another paladin puts up like JoL or JoW but seems only under timless can i track this debuff. Is there anyway to track it such that it has a timer? Also when i use crusader strike it should reset the timer as long as my crusader strike didn't miss.

    Unless you can see the duration of the buff/debuff via the target frame, there is currently no way to track it. This is something restricted by game not by mods. I may be able to put in a work-a-round for crusaderstrike only since it resets the timers of all active "Judgements", but if someone refreshes their judgement between crusader strikes the durations will be inaccurate.

    Quote from dsenen »

    Today I noticed a minor bug that might be annoying:
    When I enter Shattrah, AbilityWatch is disabled (because of the sanctuary status)
    Well, problem is that if I queue for arenas in Shattrah city whenever I get inside the arena the addon is still disabled and doesn't work. Tried going to Nagrand and queued up there and everything worked fine.

    Thx again for the great work on this addon and specially for the great support you're giving in this forum.

    PS: (tried the code you provided for the Elemental Timer, and it's still not working)

    Will have the zone bug fixed soon. Thanks for the report.
    I will be adding proper support for the Water Elemental soon. currently the api's I have written do not support a proper way to add the uptime of this in. Does the cooldown work however?

    And I try my best to give support on the forums, irc, aim, etc the best I can. This weekend I have had a very special lady friend over and my time is very limited of when I actually get to play wow and most of the time I get to play this weekend has been spent raiding or doing dailies (the probably 3 hours total). :) After Monday my time should go back to normal.

    Quote from jrkilroy »

    Hey, I just wanted to say thank you to the author. I've been watching the thread all day and I appreciate how active and reasonable you've been in assisting people with their challenges. If you have a donate link somewhere, let us know, I can't give much, but I can at least offer you a beverage of your choice :)

    Thank you very much for your kind words. Anyone is able to donate to me directly via the following link:
    https://www.paypal.com/cgi-bin/webscr?cmd=_xclick&business=Apoco%40assimx%2enet&item_name=RBM%20Donations&no_shipping=0&no_note=1&tax=0¤cy_code=USD&lc=US&bn=PP%2dDonationsBF&charset=UTF%2d8
    Posted in: Raid AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from jrkilroy »

    Hello,

    I can recreate this problem. Disabling Xloot fixes the problem for me.

    I do have another challenge for you. When I select the Cooldowns plugin from the config frame, then enable the plugin WoW locks up. I don't get any errors, but the game freezes and won't recover. Twice, I've been able to logout without killing WoW, but when I go back in and try to access the enabled cooldowns configuration page, WoW locks up.

    This happens even if RBM core + Config are the only two addons loaded.

    I installed for the first time this morning, directly from the wowace site.

    And, to make it *really* interesting, I'm on a Mac, in the event that makes a difference.


    This looks like a tool that will scratch the itch for my 'lock since the demise of DoTimers. Please let me know if I can provide you any additional information.



    If its locking up then it is probably in an endless loop somehow. I do not believe having a mac should cause the problem, but I know some other addons have had issues with Macs in the past. Can you open up any of the other config menus (De|Buff Watch, SpamWatch, etc)?
    Posted in: Raid AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from dsenen »

    Thanks for your previous answer, i might have been looking for spellid's in the wrong place :-/

    I keep tuning the spell list and need help with the mage Water Elemental. I'm trying to display a bar with time left on the Elemental but can't get it to work. I've try changing the ct=45 with dur=45 so it could appear as a buff in the buff list but it doesn't work, also tried to show it like a cast, using ct=45, cast=true, no results either... Any ideas?

    I'm also having some problems with gradients, sometimes, for some sets of abilities, i can only see the 1st colour.

    Thx in advance.



    I will look into the gradient issue.
    try this (untested)
    [31687] = { ct = 45, cast = true, target = true, cd = 180 }, -- Summon Water Elemental

    I will add in proper implimation later on.
    Posted in: Raid AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from G00DFe77a »

    After a little more random testing. I have found that RBM, Auctioneer advanced, and Xloot doesnt play nicely together. RBM and auctioneer advanced together works fine. RBM and Xloot works together fine. I enable all three the errors starts to appear. There are a alot of errors, so I put most of the highlights in pastebin instead. http://pastebin.com/m7e0b58ac


    Alright, will be looking into it then. I do not run Auctioneer Advanced so yeah, cant say it works with it but I will be looking into it.

    I just installed Auctioneer Advanced and did not have any issues with it running along with XLoot and RBM. I will be installing all of your addons and seeing what I can figure out. I really appreciate all of the assistance.
    Posted in: Raid AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from G00DFe77a »

    I found the culprit, unfortunately it was the last one I tested. When I enable "Xloot" and RBM together it causes the errors.


    So everything else worked with RBM besides Xloot and RBM?

    That is very odd because I run xloot with RBM perfectly fine ~_~;; Where did you get your xloot from? files.wowace.com/WAU?

    Could you also please post the errors it gives. a txt file or something would suffice I just need to know every error.

    I also just tried only loading:
    Ace3, Ace2, LibRock-1.0, LibFuBarPlugin-2.0, LibFuBarPlugin-3.0, RBM, Xloot, and LibSink-2.0(required by RBM) and had no problems at all. This was all unembeded but it shouldnt change anything
    Posted in: Raid AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from Yinchie »

    There is a thing that is kinda annoying.
    Like whenever you got a IMP out as a Warlock and you die.
    The addon keeps spamming phase shift is ready or something like that non stop till you resummon the imp.


    I am looking into it but I have a feeling this is the wrong thread for you. I do not see anything in RBM that tracks phase shift, and I do not see how it could be "spamming" anything.
    Posted in: Raid AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from Faridoon »

    Every time I log in this error pops up.
    [2008/06/06 13:03:17-319-x1]: RBM-2.0.6\Core.lua:330: Usage: AceDBObject:RegisterNamespace(name, defaults): 'name' - a namespace with that name already exists.
    AceDB-3.0\AceDB-3.0.lua:565: in function `RegisterNamespace'
    RBM-2.0.6\Core.lua:330: in function `NewPlugin'
    RBM_SpamBlock-1\SpamBlock.lua:2: in main chunk
    <in C code>: ?
    RBM-2.0.6\Core.lua:249: in function <Interface\AddOns\RBM\Core.lua:211>
    RBM-2.0.6\Core.lua:426: in function <Interface\AddOns\RBM\Core.lua:409>
    (tail call): ?:
    <in C code>: ?
    <string>:"safecall Dispatcher[1]":9: in function <[string "safecall Dispatcher[1]"]:5>
    (tail call): ?:
    AceAddon-3.0\AceAddon-3.0.lua:341: in function `EnableAddon'
    AceAddon-3.0\AceAddon-3.0.lua:411: in function <Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:397>
    <in C code>: in function `LoadAddOn'
    Interface\FrameXML\UIParent.lua:908: in function `UIParentLoadAddOn':
    Interface\FrameXML\UIParent.lua:234: in function `CombatLog_LoadUI':
    Interface\FrameXML\UIParent.lua:327: in function `UIParent_OnEvent':
    <string>:"*:OnEvent":1: in function <[string "*:OnEvent"]:1>
    
     ---




    I have done a potential fix. Please let me know. There is an addon conflicting with SpamBlock.
    Posted in: Raid AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from Marqui »

    Yes, I attached two screenshots, 1st without RBM enabled, second with





    As you can see, basically PitBull, Cowtip and Satrina BuffFrames are screwed




    Could you guys please post every error that is being caused when you have RBM enabled. I have tested RBM with Pitbull, CowTip, and SanturaBuffFrames and did not have any conflict issues what so ever. I would love to help fix it but I am at a loss as to why an error is occuring.

    Or if you want to spend the time, disable every addon but RBM and load the game, if it loads properly then start enabling them one by one and see when you get errors. If it does NOT load properly give me the RBM error message. I know what is occuring but I do not know what is causing it nor do I know how RBM could in anyway be causing it. I am guessing there is a major conflict with another addon you select few are running.
    Posted in: Raid AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from dsenen »

    First, i want to thank you for this great addon.

    I'm trying to modify the spell list in the Abilitywatch.lua file to add some spells and change the behaviour of others. Well, problem is whenever I try to add a new spell (previously looking for the spellid) i get an erratic behaviour, for instance i've added to the paladin spells this line:

    [19750] = { ct = 1.5, cast = true, heal = true }, [19751] = { ct = 1.5, cast = true, heal = true }, -- Flash of Light

    then, when i try to get to paladin abilities in the rbm conf. screen, i just can't see any of the abilities listed, just the "select all" check.

    Also tried with some other abilities, like hunter's scatter shot and others... same problem there.

    Only time i could get to see the new ability in the conf. screen was with Perception, but in this case i could see the check box but where unable to check it. Really, i can't get what i'm doing wrong, help plz.

    I'm using the LuaIDE editor, btw, in case this migth be the problem.

    Finally, a petition, since i've seen some of the code already implemented in the lua: Please add Diminishing Returns and this addon will be just perfect ;-)

    Thanks again.


    Working on Diminishing Returns as you noted there is code inplace for it to work, but hasnt been tested, nor do I think it will work.

    The problem with the paladins holy light is this:
    19751 is not a spellid :) lol
    http://www.wowhead.com/?spell=19751

    You have to make sure all spellid's are correct otherwise it will error out. I will add in an error message if there is not a proper spellid in the next build.


    Perception wasnt working because I apparently forgot to fix the settings for the "All" category when I changed to the new filtering system for buffs/debuffs/casts etc. Will get it fixed and uploaded within the hour.
    ** Update **
    I fixed the "All" category, you can now select them again. Sorry about that. I also added in the message to alert you when there is not a proper spellID in the spellList. I also added in Perception and Rank 1 Flash of Light.
    Posted in: Raid AddOns
  • 0

    posted a message on RBM Offical Thread
    Quote from nailer »

    :) found a minor bug in totem watch, fire res totem correct spell id is 8184, and rank 4 is not there at all, it's 25563.


    Thanks. Fixed.

    Quote from Arkive »

    I thought I had reported this but may have been mistaken:

    1) If I'm in a group with a another shaman and he recalls his totems, it makes my totem bars disappear.

    2) In the TotemWatch options, all I see is a bunch of question marks. I'm using US english localization and the latest version.



    Appears someone tried to localize it to korean but didn't do it properly and overwrote the english localizations.

    Got it and the totemic recall bug fixed. Sorry thought I patched it in sooner.
    Posted in: Raid AddOns
  • To post a comment, please or register a new account.