• 0

    posted a message on Skinner
    Hi Jncl,

    I just popped in to say thanks for keeping this great addon updated.

    Cheers. :)
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Hi Jncl,

    Thanks for the update. It seems to work perfectly. :)
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Hi Jncl,

    Buggrabber is reporting the following errors with version b4.13914.3 with only Chocolate Bar, Buggrabber, Bugsack, Grizzly Shared Media and Skinner loaded.

    2x Skinner-b4.13914.3\CharacterFrames1.lua:87: attempt to index field "sknrBdr" (a nil value)
    Skinner-b4.13914.3\CharacterFrames1.lua:87: in function <Skinner\CharacterFrames1.lua:36>
    (tail call): ?
    <in C code>
    Skinner-b4.13914.3\UtilFuncs.lua:95: in function <Skinner\UtilFuncs.lua:93>
    (tail call): ?
    Skinner-b4.13914.3\CharacterFrames1.lua:15: in function <Skinner\CharacterFrames1.lua:6>
    (tail call): ?
    <in C code>
    Skinner-b4.13914.3\UtilFuncs.lua:95: in function <Skinner\UtilFuncs.lua:93>
    (tail call): ?
    Skinner-b4.13914.3\AddonFrames.lua:24: in function <Skinner\AddonFrames.lua:3>
    (tail call): ?
    <in C code>
    <string>:"safecall Dispatcher[2]":9: in function <string>:"safecall Dispatcher[2]":5
    (tail call): ?
    Skinner-b4.13914.3\libs\AceTimer-3.0\AceTimer-3.0-5.lua:164: in function <Skinner\libs\AceTimer-3.0\AceTimer-3.0.lua:138>
    
    Locals:
    nil
    and

    2x Skinner-b4.13914.3\UIElements1.lua:1164: attempt to index global "FeedbackUIButton" (a nil value)
    Skinner-b4.13914.3\UIElements1.lua:1164: in function <Skinner\UIElements1.lua:1047>
    (tail call): ?
    <in C code>
    Skinner-b4.13914.3\UtilFuncs.lua:95: in function <Skinner\UtilFuncs.lua:93>
    (tail call): ?
    (tail call): ?
    <in C code>
    <string>:"safecall Dispatcher[2]":9: in function <string>:"safecall Dispatcher[2]":5
    (tail call): ?
    Skinner-b4.13914.3\libs\AceTimer-3.0\AceTimer-3.0-5.lua:164: in function <Skinner\libs\AceTimer-3.0\AceTimer-3.0.lua:138>
    
    Locals:
    nil
    I don't know if this helps or is relevant but in the chat frame, Skinner reports errors running PaperDollFrame and MinimapButtons.

    Thanks a bunch for keeping this updated and maintained and being so prompt with bugfixes.

    Cheers. -S
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    This one is slightly different from the previously posted errors.

    'SetStatusBarTexture' (a nil value)
    Skinner-b4.13561.1\CharacterFrames2.lua:652: in function <Skinner\CharacterFrames2.lua:636>
    (tail call): ?:
    <in C code>: in function `xpcall'
    Skinner-b4.13561.1\UtilFuncs.lua:88: in function <Skinner\UtilFuncs.lua:86>
    (tail call): ?:
    Skinner-b4.13561.1\AddonFrames.lua:244: in function <Skinner\AddonFrames.lua:237>
    (tail call): ?:
    <in C code>: ?
    <string>:"safecall Dispatcher[2]":9: in function <[string "safecall Dispatcher[2]"]:5>
    (tail call): ?:
    AceTimer-3.0-5 (AdiBags):164: in function <...ce\AddOns\AdiBags\libs\AceTimer-3.0\AceTimer-3.0.lua:138>
    
      ---
    Posted in: General AddOns
  • 0

    posted a message on AdiBags - a bag addon
    Hi Adirelle,

    Nice work on this addon. It makes things so much easier to find. I just found this in my BugSack using version 1.2-beta-1 and thought I would pass it on. Cheers. :)

    2x AdiBags-v1.2-beta-1\modules\TidyBags.lua:141: attempt to compare number with nil
    AdiBags-v1.2-beta-1\modules\TidyBags.lua:163: in function `GetNextMove'
    AdiBags-v1.2-beta-1\modules\TidyBags.lua:190: in function `UpdateButton'
    AdiBags-v1.2-beta-1\modules\TidyBags.lua:208: in function `?'
    CallbackHandler-1.0-6:147: in function <...ags\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:147>
    <string>:"safecall Dispatcher[5]":4: in function <[string "safecall Dispatcher[5]"]:4>
    <in C code>: ?
    <string>:"safecall Dispatcher[5]":13: in function `?'
    CallbackHandler-1.0-6:92: in function `SendMessage'
    AdiBags-v1.2-beta-1\widgets\ContainerFrame.lua:521: in function `UpdateButtons'
    AdiBags-v1.2-beta-1\widgets\ContainerFrame.lua:190: in function <AdiBags\widgets\ContainerFrame.lua:177>
    (tail call): ?:
    <in C code>: ?
    <string>:"safecall Dispatcher[2]":9: in function <[string "safecall Dispatcher[2]"]:5>
    (tail call): ?:
    AceBucket-3.0-3 (AdiBags):116: in function <...\AddOns\AdiBags\libs\AceBucket-3.0\AceBucket-3.0.lua:109>
    (tail call): ?:
    <in C code>: ?
    <string>:"safecall Dispatcher[1]":9: in function <[string "safecall Dispatcher[1]"]:5>
    (tail call): ?:
    AceTimer-3.0-5 (AdiBags):166: in function <...ce\AddOns\AdiBags\libs\AceTimer-3.0\AceTimer-3.0.lua:138>
    
      ---
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Quote from Jncl
    Hi skyggesang,
    Do these issues clear up the next time the tooltip is displayed? I've seen the white background on tooltips, doesn't happen every time though so difficult to fix, but it clears on subsequent displays for me.


    Hi Jncl,

    The white tooltip background item linked in chat only happens once after a UI load or reload.

    The white tooltip background while comparing an item (either shift-clicked or mouseover in the auction house) happens at every occurrence.

    I know of at least two people in my guild who do not see that second tooltip at all. They do not use any addons, so I am guessing that Blizzard must have changed something there and it could be related to the problem I am having with the related Skinner tooltip.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Hi again, Jncl.

    I have a number of issues to report this time. When I shift-click to compare items or mouseover a comparable item in the auction house, the tooltip for my equipped item has a blindingly white background making it difficult to read as you can see in this picture. The same thing happens when I click a linked item in chat (picture) for the first time after logging in to a character or reloading my UI.

    Also, on the bottom-most action bar, the buttons are not showing if I do not have an ability, item, macro or profession shortcut in them as seen here. Also in the same picture on the top right hand side, the shaman totem bar (moved via MoveAnything) is not skinning at all.

    And finally a request. I don't know if this was covered in the raid updates for v. b4.13164.5 and I am just missing the option, but if not, would you mind skinning both of the default raid frames shown in this picture and the role check as shown in this picture.

    Thanks again. I imagine this addon must be a beast to maintain. Cheers.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Jncl, great job keeping this addon maintained. Thank you so much.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    I am getting this error when opening the options for AdiBags.

    AdiBags version: 1.1-beta-8
    Skinner version: b4.13164.1

    Although, the error was happening with 3.3 and the latest addon versions for that patch as well.


    1x Skinner-b4.13164.1\Skinner.lua:212: table index is nil
    Skinner-b4.13164.1\Skinner.lua:1294: in function <Skinner\Skinner.lua:1276>
    Skinner-b4.13164.1\Skinner.lua:1351: in function `skinEditBox'
    Skinner-b4.13164.1\SkinMe\AdiBags.lua:19: in function <Skinner\SkinMe\AdiBags.lua:15>
    (tail call): ?:
    <in C code>: ?
    <string>:"safecall Dispatcher[1]":9: in function <[string "safecall Dispatcher[1]"]:5>
    (tail call): ?:
    AceTimer-3.0-5 (AdiBags):166: in function <...ce\AddOns\AdiBags\libs\AceTimer-3.0\AceTimer-3.0.lua:138>

    ---
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Quote from Jncl
    Hi,
    Skinned FPSideBar (as requested by mkcorp), POMAssist (as requested by skyggesang) & WowLua
    Updated ArkInventory skin

    More Beta/PTR changes
    Improve Frame Enabling/Disabling code

    b4.12984.1


    Thank you so much!
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Hi Jncl, sorry to bug you again but do you think you could add POM Assist to the skins? Thanks again for keeping Skinner maintained and updated. :)
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Quote from Jncl
    Hi skyggesang,

    You've found a bug, thanks ;-).A tooltip border value of 1 should use the Tooltip border colour setting and 2 should use the Frame border colour, these are reversed at the moment.

    Looking at the description of TipTop it changes the border colours so you may want to turn that feature off


    You are very welcome. :) Thank you for looking into it and resolving the issue. It works perfectly now. I have taken TipTop out of my UI now as I was only using it for the ability to move the tooltip which can also be done with MoveAnything.

    Thank you so much for the QuestHelper skin and keeping this beautiful addon updated as well. You have made the game UI much more pleasing to look at.

    Cheers.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Quote from Kerecha
    Would seem like a conflict of some sort, i just tested myself ingame and the frame is fully skinned.

    Perhapps an issue related to the new way of handling textures?


    Well, I just tested it with all addons disabled except for Skinner and DBM. The /range check window was still not skinned.

    Edit note: problem solved. :oops: It is because I had not enabled tooltip skinning due to TipTop already handling the tooltip. I apologise for the misunderstanding.

    However, I now have a question. The border shows up as bright white when the rest of my borders are a dark blue even after reloading the interface. I have the tooltips style set to "3" and tooltip border colour set to "2" (also white when set to "1"). Glaze status bar is unticked. Should I change these?

    Thank you again.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Quote from Jncl
    Hi skyggesang,
    What is this frame, I've never heard or seen it?

    I've encountered this several times but not consistently. I don't think it's Skinner related but will do some more checking.


    Jncl, thank you so much for your time. I thought the /range window was part of the default UI, but now I realise, I was mistaken. If it is indeed a part of DBM, Skinner is not handling it as Kerecha has mentioned above because I am using krsnik and Caith borders and DarkBottom and Flat textures, what shows up is the default Blizzard tooltip border and texture. See this photo.

    Also, the vehicle error is most likely not a Skinner problem since I have seen many people in the official forums with the same problem who give no indications of using it. I just never encountered it before I started using Skinner so I thought I'd mention it here to rule out that possibility since you are so good at responding and maintaining your addon. Again, it mostly seems to happen when exiting the vehicle in combat and occassionally out of combat. I can provide a list of my addons if you need them. Thank you again. :)
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Quote from Kerecha
    second issue sounds like its you barmod


    Thank you for replying. I really appreciate it.

    I ask here because I never had this problem prior to installing Skinner even with StellarBars and ButtonFacade. Upon doing a little research, I found people on the USWoW UI forum having the same problem without using any action bar addons at all.

    See the following threads:

    Vehicle UI in Raids
    Vehicle UI to Regular UI

    As you can see, no possible reasons or solutions were given.

    However, in this thread, there is. But this does not explain why I never had this problem prior to installing Skinner. Could it be a conflict between addons?

    Also, I am not a programmer. The few attempts I have made at creating my own addons, including the (most likely outdated) projects in Hacking World of Warcraft have ended in failure, so the suggestion made in that last thread is not really an option for me.

    Thank you again for reading this.
    Posted in: General AddOns
  • To post a comment, please or register a new account.