• 0

    posted a message on Where did TriviaBot go?
    Well half of the problem is that the download page is gone from curse and there doesn't seem to be much way to get it back since it's been abandoned by the author, which also means that all of my comments are gone too. The curseforge page for it though can be found over here: http://wow.curseforge.com/addons/trivia-bot/files/46-v2-8-8-50400/#w-version-2-8-8-28-11-2013. Aiden up there probably just needs to update his quiz to tell the game that it works with current versions of the game (because it does, as long as the base triviabot works) to get his quiz showing back up on curse.

    The bug in 6.0 does not have an error message, but doesn't detect any quizzes because of a change with the way loading addons on demand worked, namely that the function GetAddOnInfo no longer returns a value for the whether an addon is enabled or not, but rather if its loadable, which doesn't actually tell us what we want to know since the quizzes are load on demand and will say that they aren't loadable because of that.

    The dirty fix that I originally found involves replacing the 4th value, the "loadable" boolean, returned by GetAddOnInfo with the one returned by GetAddOnEnableState (using the currently played character's settings and comparing that greater than a value of 0 to get a true/false value) on lines 356 and then used on 357 of the main TriviaBot.lua file. This retains the intended functionality of only discovering enabled quizzes, but could probably be handled better.

    alternatively you could also check the 5th return of GetAddOnInfo against "DEMAND_LOADED", since all of the quizzes are load on demand.

    Alternatively the if statement on line 357 and its accompanying "end" on line 362 could just be removed, in which case you also get around the problem, but have some unintended behavior of discovering any quizzes that are not actually enabled. Attempting to load these discovered quizzes has the addon spit out an error indicating that the quiz in question has actually been disabled and can't be loaded.

    None of these changes fundamentally change how the addon works with regards to blizzard's changes and ultimately I don't know enough about the 6.0 addon changes or coding to say how the "if" on line 357 should be changed to appropriately handle the api changes, so for me it's just a dirty fix that keeps the addon kicking, but will probably come back with a vengeance if/when blizzard decides to change how addons load in the future.
    Posted in: Addon Ideas
  • 0

    posted a message on Where did TriviaBot go?
    There was 1 6.0 change that broke the addon. It was related to loading the plugin quizzes. This stopped quizzes from being loaded completely.

    Unfortunately the addon has been completely abandoned by its author and hasn't seen an update in a year and a half (even though there has been some bugs that stop it from working in 5.4 even, although intermittently) . I posted a fix for this on the curse.com page but no fix or communication from the author/maintainer has happened.
    Posted in: Addon Ideas
  • To post a comment, please or register a new account.