• 0

    posted a message on Grid2 - What it is, and what it's not
    Hi,

    I've already made a ticket but I am posting this here too. Since 5.1 I am getting a lua error caused by StatusShields. The moment I get in combat and a shield that isn't mine is applied the addon starts throwing lua errors. I've tried resetting the saved variables etc. Didn't work. Here is the error:

    Message: Interface\AddOns\Grid2\modules\StatusShields.lua:50: attempt to compare number with boolean
    Time: 11/29/12 14:05:41
    Count: 12
    Stack: Interface\AddOns\Grid2\modules\StatusShields.lua:50: in function `UpdateShields'
    Interface\AddOns\Grid2\modules\StatusShields.lua:77: in function `?'
    ...Log\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:147: in function <...Log\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:147>
    [string "safecall Dispatcher[18]"]:4: in function <[string "safecall Dispatcher[18]"]:4>
    [C]: ?
    [string "safecall Dispatcher[18]"]:13: in function `?'
    ...Log\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:92: in function `Fire'
    ...ce\AddOns\AutoLog\Libs\AceEvent-3.0\AceEvent-3.0.lua:120: in function <...ce\AddOns\AutoLog\Libs\AceEvent-3.0\AceEvent-3.0.lua:119>
    
    Locals: <none>
    Posted in: Grid & Grid2
  • 0

    posted a message on Grid2 - What it is, and what it's not
    Is it intended that you can only anchor on one element once? I am trying to anchor a "shield bar" to go the opposite way of the health bar but because the incoming heals bar is anchored to it I don't even have the option available. Is there a workaround for that?
    Posted in: Grid & Grid2
  • 0

    posted a message on DrDamage - Official Thread
    Paladin Holy Radiance shouldn't have "NoDotHaste = true ". It does in fact gain ticks through haste.
    Posted in: General AddOns
  • 0

    posted a message on Grid — compact party/raid unit frames
    Is it normal that the incoming heals are way off? For Greater Heal in example it shows around 2k lower. Does it have to do with the fact that there is no need for LibHealComm anymore(hence being an error on Blizzard's side)? That's assuming that it happens to everyone and not just me.

    Thanks in advance.
    Posted in: Grid & Grid2
  • 0

    posted a message on DrDamage - Official Thread
    Hello again, I managed to fix PW:Shield too! It was showing for more than 1k lower than what the blizzard tooltip states(which is identical to combat log report so it is correct).

    First of all while the talent Imp.Power Word: Shield states it's 5/10% it's actually 10/20%(refer to http://elitistjerks.com/f77/t105330-cataclysm_healing_priest_theorycrafting/p4/#post1784551) so I changed the code for this talent to that
    --Improved Power Word: Shield (multiplicative - 3.3.3, updated for 4.0.3)
            [GetSpellInfo(14748)] = {     [1] = { Effect = 0.1, Spells = "Power Word: Shield", ModType = "Improved Power Word: Shield" }, },
    There was still a slight difference after that, so I checked Twin Disciplines and it was marked as a bonus to "all", now I don't know if all covers shields too but switching the code of it to this
    --Twin Disciplines (additive - 3.3.3, updated for 4.0.3)
            [GetSpellInfo(47586)] = {     [1] = { Effect = 0.02, Spells = "Power Word: Shield","All"  }, },
    did the trick for me as it's the average hit is now only 2 absorption points below the real one. I have to mention that when I tried to put the "PW:S" part after "all" it didn't work but in front of it made it work.
    Posted in: General AddOns
  • 0

    posted a message on DrDamage - Official Thread
    Hello Gagorian!

    Just a heads up for you, Grace for priests is broken. The code is

    --Grace (updated for 4.0.3)
            [GetSpellInfo(47516)] = {     [1] = { Effect = 1, Spells = "Healing", ModType = "Grace" }, },
    While it should be


    --Grace (updated for 4.0.3)
            [GetSpellInfo(47516)] = {     [1] = { Effect = 0.04, Spells = "Healing", ModType = "Grace" }, },
    Posted in: General AddOns
  • 0

    posted a message on Quartz: Modular Casting Bar
    Is there a way to fix the problem with the dropdown menus? I'm using Shared Media and trying to pick bar texture I can't see past R because it clips though the screen.
    Posted in: General AddOns
  • 0

    posted a message on PitBull 4.0
    Quote from Shefki
    Is the Use unfriendly colors option in colors, Aura on Friendly auras what you want?

    Unless I'm screwing it up I don't think it is. To make it more clear what I'm trying to do. I just migrated from Pitbull 3 to Pitbull 4. My setup for auras was
    Green for buffs, Red for Debuffs(no colouring by type) regardless of the target being hostile or friendly. With Pitbull 4 by default it's green buffs and red debuffs for friendly targets but targetting an unfriendly target has reverse colours(red buffs green debuffs). If I enable Use Unfriendly Colors while all unfriendly colors are tuned to red(I don't need colouring by spell type) then even targeting friendly targets gives me red buffs. If I switch unfriendly auras to green it has opposite results, while I do get buffs green on every target, I also get the debuffs.

    I hope that's not confusing.
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    I've been facedesking 1 hour now. Tried to find a solution, my searches in this thread absolutely failed (found irrelevant stuff). I was wondering how I could reverse the colours of debuffs and buffs on hostile targets. Right now hostile target buffs are red and their debuffs green. I want them as they were on PB3 since I use another addon to keep track of my own debuffs.
    Posted in: Unit Frames
  • 0

    posted a message on XLoot
    I get this taint error since 3.1
    5/10 01:19:49.351  An action was blocked in combat because of taint from XLoot - LootSlot()
    5/10 01:19:49.351      Interface\FrameXML\LootFrame.lua:191 LootButton_OnClick()
    5/10 01:19:49.351      Interface\AddOns\XLoot\XLoot.lua:338
    5/10 01:19:49.351      XLootButton1:OnClick()
    5/10 01:24:00.637  An action was blocked in combat because of taint from XLoot - LootSlot()
    5/10 01:24:00.637      Interface\FrameXML\LootFrame.lua:191 LootButton_OnClick()
    5/10 01:24:00.637      Interface\AddOns\XLoot\XLoot.lua:338
    5/10 01:24:00.637      XLootButton1:OnClick()


    Any way to fix this? The addon hasn't been updated for ages so if it's abandoned is there any alternative?
    Posted in: General AddOns
  • 0

    posted a message on DrDamage - Official Thread
    I noticed that the healing values of my healing spells as Discipline Priest are way off in Penance and a bit off with the rest spells. Investigating it a bit I think I've found the root of the problem.

    About Flash Heal/Greater Heal/Binding Heal and basically every heal but Penance, Focused Power isn't factored. Focused Power as it is, adds up 4% Healing (and damage) multiplicative on every spell just like Spiritual Healing.

    Power Word: Shield values are way off but I'm pretty sure it's buggy in live so I'll have to investigate it a bit more. The formula I found in EJ was

    ((Base Absorb + 1.5/3.5*1.883*SPP + 0.08*BT*SPP) * (1+Imp*0.05) * (1+TD*0.01+FP*0.02))

    were Base Absord=2230, SPP= Spell Power, BT= Borrowed Time, Imp= Imp.PW:S, TD= Twin Disciplines and FP= Focused Power. Although this formula is accurate for PTR 3.08 and I get lower absorption value than ingame which seems to be that Imp.PW:S is counted twice on live; so base amount is multiplied by 1.15 and then multiplied again after the talent and spellpower gains.

    Last but not least Penance. Penance average heal as it is, is counted as (1580+((0.571*1.883*SpPower)/3)). That's 2231 average heal per tick with 1818 SpPower according to DrDamage. Truth is Penance will heal for 2600-2900 instead pre-Grace. Doing some research, mostly trial and failure I've found out that it's more like:

    1580+((0.571*1.883*SpPower)/2))*(Focused Power+Twin Disciplines)

    that's 2792 which is if not 100% accurate at least very close to the true average value. Now I'd guess the reason Penance only divides SpPower by 2 is that the first tick is instant but still uses the same coefficient with the 2 channeled heals. All 3 ticks have identical power so it's not really an instant spell (0.429*1.883) plus two ticks of a 2sec channeled heal(0.571*1.883).

    Oh, also Grace isn't counted at all. It works exactly as Focused Power/Spiritual healing 2%*Stack multiplicative increase.
    Posted in: General AddOns
  • 0

    posted a message on PitBull 2.0
    I've had some strange behaviour two days ago. I was on my priest and I have only my buffs shown on the party/target frames. I'm tracking Renew duration with the buff button turning grey as the time passes. Although that day the buffs started flickering and from what I understand, basically the grey part of the button was vanishing momentary to reappear 0,5-1 second later.
    Posted in: Unit Frames
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    Is there a way to move the configuration window? I'm using SharedMedia and the Fonts in the Font selection go off screen so I can only see like 10 of them. Any way to fix this?
    Posted in: General AddOns
  • 0

    posted a message on DrDamage - Official Thread
    Also there's a calculation bug I've noticed with rogues. Check this out:



    As you see my crit chance is 33.24%, but on Backstab it shows 68.24%. Improved Backstab grants +30% crit so it should be 63.24%. This error appears on every ability(+5% crit up from the correct one). I suspect, that it's counting dagger specialization twice for some reason. I've tried to unequip my offhand to see if it erroneously counts +10% crit because I use two daggers, but I still get the same crit chance.

    PS. I also tried updating DrDamage but the problem still exists.

    Edit: About Mutilate: I've just tested the new version on the PTR and it shows the Combined Total correctly when AvgTotal is selected. I don't know if I had a really old version on my live client. I'll test it again when I spec back to Mutilate on live.
    Posted in: General AddOns
  • 0

    posted a message on DrDamage - Official Thread
    Quote from Gagorian »

    With the AvgTotal display option it should show combined total, because that is the same table value that is used for the tooltips Combined Total display. Make sure you have that selected.. If it still doesn't display combined totals I'll need to borrow some char with a dual attack ;)

    I'm sorry to say it, but it doesn't. I'm using the AvgTotal anyway, and it's showing the mainhand AvgTotal instead of the combined.
    Posted in: General AddOns
  • To post a comment, please or register a new account.