• 0

    posted a message on UI Screenshots - Show us what you use!
    Here Wonderfools WonderUI 2.0 :)



    Basic ingredients:

    • Viewframe set with aperture, background with EEPanels
    • Prat, Bartender, Eavesdrop, Ricos Minimap
    • Pitbull for self (center), target (left) and focus (right) frames. Focus can be set with the Focus button (left-click set, right-click clear)
    • All buffs visualized with Pitbull (you cant see any buffs/debuffs on target/focus, its shackled). Debuffs above unit frames, Buffs below
    • Quartz for own cast bar
    • Omen and Recount for entertainment, don't really need it as a priest
    • oRA2 and BigWigs, you can see oRA2 main tank frames to the left
    • Aloft (and Tinytip)
    • Chronometer (left), Shacklewatch and MendWatch (right)
    • FuBar panel at top (hidden) and bottom
    • Grid/Clique for healing
    • Trinketmenu
    • XRS to the right

    Posted in: General Chat
  • 0

    posted a message on ArkInventory v2.00
    Quote from Wonderfool »

    I configured some rules using outfit() (i have outfitter) and noticed that opening bags (and bank) took much longer than before. Anybody else noticed that too? Is there a way to reduce this overhead?



    Now i found out the real reason. I happened to check "Include item category" under sorting too at the same time. Enabling this makes opening bags/bank or even transferring items from bank to bags or vice versa MUCH slower.
    Posted in: General AddOns
  • 0

    posted a message on PitBull - official topic
    Quote from Wonderfool »

    I noticed while canceling buffs with right-click works fine, it doesn't work for self-inflicted debuffs. At least it doesn't work for Priests Mind Vision.

    I switched to Pitbull solely displaying all my own buffs/debuffs. I just made the icons on my own frame big enough to see the cooldown timers (see http://home.arcor.de/gunter63/WonderUI20.jpg. So it would be nice if this worked.

    Weapon buffs aren't displayed at all. Is support for them planned/possible, maybe just displaying them as normal buffs?



    I am a noob at LUA and WoW scripting, but a quick&dirty patch seemed to work:

    Add the following to functions in Aura\Aura.lua after buffFrame_OnMouseUp:

    local debuff_down_button, debuff_down_button_name
    local function debuffFrame_OnMouseDown(this, ...)
    	debuff_down_button = nil
    	if this.player and not IsAltKeyDown() and not IsControlKeyDown() and not IsShiftKeyDown() then
    		-- local id = GetPlayerBuff(this.id, "HELPFUL")
    		local id = this.id
    		debuff_down_button_name = GetPlayerBuffName(id)
    		debuff_down_button = this
    	end
    end
    
    local function debuffFrame_OnMouseUp(this, ...)
    	if debuff_down_button == GetMouseFocus() and debuff_down_button == this and this.player then
    		-- local id = GetPlayerBuff(this.id, "HELPFUL")
    		local id = this.id
    		if GetPlayerBuffName(id) == debuff_down_button_name then -- don't want to cancel some other buff accidentally.
    			CancelPlayerBuff(id)
    		end
    	end
    end


    and look for the line:

    			debuffFrame:SetScript("OnLeave", debuffFrame_OnLeave)


    and after that add

    			debuffFrame:SetScript("OnMouseDown", debuffFrame_OnMouseDown)
    			debuffFrame:SetScript("OnMouseUp", debuffFrame_OnMouseUp)



    I had to replace GetPlayerBuff(this.id, "HELPFUL") with this.id.
    As already stated i am a noob and don't know if this will work in every case ;). But i can cancel my Mind Vision now.

    Edited:

    Noticed that underscores sometimes don't display in the code sections, they are there in the edit window. debuff_down_button and debuff_down_button_name and the function names have underscores!
    Posted in: Unit Frames
  • 0

    posted a message on ArkInventory v2.00
    I configured some rules using outfit() (i have outfitter) and noticed that opening bags (and bank) took much longer than before. Anybody else noticed that too? Is there a way to reduce this overhead?
    Posted in: General AddOns
  • 0

    posted a message on PitBull - official topic
    I noticed while canceling buffs with right-click works fine, it doesn't work for self-inflicted debuffs. At least it doesn't work for Priests Mind Vision.

    I switched to Pitbull solely displaying all my own buffs/debuffs. I just made the icons on my own frame big enough to see the cooldown timers (see http://home.arcor.de/gunter63/WonderUI20.jpg. So it would be nice if this worked.

    Weapon buffs aren't displayed at all. Is support for them planned/possible, maybe just displaying them as normal buffs?
    Posted in: Unit Frames
  • 0

    posted a message on ArkInventory v2.00
    The rule tooltip(damage) will only be applied on items which have the string "damage" in the "Use:" or "Set:" part of the tooltip, not in the "Equip:" part.

    Is the "Equip:" part not part of the basic WoW item tooltip text?

    Posted in: General AddOns
  • 0

    posted a message on NShakedown - Organise Your UI - Official Thread
    Adding a grid for aligning stuff would be useful, like http://www.wowinterface.com/downloads/info7231-Align.html does. So we'll have an all-in-one helper :)

    What do you think?
    Posted in: General AddOns
  • 0

    posted a message on NShakedown - Organise Your UI - Official Thread
    Pitbull, Quartz and Chronometer work perfectly now. You'll save the Ace community countless hours of configuring their latest and greatest UI :D.

    The only minor thing i miss now (as a Priest) is MendWatch.

    This little addon was a great idea!
    Posted in: General AddOns
  • 0

    posted a message on NShakedown - Organise Your UI - Official Thread
    Chronometer support would be nice yes.

    What about toggling Pitbull config mode? That would be nice to see if buff/debuff display will overlap.
    Posted in: General AddOns
  • 0

    posted a message on Prat 2.0 Chat Mod Framework
    Anyone has an idea how to solve that problem?

    Quote from Wonderfool »

    I have a problem with item links in a user created chat channel.

    They look like

    pcffffffff pHitem:3665:0:0:0:0:0:0:61407264ph[Curiously Tasty Omelet]

    Changing all possible setting combinations of the Chatlink module doesn't help, as does not disabling the module.

    Clearing the flag "Do the actual chat replacement" makes it go away.

    This channel is also used for GEM (guild event manager) communication and GEM is running. As i understand it GEM also tries to make linking in user created channels possible. Probably there is now a clash between GEM and Prat.

    It worked with Prat 1.0, though.

    Posted in: General AddOns
  • 0

    posted a message on Prat 2.0 Chat Mod Framework
    I have a problem with item links in a user created chat channel.

    They look like

    pcffffffff pHitem:3665:0:0:0:0:0:0:61407264ph[Curiously Tasty Omelet]

    Changing all possible setting combinations of the Chatlink module doesn't help, as does not disabling the module.

    Clearing the flag "Do the actual chat replacement" makes it go away.

    This channel is also used for GEM (guild event manager) communication and GEM is running. As i understand it GEM also tries to make linking in user created channels possible. Probably there is now a clash between GEM and Prat.

    It worked with Prat 1.0, though.
    Posted in: General AddOns
  • 0

    posted a message on Profile/Saved Variable issues after recent AceDB change
    Ok, it kinda worked.

    I had to go through every Ace2-based addon (and have quite a few) and change the profile back to the character-based. Sometimes i had to copy from the character-based profile after. Sometimes there were some other glitches too. It took a while.

    Posted in: General AddOns
  • 0

    posted a message on Profile/Saved Variable issues after recent AceDB change
    Quote from Athariel »

    Theres no problem at all. It just resets all your configuration to "Default". I was using my specific set of configurations, and after the reset just loaded it.


    This didn't work for me. I glanced over the changes in Ace-DB and it seems a kind of automatic conversion is being made. Perhaps this doesn't work in all cases.
    Posted in: General AddOns
  • 0

    posted a message on Profile/Saved Variable issues after recent AceDB change
    Btw, i have an english WoW client, playing on a german Windows XP
    Posted in: General AddOns
  • 0

    posted a message on Profile/Saved Variable issues after recent AceDB change
    Quote from funkydude »

    the issue has already been fixed in the latest revision. 23704


    Not for me, i have the problem with exactly that version.

    The last working version i tried is r23407
    Posted in: General AddOns
  • To post a comment, please or register a new account.