• 0

    posted a message on PassLoot - Official thread
    should be fixed
    Posted in: General AddOns
  • 0

    posted a message on PassLoot - Official thread
    And that's what I did. I used the ace3 options table it produces for my dropdowns n stuff. The only downside I see is that if libsink changes how it does the options table (ie - i looked for type=toggle, and not hidden stuff).. then i will have to keep up on the changes..
    Posted in: General AddOns
  • 0

    posted a message on PassLoot - Official thread
    Hrmf.. Went into that thinking this would be easy.

    I do not like LibSink at all. It only gives Ace2 or Ace3 config option definitions, which is great if you use them. I am using a custom UI that doens't use either. I thought about Dewdrop for a dropdown menu for it, but it requires Ace2 libraries. Loading both Ace2 and Ace3 libraries kind of feels.. wrong. I couldn't find any other libraries to display a drop down window to deal with the config option definitions, so I just parsed them myself and did a hack job.

    Never went with the ace3 config stuff because I never found any good GUI widgets that do what I wanted. (and I'm not about to spend time making my own)

    I'm about to just rip the option out. It just doesn't seem to be worth the effort.
    Posted in: General AddOns
  • 0

    posted a message on PassLoot - Official thread
    Heh, glad you guys know all the good libraries.. I don't have time to look over them all :)

    I'll work on adding it after my raid tonight.
    Posted in: General AddOns
  • 0

    posted a message on PassLoot - Official thread
    Ah, didn't know about the GetSellValue() thing. I've switched to that. And if ItemPrice-1.1 is available, it can use that still.

    As for the output frames, I used to just iterate through UIParent's direct children for a ScrollingMessageFrame. Now I recursively iterate through all UIParent's children. This should get whatever frame you are wanting it to output to. (hopefully)

    Havn't heard any word back on if the LootWon Counter stuff is working again? Think I fixed it last update.
    Posted in: General AddOns
  • 0

    posted a message on PassLoot - Official thread
    Ok, I think I found the bug.. and man was it hard to find.

    If you have not added the counter or comparison filters to a rule yet, and you add the counter first it doesn't add the counter filter correctly. (if you add the comparison first, it automagically adds the counter filter.. and does it right)

    I'm throwing in a better data validation check on each of the filters. If it detects invalid data, it sets it to a default value (0 for the counter), and saves it.

    Hopefully this should fix your problem. And hopefully you didn't get too much grief from your guildmates when rolling when you shouldn't have. :)

    Posted in: General AddOns
  • 0

    posted a message on PassLoot - Official thread
    Hrm... something I hadn't considered... Did it stop working for you when I changed the UI itself to let you set up multiple filters of the same type? (ie your screenshot is of the new layout vs the older layout)
    Posted in: General AddOns
  • 0

    posted a message on PassLoot - Official thread
    Well, I've tried every build that I listed, and I can't seem to replicate the problem. I had 3 rules that I tested in deadmines and each rule's counter incremented when it matched it's corresponding rule.

    When it said it rolled on the marks, which rule did it say it used? It should have been in parenthesis. I'm wondering if it didn't match the rule you have highlighted (maybe the item name or some other filter is bugged, and it's rolling on a rule further down? or further up?)

    I'll continue to keep looking into it.


    edit: if you want to see what's going on, you can do a /script PassLoot.DebugVar = true
    Be prepared for spam tho, and to turn it off, just /script PassLoot.DebugVar = false
    Posted in: General AddOns
  • 0

    posted a message on PassLoot - Official thread
    Quote from reale »

    Loot counter isn't working, was working perfectly with Mark of Illidari before the update. I've changed no rules.


    Which build was working fine?
    79076 (July 24) I made it multiple filters (could have messed up here)
    79132 (July 25) I fixed a ui error
    80112 (Aug 10) I attempted to add WotLK compatibility (this is where i'd think it broke for you?)
    80189 (Aug 11) I changed how I pass information to display in tooltips, added in itemlevel/required level filter, added changable chatframe ouput, and added a Settings tab
    80512 (Aug 15) I added in the ItemPrice filter, LootWon filter unchanged at all.
    80803 (Aug 22) I edited the .toc and .lua file descriptions to show version 3.4 instead of 3.3

    I am gonna push another change in a minute to fix a few wotlk things, saw some arg1's and this's
    Posted in: General AddOns
  • 0

    posted a message on PassLoot - Official thread
    Added a ItemLevel and RequiredLevel filters
    Added a Settings tab, where the quiet and enable mod checkbox lives now
    Added an option to change output to different chat frames.
    Changed the ShowTooltip() so if you get errors when mousing over things.. lemme know

    I made a filter for Item vendor prices, but I havn't added it to the core module list yet. Since it uses the ItemPrice-1.1 library which is a good 250+ KB, I was thinking I might make it a separate addon instead of forcing the user to load a library they might/might not use. Then I got to thinking I might just move all the modules to their own addons.

    I can't decide what to do.
    Posted in: General AddOns
  • 0

    posted a message on PassLoot - Official thread
    Updated for WotLK compatibility
    Posted in: General AddOns
  • 0

    posted a message on PassLoot - Official thread
    Ok, tried to reproduce bug. I got an error on that line, when i had 2 item name filters, i had the 2nd highlighted, and was in the middle of editing it, then shift-right clicked the first one.

    That sound familiar?

    edit: Okay, was able to produce 3 different bugs all similar in nature. They are just display bugs. Doesn't look like they will impede operations.

    edit2: fixed.
    Posted in: General AddOns
  • 0

    posted a message on PassLoot - Official thread
    I really liked your idea with having a list of active filters. I have been wanting to make it so you can select multiple filters for some time, but was wrestling with how to display it.

    So.. there are now two lists: one is of available filters and the other is of active filters.

    Also made it so you can add multiple filters of the same type (ie - add rare and epic quality filters at the same time) Each filter must have at least one match.

    An example of the logic:
    Quality:
    Rare
    Epic
    Binds on:
    None
    Equip
    Use

    This will match all (Rare OR Epic) AND (None OR Equip OR Use)

    When it upgrades your old database, you'll still see a lot of 'Any's, you can remove those from the active filters to clean it up if you so choose.

    A few notes: you can either select a filter to remove individually, or select the title of the filter to remove all of that type. (You can also shift-right-click to remove instead of clicking the remove button)


    As for sending output to another channel, I'll add that later, I want to make sure I have the multiple filter thing working first. Get to work beta testers! :)
    Posted in: General AddOns
  • 0

    posted a message on Bang it harder problem
    edit: should be fixed now.
    Posted in: AddOn HELP!
  • 0

    posted a message on PassLoot - Official thread
    Okay, was doing some checking, think I might have found the error. r77429 should fix it.
    Posted in: General AddOns
  • To post a comment, please or register a new account.