• 0

    posted a message on LibNameplate-1.0
    i receive numerous (hundreds) erros in game, they look like this one:

    1x LibNameplate-1.0-2:484: table index is nil
    LibNameplate-1.0-2:520: in function <...bNameplate-1.0\LibNameplate-1.0\LibNameplate-1.0.lua:504>
    LibNameplate-1.0-2:538: in function <...bNameplate-1.0\LibNameplate-1.0\LibNameplate-1.0.lua:527>
    LibNameplate-1.0-2:602: in function <...bNameplate-1.0\LibNameplate-1.0\LibNameplate-1.0.lua:592>
    (tail call): ?:
    
    Locals:
    frame = <unnamed> {
     0 = <userdata>
     lnpCheckForTarget = false
     aloftData = <table> {}
     lnpLastUpdate = 3.8970001861453
    }
    raidNum = 1
    from = "UpdateNameplateInfo"
    g
    
    Posted in: Libraries
  • 0

    posted a message on HeadCount - Raid attendance and loot tracker
    Quote from notrachel
    A couple of people have in the past asked me about parsing HeadCount offline for attendance and looting solutions that don't involve full DKP and/or web hosted solutions.

    So on the off chance that this sort of thing is still of interest to people i published my softare (inc. code) on CodePlex at http://headcounter.codeplex.com/


    Pitty it doesn't work with localizations (RU data for instance).
    Posted in: Raid AddOns
  • 0

    posted a message on HeadCount - Raid attendance and loot tracker
    after applying this patch http://paste.wowace.com/955/ I receive following errors while mouse hovering the boss, loot, raid list and whait list buttons in raid section:

    [2009/08/15 17:31:47-878-x4]: HeadCount-1.6.0\HeadCountFrames.lua:2131: attempt to index field '?' (a nil value)
    <string>:"*:OnEnter":1: in function <[string "*:OnEnter"]:1>

    [2009/08/15 17:31:47-878-x5]: HeadCount-1.6.0\HeadCountFrames.lua:2105: attempt to index field '?' (a nil value)
    <string>:"*:OnEnter":1: in function <[string "*:OnEnter"]:1>

    [2009/08/15 17:31:53-878-x5]: HeadCount-1.6.0\HeadCountFrames.lua:2078: attempt to index field '?' (a nil value)
    <string>:"*:OnEnter":1: in function <[string "*:OnEnter"]:1>

    [2009/08/15 17:31:53-878-x3]: HeadCount-1.6.0\HeadCountFrames.lua:2051: attempt to index field '?' (a nil value)
    <string>:"*:OnEnter":1: in function <[string "*:OnEnter"]:1>
    Posted in: Raid AddOns
  • 0

    posted a message on [Grid] Modules: Threat,RaidIcons,MTs / Indicators: Text3,SideIcons
    i've got the same issue. there is no centertext2 in my grid options and centertext3 option is grayed after its installation.
    Posted in: Grid & Grid2
  • 0

    posted a message on FuBar2Broker (Unofficial)
    Quote from HunterZ
    Did you get a warning message in the chat frame?


    yes i did:

    23:58:58] FuBar2Broker: Broker plugin Aloft already exists, aborting. This is most likely due to the addon attempting to create both a native Broker plugin and a FuBar plugin.
    [23:58:58] FuBar2Broker: Broker plugin Aloft already exists, aborting. This is most likely due to the addon attempting to create both a native Broker plugin and a FuBar plugin.
    Aloft version 2.7.4.810
    ?????? ???? ??????????, ?????????? /buggrabber ????? ?????????? ??.
    Calendar: ARGGGGGGGHHHH
    Telo's LootLink AddOn loaded
    Stackpack 2.1 loaded. Type /sp help for options.
    [23:58:58] FuBar2Broker: Broker plugin Aloft already exists, aborting. This is most likely due to the addon attempting to create both a native Broker plugin and a FuBar plugin.
    Posted in: Data Broker AddOns
  • 0

    posted a message on FuBar2Broker (Unofficial)
    Quote from HunterZ
    SigAnsweringMachine is definitely trying to make a native Broker object and then a FuBar one. I suspect Aloft is as well for those having problems with it, even though it wasn't for me for some reason.

    For those having issues, try this build and let me know what happens:


    so far i see no errors with this testfix build, thanks a lot!
    Posted in: Data Broker AddOns
  • 0

    posted a message on FuBar2Broker (Unofficial)
    Quote from HunterZ
    For Aloft, yeah.

    I'm thinking that maybe Aloft tries to create both a native FuBar plugin and an LDB plugin, and for some reason Fubar2Broker on your setup is trying to show the FuBar plugin on your LDB display (Fortress) in addition to the native LDB plugin created by Aloft. If this is the case, then Aloft should be fixed to take the presence of F2B into account. What's weird is that it doesn't happen to me though.

    I'm also thinking of adding more debug logging though to see if there's an obvious fix that can be made to F2B. Certainly it should hande the tocname=nil issue in a way other than generating an error, such as either substituting a dummy value or not proceeding as if a broker plugin was successfully created.

    Edit: The difference may also be that I'm using this: http://mikk.wowforge.com/stuff/FuBar_for_FuBar2Broker.zip - that may be causing Aloft to only create a FuBar plugin, which is then translated into a broker plugin by F2B.


    I'm using dummy FuBar_for_FuBar2Broker as well.
    Posted in: Data Broker AddOns
  • 0

    posted a message on FuBar2Broker (Unofficial)
    Quote from HunterZ
    Hmm thanks I'll take a look when I'm at home.

    Do you still get a broker feed for Aloft even with the error?


    feed? if you mean broker icon on fortress panel - yes i have it all the time.
    Posted in: Data Broker AddOns
  • 0

    posted a message on FuBar2Broker (Unofficial)
    Quote from HunterZ
    BTW, what broker display are you using?


    i'm using fortress.

    ok, here the debug info i see in chat:

    Aloft version 2.7.3.767
    Aloft version 2.7.3.767
    Calendar: ARGGGGGGGHHHH
    [22:35:02] brokerPlugin is nil:
    [22:35:02]   type: data source
    [22:35:02]   icon: Interface\Icons\Spell_Frost_Wisp
    [22:35:02]   label: Aloft
    [22:35:02]   tocname: nil
    Posted in: Data Broker AddOns
  • 0

    posted a message on FuBar2Broker (Unofficial)
    Quote from HunterZ
    Are you using "Broker_Aloft" or "FuBar_AloftFu"? The Aloft page on WoWInterface says they're obsolete and should not be used.

    Edit: I tried the latest Aloft from WoWInterface and got no errors: http://www.wowinterface.com/downloads/info10864-AloftBeta.html

    Edit 2: Try using this version of FuBar2Broker.lua in place of the one you're currently using. It should dump some info to the chat frame in the event that the condition you're describing occurs. Let me know what it says.


    no i dont use "Broker_Aloft" or "FuBar_AloftFu", only AloftBroker as a part of aloft package.

    i'lll be back as soon as i have a chance to check the issue with your debug version.
    Posted in: Data Broker AddOns
  • 0

    posted a message on FuBar2Broker (Unofficial)
    Quote from Squeeg
    Actually, I had meant to turn all the addons above 'F' off at the same time. Then log in while they're turned off, to see if the error went away.

    But seeing as you spent all that time already... were those two addons the ONLY two that caused that error?... ANd have you tried updating them?


    yes these 2 addons are the only two that cause this error. and yes, i have the latest versions of them. well, Announceit! was updated by author 3 months ago... but aloft gets updates pretty often.
    Posted in: Data Broker AddOns
  • 0

    posted a message on FuBar2Broker (Unofficial)
    Quote from HunterZ
    Is the line number in the error the same with the version I linked? Line 154 doesn't seem to gel with the code I'm looking at.

    yes, the line number is the same.

    On a more serious note. Are you loading any out-of-date addons Dreykos? Try not loading them if you are. Also, try disabling all your addons that start before 'F', EXCEPT BugSack, !BugGrabber, and which ever display you use (if it's listed before 'F').


    I don't know exactly about what out-of-dates addon are loaded (not a one becomes marked read after i disabled this loading option but i am pretty sure there are some) but i spent some time turning off addons from A to F one by one and found out that there are 2 addons that make fubar2broker to load with this error: "aloft" and "announceit!".
    Posted in: Data Broker AddOns
  • 0

    posted a message on FuBar2Broker (Unofficial)
    Quote from HunterZ
    Is the version of F2B that you're using from Curse, or is it from WowAce? If you're using 1.0.3 from Curse then try http://static.wowace.com/uploads/18/315/832/FuBar2Broker-r75.zip instead and see if the issue still persists.

    If I can remember to, I might look at the code to see if there's some kind of easy workaround or debugging output that could be added, but it's likely that something more serious is going on as a result of some kind of library issue.


    I don't remember where i got my version from but anyway I deleted it and installed the one from your link. nothing changed, the problem still persists.
    Posted in: Data Broker AddOns
  • 0

    posted a message on FuBar2Broker (Unofficial)
    after disabling aloft...

    2009/01/22 13:19:47-605-x1]: FuBar2Broker-1.0.3\FuBar2Broker.lua:154: attempt to index local 'brokerPlugin' (a nil value)
    AceAddon-2.0-91094 (Decursive):983: in function <...\AddOns\Decursive\libs\AceAddon-2.0\AceAddon-2.0.lua:976>
    <in C code>: ?
    AceEvent-2.0-91091 (Decursive):260: in function `TriggerEvent'
    AceEvent-2.0-91091 (Decursive):910: in function <...\AddOns\Decursive\libs\AceEvent-2.0\AceEvent-2.0.lua:903>
    
      ---


    after disabling Decursive...

    [2009/01/22 13:22:10-606-x1]: FuBar2Broker-1.0.3\FuBar2Broker.lua:154: attempt to index local 'brokerPlugin' (a nil value)
    AceAddon-2.0-91094 (oRA2):983: in function <...rface\AddOns\oRA2\Libs\AceAddon-2.0\AceAddon-2.0.lua:976>
    <in C code>: ?
    AceEvent-2.0-91091 (ElkBuffBars):260: in function `TriggerEvent'
    AceEvent-2.0-91091 (ElkBuffBars):910: in function <...ddOns\ElkBuffBars\libs\AceEvent-2.0\AceEvent-2.0.lua:903>
    


    im afraid it can take a looooong time for i have a lot of addons =)
    Posted in: Data Broker AddOns
  • 0

    posted a message on FuBar2Broker (Unofficial)
    Quote from cM2003
    Isn´t working anymore for me, since the last patch ( 3.0.8 )

    -edit-
    Is working, but getting this errormessage:


    check my message above your one, its definitely not because of 3.0.8 patch.
    Posted in: Data Broker AddOns
  • To post a comment, please or register a new account.