• 0

    posted a message on Skinner
    Hi there. I'm experiencing some troubles with tekAccept (auto-accepting invites addons, and actually with any other similar addons).

    local function IsFriend(name)
    	for i=1,GetNumFriends() do if GetFriendInfo(i) == name then return true end end
    	if IsInGuild() then for i=1, GetNumGuildMembers() do if GetGuildRosterInfo(i) == name then return true end end end
    end
     
     
    local f = CreateFrame("Frame")
    f:RegisterEvent("PARTY_INVITE_REQUEST")
    f:SetScript("OnEvent", function(frame, event, name)
    	if IsFriend(name) then
    		for i=1,STATICPOPUP_NUMDIALOGS do
    			local frame = getglobal("StaticPopup"..i)
    			if frame:IsVisible() and frame.which == "PARTY_INVITE" then StaticPopup_OnClick(frame, 1) end
    		end
    	else SendWho(string.join("", "n-\"", name, "\"")) end
    end)


    With Skinner this does nothing, no errors are shown, but this snippet seems to have no access to popup.
    If i get invite while loading to world all goes smooth (i guess that is the time when popups are not skinned actually).
    Furthermore: using of AcceptGroup() and StaticPop_Hide seems not helping too.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Skin request: GnomishAuctionShrinker
    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Here's skin for IntricateChatMods copying window.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Skin request: BindPad.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Skin request: Alley Map.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Skin request: BasicChatMods urlcopy and chat copy windows skin.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    1x Skinner-b2.11159.3\SkinMe\tomQuest2.lua:119: attempt to index field 'ignoreLQTT' (a nil value)
    (tail call): ?:
    <in C code>: ?
    Skinner-b2.11159.3\Skinner.lua:800: in function <Skinner\Skinner.lua:798>
    Skinner-b2.11159.3\Skinner.lua:845: in function `?'
    Skinner-b2.11159.3\AddonFrames.lua:123: in function <Skinner\AddonFrames.lua:63>
    (tail call): ?:
    <in C code>: ?
    <string>:"safecall Dispatcher[2]":9: in function <[string "safecall Dispatcher[2]"]:5>
    (tail call): ?:
    AceTimer-3.0-5 (Ace3):164: in function <Ace3\AceTimer-3.0\AceTimer-3.0.lua:138>
    
      ---
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Switching to independent SharedMedia source solved the problem anyway. So i guess it's truly the fault of those addons (i mean they're both LOD).
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    All other addons including Pitbull4 load this texture without a problem.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Both Skada and Gladius have this texture in their directories.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Quote from Jncl
    Hi ichik,
    What addon are you using to provide an alternative texture ? Is it being loaded when you login ? The Blizzard texture is used if the alternative isn't available.


    Erm. Not pretty sure 'bout this. I prefer minimalist texture, that comes with some of Ace addons and available via SharedMedia.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Everytime i relog, Skinner resets status bar texture to Blizzard. Kinda annoying. Any ideas?
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Skin request DaemonMailAssist.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Oh. I'm ashamed. Really. ;)
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Well, there's actually no GatherMate.lua in AddonSkins directory.
    Posted in: General AddOns
  • To post a comment, please or register a new account.