CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on RatingBuster performance question
    Hmm that's bad news.. you'd think with a SSD and a quad core CPU the disc writing wouldn't be that much of an issue.
    Posted in: AddOn HELP!
  • 0

    posted a message on RatingBuster performance question
    These are the addons I use.
    Cooldowns
    Examiner
    MSBT
    RatingBuster
    Skada
    TrinketMenu
    VBM (Vision Boss Mod)
    WinterTime
    WowLua
    + a custom made font replacement addon

    Like you said the fps drop usually occurs when combat starts (in raids). I can go from 50+ fps out of combat to ~20 when combat starts. I'm gonna try to disable MSBT next time we raid and see if it helps, I wish I could re create the raiding scenario but not even AV fights puts me down to 20 fps..

    By the way I'm usually running /combatlog logging for world of logs, could that have any impact on performance?
    Posted in: AddOn HELP!
  • 0

    posted a message on RatingBuster performance question
    ohh sorry :) I'm trying to pinpoint what's causing my fps to drop.. as a general rule of thumb, what types of processing would cause the most cpu load for addons in Wow?
    Posted in: AddOn HELP!
  • 0

    posted a message on RatingBuster performance question
    slightly offtopic but does anyone know how fps intensive ratingbuster is?
    Posted in: AddOn HELP!
  • 0

    posted a message on Problem with custom textures
    I know this is not directly related to programing but I don't know where else to turn. I'm trying to make custom textures and I'm using this tutorial http://www.edowner.net/Texture-Tutorial/.

    I got everything working except for one small problem, when I set my texture to my object it adds a small glow-like effect to the outer border of my texture. I double checked and my alpha channel in photoshop has no shades of gray, only black and white.

    Is this how it's supposed to be? Every texture you add in wow automatically gets this glowy border effect?
    Posted in: Lua Code Discussion
  • 0

    posted a message on Actionbar buttons
    Another question, I tried to make a range check on the buttons but my event driven function failed since there are no events that fire as you move in/out of range of something.
    Looking through blizzards code I noticed it runs an OnUpdate script with range check included. So is that what I have to do? Create my own OnUpdate to check range?
    And if so, let's say I do 1 check every second and each check goes through 20 spells, will that create a lot of cpu processing?
    Posted in: Lua Code Discussion
  • 0

    posted a message on Actionbar buttons
    What if you did something like this
    local function UpdateCooldowns()
       for i = 1, numSpells do
          CooldownFrame_SetTimer(_G["frame_name"..i.."Icon"], GetSpellCooldown(table.spell[i]))
        end
    end
    
    f:RegisterEvent("ACTIONBAR_UPDATE_COOLDOWN")
    f:SetScript("OnEvent", UpdateCooldowns)


    to avoid OnUpdate having to run constantly?
    Posted in: Lua Code Discussion
  • 0

    posted a message on Actionbar buttons
    Thanks! that was more what I was looking for :)
    Just one question, does OnUpdate have to be running the whole time really? or can you hook SetTimer to some event perhaps?
    Posted in: Lua Code Discussion
  • 0

    posted a message on Actionbar buttons
    I know how to set attributes but I can't figure out how to put the icon and cooldown on the button, actually I'm really only interested in the cooldown (frame?). I'm probably asking the wrong question here.
    What I want is a copy of my action bar that's not actually a real action bar, but only displays the icon (or texture) and the cooldown animation.
    Posted in: Lua Code Discussion
  • 0

    posted a message on Actionbar buttons
    I want to make my own action bar with a few buttons and I've managed to create the secure action button..
    local btn = CreateFrame("Button", "test", UIParent, "SecureActionButtonTemplate, ActionButtonTemplate")
    btn:SetPoint("CENTER")
    btn:SetNormalTexture("Interface\\Buttons\\UI-Quickslot")
    


    But how do I actually add one of my skills to the button? Including cooldown and icon. :confused:

    Also, another question. Is SetHeight and SetWidth completely ignored when you use templates?
    Posted in: Lua Code Discussion
  • 0

    posted a message on runmacro?
    Thanks a lot!

    By the way, is this a good idea?
    [I]local btn = CreateFrame("Button", "testButton", UIParent, "SecureActionButtonTemplate, ActionButtonTemplate")
    btn:SetPoint("CENTER")
    btn:SetWidth(100)
    btn:SetHeight(55)
    btn:SetText("Test")
    btn:SetNormalTexture("UIPanelButtonUpTexture") [/I]
    
    btn:SetAttribute("type1", "macro")
    btn:SetAttribute("macrotext", "/cast Frost Bolt\n/script print('casting frostbolt')\n[B]/script testButton:Hide()[/B]")
    


    It casts the spell and prints it out and then hides the button, am I using this thing correctly? :p
    Posted in: Lua Code Discussion
  • 0

    posted a message on runmacro?
    It didn't work, it only executed the first command.
    Posted in: Lua Code Discussion
  • 0

    posted a message on runmacro?
    Nice thanks guys I got it working now, just 1 last question about the SetAttribute. What if I want to perform 2 actions by clicking the button, like this:
    btn:SetAttribute("type1", "macro")
    btn:SetAttribute("macrotext", "/cast Frost Bolt")
    btn:SetAttribute("macrotext", "/script print('casting frostbolt')")
    
    Posted in: Lua Code Discussion
  • 0

    posted a message on runmacro?
    well that didn't work.. I can't even get the button to show up. Am i missing something?
    local btn = CreateFrame("Button", "test", UIParent, "SecureActionButtonTemplate")
    btn:SetPoint("CENTER")
    btn:SetWidth(100)
    btn:SetHeight(55)
    btn:SetText("Test")
    
    Posted in: Lua Code Discussion
  • 0

    posted a message on runmacro?
    Just a simple question, what should I do if I want to make a button run a macro after I click on it? Seeing as RunMacro() doesn't work are there any other commands I can use?
    Posted in: Lua Code Discussion
  • To post a comment, please or register a new account.