• 0

    posted a message on Grid2 - What it is, and what it's not
    I'll see if I can't test a few, but r332 and to lesser degree r334 seem like good candidates for causes. It'll take a while, but I'll probably roll back to r331 and start from there. Perhaps the person who said it started with r337 just happened to be on an older release than they thought.
    Posted in: Grid & Grid2
  • 0

    posted a message on Grid2 - What it is, and what it's not
    Having a weird issue that I know is related to Grid2 but I don't think it's necessarily it's fault, just perhaps an addon conflict. Sometimes when you or one of your party mates zones/drops out of the instance (we've only noticed it on randoms via LFD) WoW will completely lock up. It's possible to use Task Manager to kill the process and log back in, but something at that moment is totally hanging the game client.

    For reference, I'm the author of ArkiveUI, and if you know my comp you know it has a lot of addons. Couple that with the fact that it doesn't happen every time and so far only at the end of randoms it's becoming very hard to troubleshoot. Only conflict I could think of might be Pitbull, which I use for non-raid unit frames. At any rate, if you know of anything I should check, or can think of a scenario where something like that could happen I'd love to hear about it.

    A few final notes. It's never happened when someone has dropped/left/booted during the instance...only at the very end. Also, multiple users have confirmed the problem vanishes when Grid2 is removed. And finally, the Grid2 plug-ins I'm using are AFK, Aura, Group, and Res (all latest builds via Wowace).
    Posted in: Grid & Grid2
  • 0

    posted a message on PitBull 4.0
    Quote from Shefki
    What you were asking for before was removing the player from raid frames. Which we can't do without breaking the secure templates.


    Yea, I wasn't aware this condition existed based on my previous use of PB3.


    Quote from Shefki
    I've made a great deal of effort in PB4 to allow everything to work properly with in combat changes.


    I agree completely. That was my biggest gripe with PB3. I much prefer errorless Pitbull v/s having to redo one layout.
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    Quote from Kerecha
    Then use ur "party" layout on 5man raid and it will look like a normal partyframe (you will however always see yourself there, no getting around that as the addon and unitID's and stuff works atm)


    Yea, and therein lies my issue since my party/partytarget/partypet frames are configured in a 2x2 block to the right of my player frame. I'd have to redo it completely or create a seperate group/layout for 5's. If I had them stacked with space above/below the issue would be nil. Ah well...thanks anyway.
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    When you enter an arena now, it is converted into a raid and considered a BG (seeing as /bg works for comm).

    *Edit* This applies to any arena bracket, not just 5's.
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    As much as I want to fight more, I believe you have pounded the truth into my skull :P I'll have to figure something out. The only time this is an issue is in 5's arenas...every other time it doesn't matter as you'll either have less ppl (2's and 3's) or 10 more ppl. So I guess I'll have to figure out if I want to make a seperate group and layout just for 5's arenas :P Thanks for the posts guys.
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    Quote from jokeyrhyme
    Kerecha is spot on. There's no way to configure PitBull or any other unitframe addon do behave the way you want it to. If you are in any sort of raid, you will be displayed. That checkbox you mention is specifically for Parties, and it has absolutely zero effect when you are technically in a Raid.


    You say that, but that is exactly how Pitbull3 operated. When there were four or less raid members it kept showing party frames, and once the 6th member joined, it switched to raid frames.
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    Quote from stoobs
    so you have a set of party frames (which happens to include you) and a set of 5man raid frames when you're in a 5man raid?



    Wouldn't party frames be the natural way for arena? You join a party and queue as a group correct?

    I'm confuzzled as to what you're tryin to do ultimately...


    No, I have a set of party frames that I want to use when I'm in a party or when I'm in a raid with four (or less) other people. When we queue for an arena we are in a group and all looks fine, but once we enter the arena it is automatically changed into a raid.

    Quote from Kerecha »
    meaning while in raid, PB can't tell what char is you and thus can't hide it and while in 5man grp the playerID is simply just added to the grp ID's by pitbull when "include yourself" is checked.


    As a I stated, I do not have this checked and thus it should not be added to the index of ID's.
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    Having an issue filtering. I've set the party frames to show while in 5-man party or 5-man raid (so I can use party frames instead of raid frames during arenas). When in a party all works as intended, but when I convert to a raid with five or less (including myself) it adds myself to the party frames. And yes, I made sure to uncheck the group option to include player in the index.
    Posted in: Unit Frames
  • 0

    posted a message on Postal (was GMail2): Updated
    In the blackbook.lua, commenting out lines 41 and 151-153 did the trick for me, and still allowed the use of the Blizzard autofill. Thanks for the pointer in the right direction.
    Posted in: General AddOns
  • 0

    posted a message on PitBull 4.0
    Is it possible to limit the number of tanks listed? I have a frame just for them and want to limit it to 5, but sometimes leaders go crazy and put a bunch of players-of-interest up there.

    Also, it would cool if there was a "default" layout, where you could define options, like typeface, etc...and then have a "Use defaults" checkbox on other layouts under each major subsection (like text, auras, etc), so in the event you want to change something globally (or revert to defaults), it would be easy to do so.

    As a note, I finally converted my UI (ArkiveUI) to Pitbull4 in my working build, and man, despite being a lot of work, I am so glad I did. 1000% better in it's configuration and customizability then v3. And, it's working perfectly on the PTR. Kudos.
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    If I use another addon that uses DogTags, will that effect the performance of Pitbull, or only if DogTags is enabled within Pibull itself?
    Posted in: Unit Frames
  • 0

    posted a message on PitBull3: Curses not showing
    I suspected that and insured I was logging in with resto spec before raiding once or twice, and also did a reloadui during the raid with no luck.
    Posted in: AddOn HELP!
  • 0

    posted a message on PitBull 4.0
    I see that Pitbull4 is still in alpha, but it looks quite promising. I have a fairly involved UI I maintain that relies heavily upoon Pitbull3. Is Pitbull4 ready for primetime, or should I hold off for a bit more before trying to integrate it into a published UI? Thanks.
    Posted in: Unit Frames
  • 0

    posted a message on PitBull3: Curses not showing
    The secondary spec on my shaman is resto, and for some reason when I'm in a raid the unit frames will not highlight when they need decursing. The really weird thing is it doesn't always behave that way, just some of the time and I've been unable to figure out why. Poisons and diseases highlight perfectly fine, but just not curses.

    Is there a chance the logic used to determine if a frame should highlight for decusring might be limited to the primary spec instead of the active spec? Pretty sure no major developemnt has gone into Pitbull3 since the time dual-spec came out, but I'd hate to retalent and reglyph everything if that's definitely not the culprit. Thanks :)
    Posted in: AddOn HELP!
  • To post a comment, please or register a new account.