• 0

    posted a message on ElkBuffBars - timer on other classes debuffs?
    Well yes actually there is. In EBB, you can filter out timeless buffs/debuffs. Since you can only get times for your own debuffs, that will remove everyone else's debuffs and only show yours. This works perfectly here.
    Posted in: AddOn HELP!
  • 0

    posted a message on Gem Addon for Item Preview
    It looks like you use RatingBuster. It can already do that for you I believe. I don't know how flexible it is, because I don't use that feature, but it's there.
    Posted in: Addon Ideas
  • 0

    posted a message on has died
    Quote from HunterZ »

    Ooh nice, I've been looking for something like that. Did Blizzard fix the missing death events from the combat log though?

    Yes, it's fixed.
    Posted in: Addon Ideas
  • 0

    posted a message on Xperl Range Finder up and died last patch
    The out of range setting for the Target frame is different from the party/raid setting. Look in the target tab in the options (sidenote, it doesn't work very well for target. Its only option is 30 yards, IIRC, and I often see the hand - out of range indicator - yet I am prefectly able to cast a 30-yard-max spell).

    I don't believe the out of range feature exists for the Focus frame.

    For party, umm... I used it last night but I can't recall if it worked or not. I know it works for raid frames for sure. I have the party turned off when in a raid when I am DPS'ing and I tend to look at raid frames when healing, rather than party, so yeah... lack of attention on my part last night.

    Not home so can't check any of that right now, this is just from memory.
    Posted in: Unit Frames
  • 0

    posted a message on Xperl rangefinder
    I think that's already in there for target. I am at work, so can't look right now. Actually I'm almost certain it's there.

    For focus, I can't remember. Unless it follows the rules for friendly and enemy targets depending on type which you have focused.
    Posted in: Addon Ideas
  • 0

    posted a message on X-Perl bug (and the fix hopefully)
    Hey all,

    I found a bug in X-Perl. I e-mailed Zeksie about it 3 weeks ago, but he must be busy with other stuff. So I decided to dig in and try to fix it myself.

    So, the bug... I have X-Perl set to keep the party frame up if I'm in a raid with only one group, such as arenas. I also have it set to show a separate raid group for pets when in a raid. Unfortunately, when playing an arena game with a hunter (with his pet out), I found that the raid interface would correctly stay hidden, but the extra group for pets would still show up.

    From what I found, the setting to hide the raid interface if there's only one group in the raid is not taken into account when displaying the extra pet group. So I modified a couple of functions in XPerl_RaidPets\XPerl_RaidPets.lua by simply copying what Zeksie did for the rest of the raid interface.

    I modified
    -- XPerl_RaidPets_HideShow
    function XPerl_RaidPets_HideShow()
    
    	local on = (GetNumRaidMembers() > 0 and rconf.enable)
    
    	local events = {"UNIT_HEALTH", "UNIT_MAXHEALTH", "UNIT_NAME_UPDATE", "UNIT_AURA"}
    	for i,event in pairs(events) do
    		if (on) then
    			XPerl_RaidPets_Frame:RegisterEvent(event)
    		else
    			XPerl_RaidPets_Frame:UnregisterEvent(event)
    		end
    	end
    
    	if (rconf.enable and GetNumRaidMembers() > 0) then
    		XPerl_RaidPets_Frame:Show()
    		XPerl_Raid_TitlePets:Show()
    		XPerl_Raid_GrpPets:Show()
    	else
    		XPerl_RaidPets_Frame:Hide()
    		XPerl_Raid_TitlePets:Hide()
    		XPerl_Raid_GrpPets:Hide()
    	end
    end


    with
    -- XPerl_RaidPets_HideShow
    function XPerl_RaidPets_HideShow()
    
    	local singleGroup
    	if (XPerl_Party_SingleGroup) then
    		if (conf.party.smallRaid) then
    			singleGroup = XPerl_Party_SingleGroup()
    		end
    	end
    
    	local on = (GetNumRaidMembers() > 0 and rconf.enable)
    
    	local events = {"UNIT_HEALTH", "UNIT_MAXHEALTH", "UNIT_NAME_UPDATE", "UNIT_AURA"}
    	for i,event in pairs(events) do
    		if (on) then
    			XPerl_RaidPets_Frame:RegisterEvent(event)
    		else
    			XPerl_RaidPets_Frame:UnregisterEvent(event)
    		end
    	end
    
    	if (rconf.enable and GetNumRaidMembers() > 0 and not singleGroup) then
    		XPerl_RaidPets_Frame:Show()
    		XPerl_Raid_TitlePets:Show()
    		XPerl_Raid_GrpPets:Show()
    	else
    		XPerl_RaidPets_Frame:Hide()
    		XPerl_Raid_TitlePets:Hide()
    		XPerl_Raid_GrpPets:Hide()
    	end
    end


    I also modified
    -- XPerl_RaidPets_Titles
    function XPerl_RaidPets_Titles()
    	if (rconf.hunter) then
    		if (rconf.warlock) then
    			XPerl_Raid_TitlePets.text:SetText(XPERL_LOC_CLASS_PETS)
    		else
    			XPerl_Raid_TitlePets.text:SetText(XPERL_LOC_CLASS_PETSHUNTER)
    		end
    	elseif (rconf.warlock) then
    		XPerl_Raid_TitlePets.text:SetText(XPERL_LOC_CLASS_PETSWARLOCK)
    	end
    
    	local show
    	for i = 1,GetNumRaidMembers() do
    		local unitName, rank, group, level, _, unitClass = GetRaidRosterInfo(i)
    		if (unitClass == "HUNTER" or unitClass == "WARLOCK") then
    			show = true
    			break
    		end
    	end
    
    	if (XPerlLocked == 0 or (rconf.enable and show and conf.raid.titles)) then
    		XPerl_Raid_TitlePets.text:Show()
    	else
    		XPerl_Raid_TitlePets.text:Hide()
    	end
    
    	XPerl_ProtectedCall(XPerl_RaidPets_HideShow)
    end


    with
    -- XPerl_RaidPets_Titles
    function XPerl_RaidPets_Titles()
    
    	local singleGroup
    	if (XPerl_Party_SingleGroup) then
    		if (conf.party.smallRaid) then
    			singleGroup = XPerl_Party_SingleGroup()
    		end
    	end
    
    	if (rconf.hunter) then
    		if (rconf.warlock) then
    			XPerl_Raid_TitlePets.text:SetText(XPERL_LOC_CLASS_PETS)
    		else
    			XPerl_Raid_TitlePets.text:SetText(XPERL_LOC_CLASS_PETSHUNTER)
    		end
    	elseif (rconf.warlock) then
    		XPerl_Raid_TitlePets.text:SetText(XPERL_LOC_CLASS_PETSWARLOCK)
    	end
    
    	local show
    	for i = 1,GetNumRaidMembers() do
    		local unitName, rank, group, level, _, unitClass = GetRaidRosterInfo(i)
    		if (unitClass == "HUNTER" or unitClass == "WARLOCK") then
    			show = true
    			break
    		end
    	end
    
    	if (XPerlLocked == 0 or (rconf.enable and show and conf.raid.titles and not singleGroup)) then
    		XPerl_Raid_TitlePets.text:Show()
    	else
    		XPerl_Raid_TitlePets.text:Hide()
    	end
    
    	XPerl_ProtectedCall(XPerl_RaidPets_HideShow)
    end


    I grouped with a hunter who had his pet out, converted to raid and the pet group stayed hidden. I moved him to group 2, the raid interface appeared, with the extra pet group. I moved him back to group 1, the raid interface disappeared, including the extra pet group.

    So as far as I can tell, it works. However, I haven't programmed anything in years, let alone anything to do with WoW/Lua. So I would very much appreciate it if someone more knowledgeable than I am could quickly check all that to make sure I didn't break anything.

    Thanks in advance.
    Posted in: Unit Frames
  • 0

    posted a message on Omen - taunting an "immuned to taunt" boss
    What they need to do is inform who the tank is for a given mob. Not who's highest on threat, since DPS'ers can be above 100% threat, yet below 110%/130%.

    As to their plans for a threat meter, they're now leaning towards making info more easily available to external threat meters, as opposed to making their own. This blue post shows it:
    http://forums.worldofwarcraft.com/thread.html?topicId=5640666467&sid=1&pageNo=5#90

    I could have sworn I read another blue post saying the same, but I can't find it right now. Or it never existed and I'm losing my mind...
    Posted in: Raid AddOns
  • 0

    posted a message on LittleWigs
    Quote from ulic »

    Looking at the code, I think we should have the warnings working for heroic, but maybe not for normal. If you aren't getting the warning properly for Heroics please try to get me a combat or transcriptor log for the encounter and I'll double check the spellids.


    Sorry for the late reply. I'll try to get one. Been really short on time as of late. I can confirm that I was getting no warnings at all in heroic though. Neither was someone else running LittleWigs in the group.

    Thanks for your work.
    Posted in: Raid AddOns
  • 0

    posted a message on LittleWigs
    Is LittleWigs working for anyone else on the first boss in Arcatraz ? It doesn't for me. Heroic mode, if that helps. I don't venture there in non-heroic anymore.
    Posted in: Raid AddOns
  • 0

    posted a message on Prat 2.0 Chat Mod Framework (Official Thread)
    Quote from Arrowmaster »

    I committed a possible fix earlier today.


    Thank you. I am at work right now and can't test it. But I will as soon as I get home.


    EDIT: That did the trick. Thank you.
    Posted in: General AddOns
  • 0

    posted a message on Prat 2.0 Chat Mod Framework (Official Thread)
    Quote from Darkclaw »

    Eric2203, I was under the impression that Prat didn't touch the combat log any more... did you somehow change the sort direction with a setting? (is that even possible?)



    That's the first thing I looked for. I can't see any option in Blizzard's Combat Log Settings to change that (why would you anyway ?), and I can't find anything even remotely related to that in Prat.

    As to Prat doing anything to the combat log, as an example, I know for sure that it would timestamp it (if enabled) pre-2.4.2. Now, on or off doesn't seem to do anything. Only the Blizzard timestamp can be added/removed. Not that this is an issue, just an example.

    So nobody's experiencing that ? I might have to delete my SavedVariables and try again.
    Posted in: General AddOns
  • 0

    posted a message on Prat 2.0 Chat Mod Framework (Official Thread)
    Hello,

    Having a weird issue. I just updated Prat to r73742 today (usual round of updates after a patch) and I am having issues with the combat log. If I happen to click on a Filter (like "Self", " Everything", "What happened to me?"), it reloads the log but the events end up sorted backwards. In other words, the oldest event is at the end, the newest is the first in the list. I can't narrow it down to a specific Prat module. It seems I have to disable Prat completely for this behaviour to go away.

    If it helps, I have the Combat log in its own chat window. I have the timestamp module turned on, but NOT for this chat frame. For the combat log, I use the default Blizzard one. Incidentally, turning timestamp on or off in Prat for that particular frame doesn't do anything. As if Blizzard had disabled changing the Combat log chatframe. No clue if that's related, just giving as much info as I can.

    It's a bit annoying since I use the various filters in the Combat log. I imagine it would be worse for someone creating their own filters with the Combat Log interface.

    By the way, after that, incoming events get added to the Combat Log at the end, like they should be. It's only upon switching filters that it happens.

    Has anyone observed this ? Any idea/help ? Thanks.
    Posted in: General AddOns
  • 0

    posted a message on LittleWigs
    Hi,

    Just wanted to report a quick bug. The first boss in Arcatraz (Zereketh the Unbound) puts Seed Of Corruption on players. This is correctly reported by LittleWigs, except when it's on me (I'm the one running the add-on). Sorry I don't have a transcript to give.


    Eric
    Posted in: Raid AddOns
  • To post a comment, please or register a new account.