• 0

    posted a message on Ace2 - Ace3 - Rock
    Not that this will be worth much, as it appears... but running the upgrader and having no clue that this whole split thing was going on has, in fact, broken several of my Ace mods... or, at the very least, seriously hampered their usability.

    Included in this list are ArcHUD2 and Cartographer_Herbalism/Mining/Fishing. Rolling anything back at this point seems like it's going to be an arduous process. As, even within the major mods that switched, not every piece seems to have made the change over.

    I also haven't seen much of an "official" word from either of the main coders for the projects explaining what is going on or what the end goal is. This just sucks as an end user, but I suppose there's little complaining to do as most of us haven't paid dime one to use these products.

    I just wish their was a better way for this to have happened and, I'm honestly still a bit confused as to why any of the Rock projects still remain on the WowAce site. It would seem to make more sense to simply move that project off into its own world as to avoid the current state of things. The Ace2 version of the mods would simply have remained in the last state they were and anyone who want to move to the new environment afforded could have done so seperately.

    Just my $.02.

    PS - The current setup window for Rock addons isn't very becoming or easy to use, IMO.

    Posted in: General Chat
  • 0

    posted a message on MacAceUpdater - an update tool for Mac users.
    Not sure what's going on with my MacAceUpdater.

    Yesterday it worked fine but seemed to have a crash after it updated my out-of-date stuff.

    This morning I open it up and it shows me the addon list, but the version number are all replaced with creator information from the server.

    Now, tonight, I light of the program and the list is completely empty. Checked my preferences and those are all good. Deleted and reinstalled the program, checked my preferences, and still nothing in the list!

    What's going on?

    Posted in: Updaters
  • 0

    posted a message on CastYeller - announces to your party/raid important spells you cast.
    It works just fine now, Adirelle.

    Thanks!
    Posted in: General AddOns
  • 0

    posted a message on CastYeller - announces to your party/raid important spells you cast.
    Quote from Adirelle »

    @HouseWyth: yes and no. It seems it the same kind of trouble.

    Hmm... Could you both tell me which revision is working right now ?


    Okay...

    First, while similar on the surface, my issue does not appear to be the same as Gahlok.

    Second, as I mentioned in a previous post, there is an oddity to how your Mod downloads and extracts (whether through a downloader like MacAceUpdater or by actually pulling the file from the SVN). In either case when it extracts the structure is: Castyeller --> libs\xxx --> xxx.lua.

    To be very clear, when I extract your Mod (from any source) I end up with a folder titled "CastYeller". Inside that folder are 12 files, another folder titled "announces", and 12 more folders titled "libs\xxx" (where xxx is any of the library names).

    I went through all of my other Ace2 mods to compare libraries and it turns out, yours is the only one I use that has "Parser-3.0" in it. Omen appears to use the same library .lua file, but stores it under "ParserLib-3.0". Now, I'm not familiar with the file mechanics of the Ace system, but it struck me as kind of strange that that was the one library string that was causing a problem.

    So, I went into the CastYeller folder and created my own folder titled "Libs". Into that folder I placed all of the 12 library folders, "libs\xxx". I then renamed all of those folders; I deleted the "libs\" portion of the title.

    Presto change-o... it's magic... Castyeller no longer throws up an error and appears to work just fine!

    Ciao!

    Posted in: General AddOns
  • 0

    posted a message on CastYeller - announces to your party/raid important spells you cast.
    Did my problem get lost in the mix here somewhere?

    Posted in: General AddOns
  • 0

    posted a message on CastYeller - announces to your party/raid important spells you cast.
    Quote from Adirelle »

    I tried to fix the case of the embeds.xml file (responsible for loading libraries). I doesn't make any difference with Windows, but maybe does it with other OSes. Which OS are you running ? BTW, are you installing embedded or not-ext version of CY ? (First is the direct link from files.wowace.com, second is generally used by updaters.)


    As the other user, I am also running Mac OS X. I use MacAceUpdater, pointed at files.wowace.com to get my CastYeller download and it auto installs it in the AddOns directory. I have also tried grabbing the files directly myself and placing them in the folder on my own, the result is no different.

    The only funky thing I notice is that, regardless of how I get the mod, everything is only one folder deep. In every other Ace mod I have there is a "Libs" folder in which are other folders like "Parser-3.0" in which is the .lua file. In CastYeller, the root level has folders named "libs\XXX" (where XXX can be substituted by any Ace Library name, like "Parser-3.0" or "SpellEvents-1.0") under which is the .lua file.

    Ciao!

    Posted in: General AddOns
  • 0

    posted a message on CastYeller - announces to your party/raid important spells you cast.
    Quote from Gahlok »

    I've had to be sticking to an old version (r45801) because all the newest ones, whenever I log in an error shows up saying something like SpellLib (or a library called something like that) wasn't present.

    If it's needed I can take a screenshot of the error.


    I've got the same issue. The error is "Interface\AddOns\CastYeller\CastYeller.lua:5: AceAddon: AceOO-2.0: Library "Parser-3.0" does not exist." I checked the files, it shows that the path is there and the file, but it isn't found for the mod.

    I tried downloading it anew and reinstalling but the error still remains. I also tried running only CastYeller and it still says the same thing.

    Ciao!

    PS - I guess this isn't quite the same problem, as it appears the OP has a problem with a different file.

    [EDITED to add the exact error message]

    Posted in: General AddOns
  • 0

    posted a message on ArcHUD 2.2 (2007-06-11)
    Quote from Cilderen »

    Quote from HouseWyrth »

    Quote from Lewzephyr »

    I havent changed my settings in ArcHUD in some time..... but today I wanted to adjust a few pieces arround.

    Every time I unlock the target frame, and put it in the new position, relock the frame. If I adjust anything such as vertical or horrizontal, it pops the target frame to the center of the screen.
    If I move it back, lock it, it will stay there, untill I log out and back in, and bam it is in the middle of my screen.

    I blew away my saved var for ArcHUD, and the exact same thing continues to occur.
    If I restore my Saved Var.... adjust everything as to how I want it (except the target frame). Log out and manualy edit my x y for the target frame, all comes out fine and dandy. But the moment I change anything, POW its back to the center of the screen.

    No errors occur.


    I am having the identical problem. Every time I log out of game and come back in I have to move the target and target-of-target frames anew.

    Any info?




    I was having the same problem but I was able to fix it. Create a new profile, I changed my from Default to Default1 and then reload your interface or logout and back in. This will put all your settings back to the defaults, but after setting them all back to where I wanted my target frame stayed where I put it for all characters.

    Cilderen.


    Thanks, but that's one of the first things I did. Still doesn't fix it. And, I've also tried a clean reinstall of every mod I use as well as the game (although not solely for this issue). It also continues even if ArcHUD is the only mod loaded.

    Ciao!

    Posted in: General AddOns
  • 0

    posted a message on IceHUD
    I saw some discussion of it early on in this thread, but was there ever any option added or module to allow text offsets for the bar?

    I like everything about the HUD except that the text on the bars overlaps if you have it set to show player info n the left and target info on the right.

    Ciao!
    Posted in: Unit Frames
  • 0

    posted a message on ArcHUD 2.2 (2007-06-11)
    Quote from Lewzephyr »

    I havent changed my settings in ArcHUD in some time..... but today I wanted to adjust a few pieces arround.

    Every time I unlock the target frame, and put it in the new position, relock the frame. If I adjust anything such as vertical or horrizontal, it pops the target frame to the center of the screen.
    If I move it back, lock it, it will stay there, untill I log out and back in, and bam it is in the middle of my screen.

    I blew away my saved var for ArcHUD, and the exact same thing continues to occur.
    If I restore my Saved Var.... adjust everything as to how I want it (except the target frame). Log out and manualy edit my x y for the target frame, all comes out fine and dandy. But the moment I change anything, POW its back to the center of the screen.

    No errors occur.


    I am having the identical problem. Every time I log out of game and come back in I have to move the target and target-of-target frames anew.

    Any info?

    Posted in: General AddOns
  • To post a comment, please or register a new account.