• 0

    posted a message on Icon chooser/browser Library?
    Quote from Phanx
    Also, wrong forum. This forum is for threads about libraries that exist, not for threads asking if a library exists.


    Whatever man, it's now extremely obvious to me that ACE/Curse has gone beyond unfriendly...
    Posted in: Addon Ideas
  • 0

    posted a message on Icon chooser/browser Library?
    1
    Posted in: Addon Ideas
  • 0

    posted a message on Tortoise SVN checking help
    Hi,

    I'm using Tortoise SVN to upload my addon.

    The addon commits just fine, but I don't know how to tag it so that it shows the version number that I want to use, and shows which version of the WoW client it is for.

    Can anyone help?

    I was previously using:

    Properties:
    tsvn:logtemplate

    Value:
    {addonname}: -

    I tried using this, and specifying: "v30200 release" but it's still showing an auto populated version number, shows it as alpha, and doesn't show the correct WoW client version.

    I gotta say, this "re-architecture" sure seems very unfriendly to your average addon developer. Just seems like Curse is saying they don't want this type of developer any longer, because this is a lot of hurdles to jump through just to publish an addon.:(
    Posted in: Need Help?
  • 0

    posted a message on Bartender4 - Official Topic
    Quote from Deiga »

    Is it possible that you either add the feature "Auto self-cast" or make it so thta bt4 doesn't override the option from Interface-menu.


    Is there any answer on this one? Auto-Self cast isn't working for me. I love BT4, but without auto-self cast I'm not able to use it.

    Thanks!!!
    -ZacWolf
    Posted in: General AddOns
  • 0

    posted a message on AEmotes, no sound
    Quote from ZacWolf »
    I'll update when I know more.


    AEmotes Update:
    http://www.wowace.com/forums/index.php?topic=8946.0
    Posted in: General AddOns
  • 0

    posted a message on AEmotes addon problem
    Quote from ZacWolf »
    I'll update when I know more.


    AEmotes status update:
    http://www.wowace.com/forums/index.php?topic=8946.0
    Posted in: General AddOns
  • 0

    posted a message on Avion - Event driven visual effects (former PowerAura2)
    Quote from lapalapa »
    same issue reported to AEmotes


    Update regarding AEmotes:
    http://www.wowace.com/forums/index.php?topic=8946.0
    Posted in: General AddOns
  • 0

    posted a message on AEmotes
    Hello all.

    After working through the Blizzard forums, I found a workaround that will allow AEmotes to play the sound clips again.

    I'm waiting on the ACE folks to reset my SVN password so that I can upload the patched version.

    The workaround requires playing a "system sound" to initialize the sound layer before you can play a custom sound file; so you might hear the lil "minimap zoom" click in the background while the AEmote sound clip is playing. You really have to be listening for it, to hear it in the background. Not my favorite solution, but it works until they patch the core sound engine.

    Seems that VoiceChat was pretty much thrust upon 2.2, as a complete sound engine rewrite was being planned for 3.0 (which would have included Voice Chat). As a result, VoiceChat is really more of a 2.2 "hack" that causes sound priority issues.

    I'll edit this post when I've uploaded the patch.
    -ZacWolf
    Posted in: General AddOns
  • 0

    posted a message on AEmotes
    Quote from andune »
    the first being allowing the user a preference to let it work across tells.


    Hey sorry, I didn't see this post.

    Did you make this change? I don't see it in the latest version...

    Just so you know, I thought about making it work across tells, but that would be open to some pretty bad abuse if someone knew you had the addon, as they could pretty much make the sounds trigger anywhere you on in the "world" (especially bad if you're in instances, etc.).

    Posted in: General AddOns
  • 0

    posted a message on AEmotes addon problem
    This is related to the 2.2 patch.

    They made some major changes to the Sound engine and it seems they bugged the PlaySoundFile command that AEmotes uses.

    I've opened a post on the WoW forums so hopefully a Bliz person will see it.

    It's possible that the problem could fix itself when the individual servers enable VoiceChat {fingers crossed}. If not, we may have to wait on a patch.

    I'll update when I know more.
    Posted in: General AddOns
  • 0

    posted a message on AEmotes, no sound
    I'm investigating it.

    There seems to be a problem with the PlaySoundFile command in 2.2 that AEmotes uses.

    I've logged this issue on the WoW forums, so hopefully a Blizzard developer will see the problem.

    They made some pretty major issues with the sound engine to support VoiceChat, so it's probably related. It could be fixed when the individual servers enable VoiceChat {fingers crossed}. If not we may have to wait for the next Blizzard patch...

    I'll update when I know more.
    Posted in: General AddOns
  • 0

    posted a message on AEmotes
    Quote from fred »

    Is it possible to make categories? Sub menu's? That way not as much it being shown...then maybe it will be accessible.ATM I can't listen to them all because it drags sooooo much.


    Hey sorry for taking so long, I don't check the forums often. I'll take a look at it, and see what I can do to make it easier to navigate when you have a lot loaded up.

    -ZacWolf
    Posted in: General AddOns
  • 0

    posted a message on ClearFont and ClearFont2 - Official thread
    Quote from tripdream »

    For about a week now I have been having issues with ClearFont2. When I log into World of Warcraft, I see the world display but then WoW crashes with the following error:

    This application has encountered a critical error:

    ERROR #132 (0x85100084) Fatal Exception
    Program: C:\Program Files\World of Warcraft\WoW.exe
    Exception: 0xC0000005 (ACCESS_VIOLATION) at 001B:006C55B9

    The instruction at "0x006C55B9" referenced memory at "0x2BB09D84".
    The memory could not be "written".


    WoWBuild: 6803


    First I attempted to isolate what could have caused the crash, so I went through my addons one by one, enabling one and disabling others. I determined that even after disabling all addons and enabling just ClearFont2, that WoW crashes with the same error. I have nuked all addons and reinstalled them, nuked the WTF folder, and did a full repair check on WoW. In fact, I have done just about everything short of reinstalling WoW itself to see if I can get any other result.

    Does anyone else have this same issue or can give me some way to isolate or fix the issue? I've done everything else that I can think of but it doesn't seem to have an effect. Thanks!


    *bump*

    Seeing the exact same error. Tracked it down to ClearFont2. I uncheck this addon from the list, and WoW loads fine. I select ClearFont2 and I get this error.

    I tried updating to the latest version of ClearFont2, still the same error.
    Posted in: General AddOns
  • 0

    posted a message on Flirty
    Quote from Doggabone »

    AEmotes (http://www.wowace.com/wiki/AEmotes) has it's fans, and if you haven't tried it yet Thortok you might like it. It doesn't do anything like what you asked for, but it's under the same genre of "pointless but fun".


    "pointless but fun". Don't exactly know how to take that. I thought the whole point of WoW was to have fun?!?! Also, remember that when comparing a world population of 7billion to a subscriber base of 6million, it means that there is a whole segment of the population that thinks WoW is pretty pointless itself.

    As the writer of AEmotes I guess I'll try not to take offense since I didn't read that as your intent; but with that said I also have to say to try not to take any of this stuff TOO seriously, eh...

    Now, regarding "has it's fans": Who!?!?! ha ha ha, besides my guild I've only heard from two other people, and they ended up creating their own Soundbite sets.

    -ZacWolf
    Posted in: Addon Ideas
  • 0

    posted a message on CooldownCount problem with Mind Control
    This sound very similar to the same type of errors I'm seeing with CooldownCount and Druid Forms. I'm assuming that the Forms button were made "secure" so CooldownCount calling show() and hide() on them is triggering errors that identify as Ace2 errors.

    Is anyone supporting CooldownCount any longer?

    -ZacWolf
    Posted in: General AddOns
  • To post a comment, please or register a new account.