• 0

    posted a message on Grid + Mana Bars
    Tested logging in when in group and the non-mana bars are hidden properly.
    Posted in: Grid & Grid2
  • 0

    posted a message on Grid + Mana Bars
    What I did was
    function GridMBStatus:UpdateUnitPowerType(name)
      --DEFAULT_CHAT_FRAME:AddMessage("MB:UpdateUnitPowerType("..name..")")
        
      local ignoreUnit = false
      
      --DEFAULT_CHAT_FRAME:AddMessage("Checking GridMBStatus.db.profile.hidepetbars: ")
      if petbars and GridMBStatus.db.profile.hidepetbars and (not UnitIsPlayer(name)) then
       ignoreUnit = true
    		elseif GridMBStatus.db.profile.hiderage then
    			local powerType = UnitPowerType(name)
      	DEFAULT_CHAT_FRAME:AddMessage("Got power type:("..powerType..")")
      	DEFAULT_CHAT_FRAME:AddMessage("Name:("..playerName..")")
    			if powerType == 1 or powerType == 3 then


    and got

    <MI2> MobInfo v3.60 Loaded, enter /mi2 or /mobinfo for interface
    Got power type:(0)
    Name:(Panzerhoof)
    Got power type:(0)
    Name:(Panzerhoof)
    Welcome to the European World of Warcraft realms!
    Got power type:(0)
    Name:(Panzerhoof)
    Got power type:(0)
    Name:(Panzerhoof)


    I'll post the result of logging on while in a grp asap.
    Posted in: Grid & Grid2
  • 0

    posted a message on Grid + Mana Bars
    I tested the behavior by using DEFAULT_CHAT_FRAME:AddMessage to output the returned value to the chat frame. :)

    Updated to UpdateAllUnits() to:
    function GridMBStatus:UpdateAllUnits()
      --DEFAULT_CHAT_FRAME:AddMessage("MB:UpdateAllUnits()")
      for u in RL:IterateRoster() do
        self:UpdateUnitPowerType(u.name)
      end
    		self:UpdateUnitPowerType(playerName)
    end

    and still got the same issue. Are you telling me I'm alone in this? I will try to test this further by being in a group at logon.
    Posted in: Grid & Grid2
  • 0

    posted a message on Grid + Mana Bars
    Quote from Julith »

    Hmm, I couldn't reproduce it.
    Could you tell me your settings of the "Mana" status as well as the settings for "ManaBar" (under "frames->advanced->manabar") and the status checked for the ManaBar frame?
    And a list of other Grid addons you are using whould probably be helpful.


    - Ignore Non-Mana checked
    - Ignore Pets checked
    - Enabled checked
    - Priority set to 30

    - show on top side
    - size 20

    - status checked: "mana"

    Grid addons I use:
    -GridManaBars
    -GridSideIndicators
    -GridLayoutPlus

    Seems like the call to UnitPowerType(name) at line 188 in GridStatusMana.lua returns 0 (mana) when called for the first time (by PLAYER_ENTERING_WORLD event being fired). Subsequent calls (by checking/unchecking the ignore non-mana checkbox or doing reloadui) seem to correctly return 1 for rage and 3 for energy?
    Posted in: Grid & Grid2
  • 0

    posted a message on Grid + Mana Bars
    "Hide non-mana" seems not to work when the addon first loads - it shows mana for my warrior when I log in (it's even blue). I have to uncheck the "Hide non-mana" checkbox and then check it again. Then it works perfectly until I log off.
    Posted in: Grid & Grid2
  • 0

    posted a message on BigWigs
    Is it possible to somehow make BigWigs info show above all other UI elements (unit frames, scrolling combat text etc)? It's the most important info on screen and really should not be missed...
    Posted in: Raid AddOns
  • 0

    posted a message on Changing frame strata?
    Is it possible to somehow change a random frame's strata setting? The reason for doing this for me is that I need my BigWigs bars to be on top of everything, especially the SCT spam.
    Posted in: AddOn HELP!
  • 0

    posted a message on SCT 6.0 / SCTD 3.0
    Is it possible to add a filter to sct_event_config.lua to show damage done by Vampiric Touch but hide the mana gain from that same spell? It gets very spammy.
    Posted in: General AddOns
  • 0

    posted a message on Parrot 1.0
    And how about the triggers? Are they broken?
    Posted in: General AddOns
  • 0

    posted a message on Parrot 1.0
    Could you update this for event triggers as well? Right now i have "Outgoing dodge" event show "Overpower!" and it doesn't work.
    Posted in: General AddOns
  • 0

    posted a message on CowTip 2.0
    Just updated CowTip and [TalentTree] still does not show anything when I mouseover any player. Is there a fix for this issue or do we just have to wait?
    Posted in: General AddOns
  • 0

    posted a message on GridLayoutPlus
    I get this on logon:

    Date: 2008-03-27 02:53:24
    ID: 55
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\GridLayoutPlus\GridLayoutPlus.lua line 589:
    attempt to call field 'RegisterCallback' (a nil value)
    Debug:
    ...\AddOns\AtlasLoot\Libs\AceAddon-2.0\AceAddon-2.0.lua:25:
    ...\AddOns\AtlasLoot\Libs\AceAddon-2.0\AceAddon-2.0.lua:23
    ...\AddOns\AtlasLoot\Libs\AceAddon-2.0\AceAddon-2.0.lua:998: ManualEnable()
    ...\AddOns\AtlasLoot\Libs\AceAddon-2.0\AceAddon-2.0.lua:926:
    ...\AddOns\AtlasLoot\Libs\AceAddon-2.0\AceAddon-2.0.lua:919
    [C]: ?
    ...\AddOns\AtlasLoot\Libs\AceEvent-2.0\AceEvent-2.0.lua:260: TriggerEvent()
    ...\AddOns\AtlasLoot\Libs\AceEvent-2.0\AceEvent-2.0.lua:910:
    ...\AddOns\AtlasLoot\Libs\AceEvent-2.0\AceEvent-2.0.lua:903
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 2.0
    Cast bar does not show the name of the spell being cast. I DONT use any custom tags for it. :)
    Posted in: Unit Frames
  • 0

    posted a message on Omen - Bug Reports and Suggestions
    Hello!
    Love the new Omen look and feel, just miss a few crucial features:
    • pull-out bars - usually you just need to compare your threat to the tank's, so I used to pull out the aggro-gain bar and look at it! Can you please put the pullout functionality there again?
    • custom bar colors - right now all the bars are colored after class which makes it quite hard to find yourself among them in a raid. I used to assign some bright color to MY bar so it was easy to see. No longer posible??
    Posted in: Raid AddOns
  • 0

    posted a message on BigWigs - Zul'Aman
    HAlazzi's Lightning Totem is not detected atm. Reason is that in Halazzi mod the trigger line is
    totem_trigger = "Halazzi begins to cast Lightning Totem.",
    while it should be
    totem_trigger = "Halazzi begins to cast Lightning Totem.",
    (no space).
    Posted in: Raid AddOns
  • To post a comment, please or register a new account.