• 0

    posted a message on Saved variabled loosing values on zoning
    Quote from Xinhuan
    PLAYER_LEAVING WORLD
    (loading screen)
    PLAYER_ENTERING_WORLD
    ZONE_CHANGED_NEW_AREA



    There is actually more than this, one thing I know is in there are a couple PLAYER_TALENT_UPDATE events. To fix some exploit involving keeping primary talents after doing a well timed talent group change close to zoning, Blizzard sets all your talents (and I think your skills too) to all unlearned briefly during the zone process. This actually bit me with my addon and I had to disable a few things related to this event.
    Posted in: Need Help?
  • 0

    posted a message on Saved variabled loosing values on zoning
    Quote from Phanx
    The ADDON_LOADED event is fired every time an addon is loaded. So, if a user is running AddonLoader, Grid, Quartz, SwapSpec, and TourGuide, the loading process will go something like this:

    ...



    Thanks for the detail on the loading process, while its not whats affecting me here, it clarifies some things I was a little unsure of and is sure to help my next project.

    To help me with this problem could you give me a similar flow of what happens during the zoning process?
    Posted in: Need Help?
  • 0

    posted a message on Saved variabled loosing values on zoning
    Quote from Xinhuan
    Did you check for arg1 == "youraddon" in your ADDON_LOADED event function?



    yes I did, as I mentioned in the edit earlier though the ADDON_LOADED event is not the problem here, it would set my hideSpam and showText variables to True, and only then if they were nil before. The problem I'm occasionally running into either sets the value of both of those to False or nil. I suspect the latter since the string variables are being set to either "" or nil.
    Posted in: Need Help?
  • 0

    posted a message on Saved variabled loosing values on zoning
    I'm not unregistering it, however the handler for it is checking to make sure SwapSpec generated the event before running its code.

    Is there am ADDON_LOADED event after zoning?

    edit: on second thought, it can't be related to my ADDON_LOADED handler since in it I've got 2 variables that are set to true if they are nil.

    I put in a slash command to dump the values of the variables and it just happened again and those 2 variables had a value of false
    Posted in: Need Help?
  • 0

    posted a message on Saved variabled loosing values on zoning
    I've been having an intermittent problem with my addon (SwapSpec) I just can't figure out, I've tried searching for someone else reporting the same problem but could not find any solutions.

    Whats happening is my saved variables seem to be loosing their values every once in a while when I zone. The result is as if I set the values to nil. I've seen it happen between continents and going into or out of an instance. It doesn't happen every time or with any other addons than mine. If I had to put a number to it I would say it happens about 1% or 2% of the time.

    The only time I've coded for the values to change are on the ADDON_LOADED event and when the user clicks OK on the options window (plugged into the blizzard options panel).

    What am I missing here, what exactly happens during zoning that could sometimes but not always do this?

    If you want to thumb through my code the addon name is SwapSpec
    Posted in: Need Help?
  • 0

    posted a message on getting started with FuBar
    I'm getting ready to write my first addon, and I want it to be a Fubar addon, but I can't find a FuBar dev kit. Can someone either point me to the dev kit, a tutorial, or a barebones example for FuBar? I'll even gladdly take someone pointing me to the obvious like to the dev tools I must've missed in my 2 day search.

    Thanks in advance
    Posted in: FuBar AddOns
  • 0

    posted a message on node to ring distance on minimap
    I've been trying to figure out how to change the distance that node icons change to rings on the minimap. Currently the change is happening at 100 yards, but I'd like to change it to 150 or 170 yards so that there is a time where the icon is a ring, but I'm not yet close enough to see the golden dot Blizzard puts on the map when I'm tracking.

    I can't find a place in the options to change this. Can someone please tell me either what I'm missing in the options, or where and in what .lua file this distance is set?
    Posted in: Map/Minimap AddOns
  • To post a comment, please or register a new account.