• 0

    posted a message on CompactRaidFrame's protected function call vs various addons
    Appreciate all your help.

    I think I just screwed something up really badly somewhere along the line! So I went ahead and scrapped everything to start over, ditching SUF along the way for safety.
    Posted in: AddOn HELP!
  • 0

    posted a message on CompactRaidFrame's protected function call vs various addons
    Hmm. This messing around with Shadowed Unit Frame's issues may or may not be related. My post 5.4 crashing seemed to have died down the past few days until I decided to mess with SUF's errors and whatnot. With these tweaks here, I went from having no crashes in about 3 days to 6 crashes in an hour.

    Oof.
    Posted in: AddOn HELP!
  • 0

    posted a message on CompactRaidFrame's protected function call vs various addons
    So tried this. I no longer seem to get taint issues, instead I get this new error. Given that my coding knowledge floats somewhere between -1 and negative infinity, I have no idea what this means!

    115x FrameXML\RaidFrame.lua:63: attempt to call global "RaidPullout_RenewFrames" (a nil value)
    FrameXML\RaidFrame.lua:63: in function <FrameXML\RaidFrame.lua:52>
    
    Locals:
    Posted in: AddOn HELP!
  • 0

    posted a message on CompactRaidFrame's protected function call vs various addons
    You are awesome. I will try these.
    Posted in: AddOn HELP!
  • 0

    posted a message on CompactRaidFrame's protected function call vs various addons
    It appears that Shadowed Unit Frames remains the current, consistent addon constantly throwing taint errors based on the taint.log file (it's the only one showing up over over a 6+ hour normal gaming session).

    To give samples:

    10/10 16:11:36.255  An action was blocked in combat because of  taint from ShadowedUnitFrames - CompactRaidFrameManager:originalShow()
    10/10 16:11:36.255      Interface\FrameXML\FrameLocks.lua:90 updateFrameByState()
    10/10 16:11:36.255      Interface\FrameXML\FrameLocks.lua:103 setBaseState()
    10/10 16:11:36.255      Interface\FrameXML\FrameLocks.lua:125 CompactRaidFrameManager:Show()
    10/10 16:11:36.255       Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:88  CompactRaidFrameManager_UpdateShown()
    10/10 16:11:36.255      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:43
    10/10 16:11:36.255  
    10/10 16:11:36.255  An action was blocked in combat because of taint  from ShadowedUnitFrames - CompactRaidFrameManager:SetHeight()
    10/10 16:11:36.255       Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:193  CompactRaidFrameManager_UpdateOptionsFlowContainer()
    10/10 16:11:36.255       Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:92  CompactRaidFrameManager_UpdateShown()
    10/10 16:11:36.255      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:43
    10/10 16:11:36.255  
    10/10 16:11:36.255  An action was blocked in combat because of taint from ShadowedUnitFrames - CompactRaidFrameContainer:Hide()
    10/10 16:11:36.255       Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:515  CompactRaidFrameManager_UpdateContainerVisibility()
    10/10 16:11:36.255       Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:93  CompactRaidFrameManager_UpdateShown()
    10/10 16:11:36.255       Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:43


    Errors like this make up the entirety of the 100kb+ log file and i'm not entirely sure if there's a workaround. Shadowed seems occupied as no one seems to have been able to get a response on issues from him in about a month so i'm not entirely sure if there's a suitable fix (no one's posted one) or a very similar alternative (I like the look, Perl's ugly to me, sorry :x).
    Posted in: AddOn HELP!
  • 0

    posted a message on Shadowed Unit Frames [official]
    It appears that Shadowed Unit Frames remains the current, consistent addon constantly throwing taint errors based on the taint.log file (it's the only one showing up over over a 6+ hour normal gaming session).

    To give samples:

    10/10 16:11:36.255  An action was blocked in combat because of taint from ShadowedUnitFrames - CompactRaidFrameManager:originalShow()
    10/10 16:11:36.255      Interface\FrameXML\FrameLocks.lua:90 updateFrameByState()
    10/10 16:11:36.255      Interface\FrameXML\FrameLocks.lua:103 setBaseState()
    10/10 16:11:36.255      Interface\FrameXML\FrameLocks.lua:125 CompactRaidFrameManager:Show()
    10/10 16:11:36.255      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:88 CompactRaidFrameManager_UpdateShown()
    10/10 16:11:36.255      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:43
    10/10 16:11:36.255  
    10/10 16:11:36.255  An action was blocked in combat because of taint from ShadowedUnitFrames - CompactRaidFrameManager:SetHeight()
    10/10 16:11:36.255      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:193 CompactRaidFrameManager_UpdateOptionsFlowContainer()
    10/10 16:11:36.255      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:92 CompactRaidFrameManager_UpdateShown()
    10/10 16:11:36.255      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:43
    10/10 16:11:36.255  
    10/10 16:11:36.255  An action was blocked in combat because of taint from ShadowedUnitFrames - CompactRaidFrameContainer:Hide()
    10/10 16:11:36.255      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:515 CompactRaidFrameManager_UpdateContainerVisibility()
    10/10 16:11:36.255      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:93 CompactRaidFrameManager_UpdateShown()
    10/10 16:11:36.255      Interface\AddOns\Blizzard_CompactRaidFrames\Blizzard_CompactRaidFrameManager.lua:43


    Errors like this make up the entirety of the 100kb+ log file and i'm not entirely sure if there's a workaround.
    Posted in: Unit Frames
  • 0

    posted a message on CompactRaidFrame's protected function call vs various addons
    Thanks for the suggestion. This method seems to throw in a new addon to the mix as well as the log brings up Shadowed Unit Frames as the candidate for the "first addon mentioned".
    Posted in: AddOn HELP!
  • 0

    posted a message on CompactRaidFrame's protected function call vs various addons
    I just came back to this game about a week ago and in the process did a clean install of most of the addons I used (that I remembered I used anyway) along with my clean reinstall of WoW and a bunch of new ones that seemed popular.

    It seems that any number of them has issues with calling a protected function in Blizzard's CompactRaidFrame. It doesn't seem to be limited to a specific addon. Another user did a quick fix for one of them (PetTracker) since the author seems absent, only to have another one take it's place. It also doesn't seem limited in type of addon or addon that i'd imagine would interact with the raidframe at all (I don't plan to currently raid so the only raid addon I have is DBM which, interestingly, hasn't popped this error).

    It's faulted BugSack, Mapster, Aurora (a generalized UI art addon), PetTracker as mentioned.

    Is there something I can do about this?
    Posted in: AddOn HELP!
  • 0

    posted a message on Shadowed Unit Frames [official]
    Quote from Wolfang
    Is it possible to share profiles across players? Or download others' profiles? I'd be interested in seeing how SUF users have set up their unitframes and possibly share across the user base?

    W


    There's the export function still in there in the SUF layouts. It takes a little bit but spits out a copy and pasteable long batch of text you can send/receive from people and pop into your own SUF to load up the layout.
    Posted in: Unit Frames
  • 0

    posted a message on Shadowed Unit Frames [official]
    Quote from Shadowed
    As long as it doesn't happen on normal use and only after configuration, I'm not too concerned. I'm guessing it's some weird edge case, but if you see it popup again after configuring, just reload.

    If you do notice it happening without having configured the position first, definitely let me know though.


    Thanks for the quick replies. I just wanted to make sure to follow up to note that after quite a few group settings (random queue, battleground, as well as invites) it hasn't cropped up again.
    Posted in: Unit Frames
  • 0

    posted a message on Shadowed Unit Frames [official]
    Quote from Shadowed
    Are you doing any sort of weird anchoring of the party frames? It's using the same system that most every other addon uses for party frames, so if there was a core issue with it, other people would likely see it.

    Also does it happen all of the time?


    It seems to have gone away having upped to the latest alpha. On multiple group runs, I didn't see it crop up again.

    But for reference, when it was occurring it was on v3.6-1-g9a7588a and it occurred every time I was invited into a group. I don't use any special anchor things, i'm actually fairly lazy when it came to setting everything up so I pretty much just had the default grouping and dragged it to the left on my screen and resized it.
    Posted in: Unit Frames
  • 0

    posted a message on Shadowed Unit Frames [official]
    Didn't want to open a ticket since I am not sure if this is how MoP party frames works now (apologize in advance if it is).

    I changed nothing about by SUF party configurations between the patches and when MoP launched since I didn't think anything changed but when I finally entered MoP content and joined a party, the party frame became misaligned. The party leader ended up slightly to the left (and thereby ending slightly offscreen, about half the portrait) while the rest of the party remains docked to the left of the screen so it seemed like the party became subcategories of the party leader, if you will. It was early in the morning when I saw it and I neglected to take a screenshot, apologies if this description is lacking.
    Posted in: Unit Frames
  • 0

    posted a message on Shadowed Unit Frames [official]
    Not sure if this was fixed in one of the 3 alpha pushes since I raided 5 hours ago. Apologies if it was, just wanted to report if it hasn't been caught.

    Was on a hunter and the text for the focus bar would never display the amount of focus I actually had (would always display 100/100 focus).
    Posted in: Unit Frames
  • 0

    posted a message on [Pitbull] Frames move positions when zoning/reloading
    I'm bumping this in hopes of a reply. This is still occurring. I've updated Pitbull to the most recent version and it's driving me nuts (arrr).
    Posted in: Unit Frames
  • 0

    posted a message on [Pitbull] Frames move positions when zoning/reloading
    Apologies if starting a thread isn't kosher. I tried posting in the official Pitbull thread but didn't find a solution (no responses to the post).

    I'm having an issue with party frames and party pet frames on my druid. I don't seem to have this issue with my shaman but I don't play the shaman much in Arenas so zoning constantly isn't really happening. I have my party frame lined horizontally across the top of the screen and party pet frame below it horizontally.

    For some reason, when I zone or reload the game, these bars randomly switch places. The problem is, if I fix them after zoning, when I zone out again, the bars again switch places. Basically, if I zone into an Arena with the bars how I wanted them (party at the top, party pets under), in the Arena, the party pets will now be along the top and the party frame below it. If I fix it inside the Arena (party frame moved back to top and party pets below it), once I zone out, one of two things happens: Either the party pets goes back to the top and the party frame is below it, or they both decide to occupy the same location either both on top of one another at the top or slightly below the top (where i'd put party pets).

    Now it doesn't seem always consistent. Occasionally, the party pet frames will decide to completely move to a location I didn't put them in and arrange itself vertically on the right side of my screen.

    I've tried deleting Pitbull completely and removing all SavedVariables for Pitbull but eventually the problem just suddenly comes back (did a full scan disk + surface area scan in case maybe it was drive corruption). I don't know if it occurs on my hunter or warrior since I don't have party pets showing but i've yet to have it occur on the shaman.

    Also, an unrelated problem, I can't seem to scale the party pets frame because if I change it's scaling, it will also decide to change my party frame scaling with it.
    Posted in: Unit Frames
  • To post a comment, please or register a new account.