• 0

    posted a message on Bag Addon
    Ok, I replaced 'then' with 'do' and get no more errors.

    Still, the bags don't resize, tho. They are at 100%, even if I set 'newScale = 0.1'

    Strange, uh?
    Posted in: Addon Ideas
  • 0

    posted a message on Bag Addon
    Okies, I tried your Addons, but they don't work :(

    \MyAddon.lua:4:'do' expected near 'then'

    (It's line 6 for Matrix110's Version)
    Posted in: Addon Ideas
  • 0

    posted a message on DrDamage - Official Thread
    Are you including Mauls fix for Trinity as well or should we do it by ourselfs?
    Posted in: General AddOns
  • 0

    posted a message on Bag Addon
    O_o this will take some time for me being german... anyway, I'm up for it. Thanks for your help everybody.
    Posted in: Addon Ideas
  • 0

    posted a message on Bag Addon
    Thank you for your fast reply, egingell.

    Sadly I'm not exactly a coding pro, so... where to put this? O_o
    Posted in: Addon Ideas
  • 0

    posted a message on Bag Addon
    I know... there are like dozens around, but none of them can do the most simple thing I can think of:

    I'd like to scale my bags!

    I want to keep 5 seperate, I want them to be docked together, I want them messy, I want the ugly Blizzard Background... I just want to scale them down. Like when you open all your bags + all the bags in your bank - then the game scales them down by itsself.

    Would anybody be up to help me here, please. I'd be pretty happy after 2 years of browsing through Addon Sites.

    Thankies,
    Xamael
    Posted in: Addon Ideas
  • 0

    posted a message on DrDamage - Official Thread
    Concerning Trinity Bars:

    Maul wrote in the comments of his Beta:

    For DrDamage, here is the code needed for beta.28 an on -

    at line124 -
    
       elseif IsAddOnLoaded("TrinityBars") or IsAddOnLoaded("TrinityBars2") then
        ABglobalbutton = "TrinityActionButton"
        ABgetID = function( button )
          if (button.config.type == "spell") then
            return nil, SecureButton_GetModifiedAttribute(button,"spell",SecureStateChild_GetEffectiveButton(button)), button.config.spellrank
          else
            return SecureButton_GetModifiedAttribute(button,"action",SecureStateChild_GetEffectiveButton(button))
          end
        end
    
    
    and at line 1120 (to account for unlimited button count) -
    
      if ABglobalbutton then
        local i = 1
        while (_G[ABglobalbutton..i]) do
          DrD_ProcessButton(_G[ABglobalbutton..i], i, updateSpell, manaUpdate)
          i = i + 1
        end
      elseif CTBar then
        for i, list in pairs(ABtable) do
          DrD_ProcessButton(list.button, i, updateSpell, manaUpdate)
        end
      end


    In order to get spell buttons to work, I had to add some data to the button, which is done in beta.28
    Posted in: General AddOns
  • 0

    posted a message on Parrot 1.0
    SW:D is also shown as outgoing dot in my version... seems to be a bug^^
    Posted in: General AddOns
  • 0

    posted a message on Parrot 1.0
    Thank you for your answer. I had a look at jira, saw 45 open tickets, and as english is not my 1st language, I decided I go ask in forums rather.

    So I keep crossing fingers, thanks for your help, everybody. :)
    Posted in: General AddOns
  • 0

    posted a message on Parrot 1.0
    I had that idea as well... but sadly I can't configure WitchHunt, so that only Aurafades are shown. And even if I could... it would also show when things like MS-Effect fade. Witchhunt is great, but much too spammy imo.

    Somebody did post some pages earlier, how to add dispell effects. If that's possible, shouldn't my request be possible as well?
    Or in other words: is it impossible at all, concerning the lua-files Parrot actually uses, or are the people who could do it simply not up for it?
    Posted in: General AddOns
  • 0

    posted a message on Parrot 1.0
    Nono, it ain't Parrot. In the Vid there is MikScrollingBattleText used.

    What I was asking for is the option "Enemy debuff fade" in the condition menue for triggers. There simply isn't such an option.
    I was trying to "help", as I found out that CHAT_MSG_SPELL_AURA_GONE_OTHER is the one, that parrot would have to look for.

    Then I could make triggers for the skills Sheep and Blind and assign the warnings to a scrollarea.

    But well, as I said... I have no idea, how to change which .lua to create such an option in the candition dropdown menu :(
    Posted in: General AddOns
  • 0

    posted a message on Parrot 1.0
    I hope someone here is willing to help me with my current task:

    I saw in this Vid: http://www.warcraftmovies.com/movieview.php?id=61797 , that the mage has warnings for CC breaks in is MSBT.

    I'd love to have those in Parrot as well, but there is'n an appropriate condition to trigger such an event.

    Me being a total noob to coding found out, that the chatmessage event should be CHAT_MSG_SPELL_AURA_GONE_OTHER, but I dun have a clue what I have to add to which library, to have the triggeroption in Parrot.

    If someone could help me I'd be pretty happy. Thanks in advance,
    Xamael
    Posted in: General AddOns
  • 0

    posted a message on Parrot? Link?
    Just ran SSC.

    Parrot is showing to Hot Water DOT as my outgoing Dot-Damage.
    Posted in: General AddOns
  • 0

    posted a message on [Errors] simple combat log
    I'm getting the following errors in SCL since 2.2:

    [q]2007/09/27 20:40:21-1517-x85]: SimpleCombatLog-1.3.0.48877\opt_gui_filter.lua:164: bad argument #2 to 'format' (string expected, got nil)[/q]

    [q][2007/09/27 20:47:11-1517-x24]: SimpleCombatLog-1.3.0.48877\opt_gui_filter.lua:164: bad argument #2 to 'format' (string expected, got nil)
    AceEvent-2.0-49307 (Ace2):303: in function `TriggerEvent'
    AceEvent-2.0-49307 (Ace2):962: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:955>
    [/q]

    [q][2007/09/27 20:47:44-1517-x1]: SimpleCombatLog-1.3.0.48877\opt_gui_filter.lua:164: bad argument #2 to 'format' (string expected, got nil)
    SimpleCombatLog-1.3.0.48877\opt_gui_filter.lua:164: in function `func'
    SimpleCombatLog-1.3.0.48877\opt_gui_core.lua:80: in function `MenuSettings'
    SimpleCombatLog-1.3.0.48877\opt_gui_core.lua:60: in function <Interface\AddOns\SimpleCombatLog\opt_gui_core.lua:60>
    Dewdrop-2.0-48630 (Cartographer):1883: in function <...AddOns\Cartographer\libs\Dewdrop-2.0\Dewdrop-2.0.lua:1832>
    Dewdrop-2.0-48630 (Cartographer):1894: in function `Refresh'
    AceConsole-2.0-48940 (Ace2):2279: in function <...erface\AddOns\Ace2\AceConsole-2.0\AceConsole-2.0.lua:1549>
    AceConsole-2.0-48940 (Ace2):2389: in function `?'
    Interface\FrameXML\ChatFrame.lua:2980: in function `ChatEdit_ParseText':
    Interface\FrameXML\ChatFrame.lua:2709: in function `ChatEdit_SendText':
    Interface\FrameXML\ChatFrame.lua:2730: in function `ChatEdit_OnEnterPressed':
    <string>:"*:OnEnterPressed":1: in function <[string "*:OnEnterPressed"]:1>
    [/q]

    Does anybody have an idea, what the problem is?

    P.S.: Also since 2.2, I get some strange lines in all versions of SCL: [Unknown] ++ "skillname". This occassionally occurs. Usually with hunters' or paladins' Auras. but only sometimes, not with all hunters or paladins... strange, uh?
    Posted in: General AddOns
  • 0

    posted a message on New Cartographer Error just showing up tonight (09-17-2007)
    I'm getting another error with the newest version:

    \Interface\AddOns\Cartographer\libs\Roster-2.1\Roster-2.1.lua:18:Roster-2,1 requires AceOO-2,0

    I'm using the newest Ace2 libs and the german client (in case this matters)
    Posted in: Map/Minimap AddOns
  • To post a comment, please or register a new account.