• 0

    posted a message on GemList
    Quote from Djoker »

    Quote from Starfox »

    GemList stopped to notice new gems.
    /gemlist show does not show them.
    Tried with autoscan and /gemlist scan with jewelcrafting window open.


    Same to me. I had to reinstall my interface and the database is still empty. What can i do? :(
    Seems that the author has converted it to 2.1 without leaving it compatible with 2.0. For now, your best bet is to grab an older version from http://files.wowace.com/GemList/
    Posted in: General AddOns
  • 0

    posted a message on Quartz: Modular Casting Bar
    Quote from imarkon »

    sorry if i'm boring but focus and global cd don't work yet ;P
    Got any errors?
    Quote from ennui »

    I'm getting the following error when logging in:

    [2007/05/16 17:42:23-1992-x1]: Quartz_TradeskillMerge\TradeskillMerge.lua:68: AceHook-2.1: Attempt to hook secure method "UNIT_SPELLCAST_START". Use `SecureHook' or add `true' to the argument list to override.
    AceAddon-2.0-31981 (Ace2):601: in function `InitializeAddon'
    AceAddon-2.0-31981 (Ace2):455: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:432>
    <in C code>: ?
    AceEvent-2.0-35519 (Ace2):324: in function `TriggerEvent'
    AceEvent-2.0-35519 (Ace2):1025: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:1018>
    <in C code>: in function `LoadAddOn'
    Quartz-0.1.0.35541\Quartz.lua:144: in function <Interface\AddOns\Quartz\Quartz.lua:129>
    <in C code>: in function `pcall'
    AceAddon-2.0-31981 (Ace2):24: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:23>
    AceAddon-2.0-31981 (Ace2):698: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:675>
    <in C code>: ?
    AceEvent-2.0-35519 (Ace2):255: in function `TriggerEvent'
    AceEvent-2.0-35519 (Ace2):1025: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:1018>

    My tradeskill merging (which I love!) no longer works. Disabling and enabling the module causes the same error.
    The first one is likely due to the fact that the directory for the tradeskill module got renamed, delete the "Quartz_TradeskillMerge" directory and make sure the "Quartz_Tradeskill" directory is there to replace it. But the second one doesn't make any sense.. try resetting your savedvariables.
    Quote from Gregory »

    I'm not sure but it seems something wrong with latency modules and spell hasting. When my Quag Eye proc I always get very big latency prediction and often get interrupts if trust it. So is it just me unlucky or there is some error with latency and spell haste ?
    I've noticed it some times and not others when I get spell speed procs. I'll do some checking into if the events are firing in the wrong order or what.
    Quote from iceheat710 »

    not sure if it's just me, but everytime i relog, i have to go in the options menu and re-disable the default blizzard casting bar =\
    It's likely another addon re-enabling it after Quartz disables it (ag_uf is one possible culprit). I'll see if I can do something about it :)
    Posted in: General AddOns
  • 0

    posted a message on Quartz: Modular Casting Bar
    Quote from SoLoR »

    Quote from Radon »

    1 more thing, latency module doesnt work for tradeskill anymore
    Who needs latency at tradeskills? I doubt you use a /stopcasting makro for tradeskills ;p


    noone :) just mentioned couse i didnt know if it was intented or not :)
    I turned that off because it didn't make much sense when your cast bar for a single item was far smaller than the lag bar ;)
    Posted in: General AddOns
  • 0

    posted a message on Quartz: Modular Casting Bar
    Quote from Radon »

    Very nice addon Nymbia :)

    I have a small request:
    Could you add an offset to the name text, that positions it a bit off its anchor?
    I thought of a slider (like the one for gaps) with values from -10 to +10.
    Will do. :)

    And a bug with tradeskill merge:
    Quote from SoLoR »

    player/tradeskill merge module doesnt go well together since recently, it seems like everytime you are making "stacks" total time from that tradeskill gets inherited to all other casts later (since its same bar anyway), reloadui fix it tho...
    Yep.
    If you cast a tradeskill and then cast a non tradeskill cast after it, the castbar buggs and shows a far too big casting time for the non tradeskill cast...

    This is where the castingbar normally should be (and is before tradeskill cast)


    And this is where the castbar is after I casted one heavy runecloth bandage (when I cast all bandages its far more to the left)


    1 more thing, latency module doesnt work for tradeskill anymore
    Who needs latency at tradeskills? I doubt you use a /stopcasting makro for tradeskills ;p
    Fixed, thanks! The screenshots helped a lot :)
    Posted in: General AddOns
  • 0

    posted a message on help with itemrack
    Gello doesn't come anywhere near this website. If you want help with his addons, you're much more likely to get it posting on wowinterface.
    Posted in: General Chat
  • 0

    posted a message on Bandwidth monitoring
    Well, as far as bandwidth usage goes, you're getting the downstream messages always, regardless of if you have the addon that receives those comms.
    Posted in: Addon Ideas
  • 0

    posted a message on Quartz: Modular Casting Bar
    Well, I can't for the life of me figure out why it's throwing that error in particular. But the main problem I see is that that module's folder was renamed "Tradeskill" so that it'd work with the new LoD system properly.

    I threw a folder in with an empty toc that should have been unpacked by WAU over the current one, deleting it. I'm not sure what went wrong there, but for now, just delete the Quartz_TradeskillMerge folder manually.

    The only way that the SetScale error could be occurring is if the Player module wasn't loaded.. I'm confused :(
    Posted in: General AddOns
  • 0

    posted a message on Quartz: Modular Casting Bar
    Quote from ffcloud2000 »

    still getting these errors.. im not sure if they changed.. but i deleted the SV to start fresh after updating again but no go :(


    [2007/05/15 19:18:56-2140-x1]: Quartz_TradeskillMerge\TradeskillMerge.lua:67: AceHook-2.1: Attempt to hook secure method "UNIT_SPELLCAST_START". Use `SecureHook' or add `true' to the argument list to override.
    AceAddon-2.0-31981 (Ace2):601: in function `InitializeAddon'
    AceAddon-2.0-31981 (Ace2):455: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:432>
    <in C code>: ?
    AceEvent-2.0-35519 (Ace2):324: in function `TriggerEvent'
    AceEvent-2.0-35519 (Ace2):1025: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:1018>
    <in C code>: in function `LoadAddOn'
    Quartz-0.1.0.35541\Quartz.lua:144: in function <Interface\AddOns\Quartz\Quartz.lua:129>
    <in C code>: in function `pcall'
    AceAddon-2.0-31981 (Ace2):24: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:23>
    AceAddon-2.0-31981 (Ace2):698: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:675>
    <in C code>: ?
    AceEvent-2.0-35519 (Ace2):255: in function `TriggerEvent'
    AceEvent-2.0-35519 (Ace2):1025: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:1018>

    ---

    [2007/05/15 19:18:56-2140-x1]: Quartz_Mirror\Mirror.lua:395: Usage: <unnamed>:SetScale(scale)
    AceAddon-2.0-31981 (Ace2):601: in function `InitializeAddon'
    AceAddon-2.0-31981 (Ace2):455: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:432>
    <in C code>: ?
    AceEvent-2.0-35519 (Ace2):324: in function `TriggerEvent'
    AceEvent-2.0-35519 (Ace2):1025: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:1018>
    <in C code>: in function `LoadAddOn'
    Quartz-0.1.0.35541\Quartz.lua:144: in function <Interface\AddOns\Quartz\Quartz.lua:129>
    <in C code>: in function `pcall'
    AceAddon-2.0-31981 (Ace2):24: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:23>
    AceAddon-2.0-31981 (Ace2):698: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:675>
    <in C code>: ?
    AceEvent-2.0-35519 (Ace2):255: in function `TriggerEvent'
    AceEvent-2.0-35519 (Ace2):1025: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:1018>

    ---
    Did you close and re-open wow after updating?
    Posted in: General AddOns
  • 0

    posted a message on Quartz: Modular Casting Bar
    The second one is definitely fixed, and the second makes no sense at all.. Update and see if they still occur.
    Posted in: General AddOns
  • 0

    posted a message on Quartz: Modular Casting Bar
    The backup spell is there in case the primary spell's school is interrupted -- just put one holy spell and one shadow spell in there, and you'll get a GCD display as long as you don't have both schools interrupted.

    BTW, I recently made a number of changes to structure to make things work better in the long run; the drawback is that you'll lose settings related to the player casting bar (positioning etc). There might also be some new bugs, just post any and I'll get 'em fixed ASAP.
    Posted in: General AddOns
  • 0

    posted a message on ItemPrice-1.0
    I'd say it'd be fine to implement GetSellValue globally in the library, as long as you make sure to upgrade it if/when the lib is upgraded.
    Posted in: Libraries
  • 0

    posted a message on Quartz: Modular Casting Bar
    Quote from Rollibock »

    I went on disabling add-ons, and ag_UnitFrames seems to be the "trouble-maker". I can't find the proper option in config, but disabling it also let disappear the "ghost bar". Screenshot attached!
    Great, I'll take a look. Thanks!
    Quote from fred »

    Quote from Rollibock »

    I went on disabling add-ons, and ag_UnitFrames seems to be the "trouble-maker". I can't find the proper option in config, but disabling it also let disappear the "ghost bar". Screenshot attached!


    I was seeing that before Quartz, and using other casting bar mods. What causes it, the casting bar mod NOT suppressing it?
    More likely than not, it's re-registering the casting bar events after quartz unregisters them.
    Quote from Abula »

    Thanks for adding mirror bar.

    Just reporting and error

    Error: attempt to perform arithmetic on local 'timeout' (a nil value)
    File: Interface\AddOns\Quartz\Mirror.lua
    Line: 218
    Count: 1

    This has happen twice, in different events.

    1) While i wasnt in a group in 5man instance, and the blizzard timmer of zoneing out started.
    2) While i was dead in AV and i was a ghost waiting for res timmer.

    Thanks again for the great casting bar.
    The line numbers changed so I had to guess which line caused the error, but it should be fixed. If not, it should print a more helpful error :)
    Quote from Jagobah »

    Hello nymbia,

    I like this mod, and it makes me think of Quartz crystals :)

    But I get this bug when I try and use my Salt Shaker:

    [2007/05/14 19:27:34-1372-x2]: Quartz-0.1.0.35337\TradeskillMerge.lua:81: attempt to perform arithmetic on upvalue 'repeattimes' (a nil value)


    No bar is shown !! I had to disable tradeskill merge to make the bar show. It's 25 seconds to shake some salt, btw :)
    Hrm, let me know if the latest commit fixed that, if not, I'll have to hijack a character with leatherworking.
    Posted in: General AddOns
  • 0

    posted a message on Quartz: Modular Casting Bar
    Quote from Rollibock »

    Quote from Saynt »

    [...] When I toggle Blizz bar on/off it goes away, but I have to do that for each login.


    I have the same problem as dicribed from Saynt. After every log-in or console-reload, the blizzard cast bar is enabled, no matter what I choose as option in Quartz. I tried to find another addon with cast bar-hiding options; OmniCC, Healbot, Chronometer, Bartender and ag_UnitFrames were my first suspects, but I can't find any en-/disabling option in configuration windows. What ca I do next? Any hints?

    Anyhow, Quartz is in my opinion the best cast bar at the moment. Thanks for your efforts Nymbia!
    Would you mind grabbing a screenshot of the bug as well? Thanks! :)
    Posted in: General AddOns
  • 0

    posted a message on Quartz: Modular Casting Bar
    Quote from N00bZXI »

    Request:

    Allow mirror bars to be unlocked and positioned freely, and allow all the other bars to be attached to each other.
    That's the plan! ;) (give it a day or so, though; I've got work until late-ish tonight then we've gotta catch up on a few 5v5 games)
    Quote from Saynt »

    Quote from Nymbia »
    Huh. Could you grab a screenshot?

    Yeah, I know it didn't make sense...this is what I'm talking about. I've dumped savedvariables and it still occurs. When I toggle Blizz bar on/off it goes away, but I have to do that for each login.


    That's odd.. that looks like it's the blizzard frame, except with a modified texture and font size. Maybe it's another cast bar addon?
    Quote from sun »

    how can i disable the aoe rez timer, etc ?

    /quartz -> Mirror -> scroll down and uncheck 'Show Static'
    Posted in: General AddOns
  • 0

    posted a message on Quartz: Modular Casting Bar
    Quote from st0nedpenguin »

    I could just be missing an option somewhere, but is there a way to enable a border for the mirror bars?
    Not yet ;)
    Quote from Saynt »

    Quote from Nymbia »

    Grab current and let me know if summoning is working. If it's not, mind posting a new error (with the new line number)?

    No errors :)

    On another note, sorry I didn't include previously... when I first log in, and cast something a 2nd cast bar appears below the Quartz one, I assume this is part of the Blizzard one as once I toggle it on/off it no longer appears. I also assume it is related to the Blizzard cast bar because upon successful spell cast the 'flash' looks like the blizzard bar.
    Huh. Could you grab a screenshot?
    Posted in: General AddOns
  • To post a comment, please or register a new account.