• 0

    posted a message on VendorSearch - Adriweb
    New version : 1.98

    Version 1.98 -new features + debug- :
    -Changed the first textfield for the type to a drop down list
    -Auto-refresh when you change page
    -Removed the Refresh button since there is no need to refresh in any case
    -Bugs removed
    -Clearer help
    -Better About
    Posted in: General AddOns
  • 0

    posted a message on VendorSearch - Adriweb
    So, for the bugs you guys encountered, it's all corrected in the latest release.... and everything works (filters...).

    And, actually, it searches only on the current page, but when you change page, you just have to press "refresh" and that's it ...

    I plan on [re]making a frame where only the results of all the pages are combined...

    It's going to be hard tho :/
    Posted in: General AddOns
  • 0

    posted a message on Curse Down (for updates) ?
    apparently, it's back ... well my project has been updated so... :D
    Posted in: General Chat
  • 0

    posted a message on Curse Down (for updates) ?
    I've an non-habitual upload delay (8 hours, so much more than 25 minutes, as it would be normally) on the new version of my addon (VendorSearch), and I was wondering if it is due to the update of the packager to the 3.0.8 version.

    Is that it ?

    What is weird, tho, is when I download the file from WoWAce directly, it's already been packaged and everything by Curse packager, apparently, because the ".toc" file has been changed with Curse's tags added.

    And I also noticed that the last updated addons were all updated at the same time.

    Actually I also noticed that my wowace project is like not "linked" anymore to curse's page. Or in appearence, because the description doesn't get updated neither ...

    Maybe Curse updates process are down ?

    Something is definitely going on on Curse lol

    Thanks to tell me what's happening ! :D
    Posted in: General Chat
  • 0

    posted a message on VendorSearch - Adriweb
    Updated to version 1.9 :D


    Changelog :

    -Added the filters ! You can search by name, type, subtype, price <, price >, rarity
    -Help is much better
    -Options reorganized
    -More options : change your opacity % when you are on opacity-hiding, sliders
    -Refresh button
    -Better layout



    Posted in: General AddOns
  • 0

    posted a message on Slider with AceConfig3
    All right, it works :D

    Thanks guys !
    Posted in: AddOn HELP!
  • 0

    posted a message on Slider with AceConfig3
    Oh, that's just a little part of the code !
    All my addon is made with Ace3, so I have everything configured and working, except that when I put the lined that I posted, in order to have a slider, it doesn't work ;)

    Thanks for the links :D
    Posted in: AddOn HELP!
  • 0

    posted a message on Slider with AceConfig3
    Hey,

    I'm having a little trouble displaying a slider with AceConfig3...

    That code is supposed to be correct, according to the documentation ...

    				Slider1 = {
    	     			type = "range",
    	     			min = "0",
    	     			max = "1",
    	     			step = "0.05",
    					set = "ToggleSlider1",
    					get = "IsSlider1",
    				},


    It doesn't work...

    Any ideas ?

    Thanks !
    Posted in: AddOn HELP!
  • 0

    posted a message on Different Merchant's Items slots...
    :P

    btw, it's kinda working now, and I've added a "refresh" button too ;)
    Posted in: AddOn HELP!
  • 0

    posted a message on VendorSearch - Adriweb
    Thanks for the comments and bug reports.

    Yes, if there are errors but it still works, it's just weird o_O.

    Works fine for me and testers...

    So, yeah, i'll put a slider for the alpha :D

    And the version 1.7 has an option for hiding non-buyable items and non-usable items too :D

    Posted in: General AddOns
  • 0

    posted a message on Different Merchant's Items slots...
    thanks for that trick, that will help if I don't find any way to make it work with an automatic refresh...
    Posted in: AddOn HELP!
  • 0

    posted a message on Different Merchant's Items slots...
    (sorry, wrong forum... can a moderator move it to Addon Help ?)


    Now I have a problem in my addon VendorSearch....

    Blizzard apparently changed the way the MerchantFrames work from 2.4.3 to 3.0 ...

    Before, the items in a slot had a unique number, for each one of them. Now, the numbers are resetted each page ..



    So if I want to hide the slot number 2, I can write :

    /script MerchantItem2:Hide()

    That works for the Item2 in 2.4.3

    In 3.0.*, all the items in the second slot *of any pages* will be hidden...

    And I would have done MerchantItem12:Hide() for the 2nd slot of the 2nd page, in 2.4.3, in a lua script.
    But in 3.0 that doesn't work at all... because Blizzard set the max number to 10, and then it's the other page.

    But what's even more weird, it is that when I want some info about a specific item, the way it works in 2.4.3 with IDs > 10 works in 3.0.3 too !

    Example : /script GetMerchantItemInfo(12)
    that works in both version of the game !
    Even if the Item 12 doesn't refer to any particular item in version 3.0.3 because 10 is the limit, then it changes page....


    That same ID for different items is really bad for my addon

    Anybody can help me ?
    Posted in: AddOn HELP!
  • 0

    posted a message on VendorSearch - Adriweb
    updated for version 1.5 :D


    oops, my image is like 15 pixels over the size of that html frame ><
    Posted in: General AddOns
  • 0

    posted a message on VendorSearch - Adriweb
    thanks :D
    Posted in: General AddOns
  • 0

    posted a message on VendorSearch - Adriweb
    Someone interested ?

    ;)
    Posted in: General AddOns
  • To post a comment, please or register a new account.